[LON-CAPA-users] EXT question

Ray Batchelor lon-capa-users@mail.lon-capa.org
Wed, 13 May 2009 07:23:46 -0700

Not sure what you are doing...
When I refer to "RAT", I mean the "Advanced Edit" mode for editing a
sequence in CSTR.

I just now, tried this out again and it works.

1) created a new assembled sequence in CSTR
2) clicked on it and selected "Simple Edit"
3)Imported a couple of problem resources.
5)clicked on "Advanced Edit".
6)clicked on the resource holder to which I want to apply an alias.
7)clicked on "Set Parameters"
8)located the parameter "Resource alias name for conditions [Part: 0]
9)typed a string of text into the "Value" vield
(in this example I entered "A" as my alias for the resource).
10) clicked on "Enter" link
11) in new popup clicked "Save"
(I realize there may be some redundancy in steps 9-11, but I am
describing what just worked...)
12) checked the box "Set?" for this parameter.
13) scrolled to the bottom of the form and clicked "Set" button.

14) Clicked "Save map and layout".

If I then publish this sequence and import it into my course, I can
then use the expression below (in any other published resource
included in the course)


to retrieve the current submission for part id="11" and response
id="12" for the aliased resource.

This works fine for me here.

I hope that your LON-CAPA installation can reproduce this?

If I bother to look in my published sequence file I see the xml:
<param to="1" value="A" name="parameter_0_mapalias" type="string" />
for what that's worth.  However, I never do so, because the procedure
above seems to work fine for me.

One final observation: once  "Advanced Edit"  has been used to save
this sequence including the map alias parameter, then I am no longer
allowed to use the "Simple Edit" option, but only see an "Edit" button
for this sequence, which opens the advanced edit mode.

If this does not work for you, then... "over to Stuart".

Good luck,

On Wed, May 13, 2009 at 6:21 AM,  <Robert_Brewington@er.monroe.edu> wrote:
> Wow, this is getting worse by the moment.
> When I run RAT, it doesn't allow me to import anything. In the import
> process I can select resoources, it gets to the screen where I can re-order
> the resources, but the "Finish Import" button does nothing.
> I used the simple editor to put two resources into the sequence. The I ran
> RAT hoping to set the mapalias parameter. There seems to be no editing
> capability? I can see a list of metadata (the <m> link), which refers to the
> mapalias but gives no ability to edit. There is a ? link which runs the
> resource. Clicking on the arrows between the two resources does nothing
> (used to bring up the decision editing block).
> Saving the map then deleted all the resources and left me with an empty
> map:(
> So, RAT doesn't seem to want to let me do anything. I tried setting the
> mapalias directly in the first problem, making up the statement
> <parameter name="mapalias" id="110" default="MyBusProblem"
> type="string_mapaliastype" description="mapalias" />
> which did not work, not surprising since I am making up statements:)
> I have previously set the mapalias to "BusProblem" using the Parameter
> Setting screen for the first problem. As Ray indicated, the second problem
> is not able to find the submission to the first problem.
> Any other clues? Stuart, et al have any suggestions?
> Thanks,
> brew
> _______________________________________________ LON-CAPA-users mailing list
> LON-CAPA-users@mail.lon-capa.org
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-users

Raymond J. Batchelor, Ph.D.
Department of Chemistry
Simon Fraser University
Burnaby, BC
V5A 1S8