[LON-CAPA-dev] Fedora only: LONCAPA prerequisites rpm and yum
Tue, 31 Aug 2004 16:59:59 -0700
On Tue, Aug 31, 2004 at 07:00:46PM -0400, Guy Albertelli II wrote:
> Hi Martin,
> > would it be possible to get a list of the LONCAPA prerequisites,
> >From the .spec file:
> apache o
> gd *
> perl-GD *
> perl-GD-Barcode o
> perl-GDGraph *
> perl-GD-Graph3d *
> perl-GDTextUtil *
> gnuplot *
> ImageMagick *
> ImageMagick-perl o
> perl-suidperl o (do I really need this?)
> mod_perl_1 o
> mysql *
> mysql-server *
> perl-DBD-MySQL *
> perl-DBI *
> perl-Algorithm-Diff *
> perl-Authen-Krb4 o
> perl-Authen-Krb5 o
> perl-Authen-PAM o
> perl-Crypt-DES *
> perl-Crypt-IDEA o
> perl-Crypt-SSLeay *
> perl-Event *
> perl-HTML-Tree *
> perl-IO-Socket-SSL *
> perl-IO-stringy *
> perl-MailTools *
> perl-Math-Cephes o
> perl-Math-FFT o
> perl-Math-Random o
> perl-Net-PH o
> perl-Net-SNPP * (assuming this is perl-Net-SNMP?)
> perl-Net-SSLeay *
> perl-OLE-Storage_Lite o
> perl-Parse-RecDescent *
> perl-Pod-POM o
> perl-PostScript-Simple *
> perl-Safe-Hole o
> perl-Spreadsheet-WriteExcel *
> perl-String-Similarity o
> perl-Text-Aspell o
> perl-Text-Query o
> perl-TimeDate *
> perl-Time-HiRes o
> aspell *
> perl-MIME-Lite *
> perl-MIME-Types *
This does not look too bad: * means included with SuSE-9.1, o means missing.
> Requires: apache <= 2.0
> Requires: perl-HTML-Parser = 3.36-2.loncapa
> Conflicts: httpd php mod_throttle mod_bandwidth
> Conflicts: mod_perl
Does this mean apache < 2.0 or would something like apache-2.0.49 actually
work? How do you actually fulfill that requirement under Fedora 2?
There is no apache package ...
Do you have a src.rpm of this package. I'd like to rebuild it.
> > in particular, the list of rpm packages that need to be installed?
> > Anything else that is done differently compared to RH 7.3?
> No differences except for the list of rpms that is to be installed.
> > Background:
> > I'd like to install LONCAPA on a SuSE-9.1 box (new access server).
> > The main components (2.6 kernel, apache2) seem to be similar to
> > Fedora 2.
> Note that apache 2 and mod_perl 1.99_X _DO_NOT_ work correctly
This means that I better build something like apache-1.3.28 and
mod_perl-1.28 myself? (should not be difficult: I would just rebuild
the SuSE-9.0 rpms - SuSE-9.0 still has apache-1 support).
> We have custom built mod_perl 1.2X to work under Fedora (Mainly you
> need to be running perl 5.8.3 for it to work)
SuSE-9.1 has perl-5.8.3.
> Thus the mod_perl_1 package above, and the conflicts with apache
> greater than 2.
> We also have customized the build of
> - perl-Authen-Krb4
> - perl-HTML-Parser
SuSE-9.1 has perl-HTML-Parser-3.35, SuSE-9.0 has perl-HTML-Parser-3.28.
Would either of the two work or should I rebuild your
I guess I do not need perl-Authen-Krb4, if I do not use kerberos?
> We also suggest gnuplot 4.0 since with that we move away from needing
> gif support in GD or anywhere else.
Did you build gnuplot-4.0 from source or do you have a rpm for that as well?
> The rest of the CPAN modules rpms are builds straight from CPAN.
One more question: Is there a way to completely uninstall loncapa from a
machine? I'd like to start from scratch once more ...