[LON-CAPA-admin] Versioning issues for resources

Gerd Kortemeyer korte at lite.msu.edu
Sat Aug 21 14:52:17 EDT 2010


On Aug 21, 2010, at 2:42 PM, Mark Lucas wrote:
> I've got a course that I cloned from last spring that is giving the following error on about 6 different
> resources when re-initializing:
> Version discrepancy: resource /res/ohiou/OUp250lib/electric_charge/hr4ed2305t.problem included in both version mostrecent and version 3. Using version mostrecent.

Yes, the new version of LON-CAPA now detects this error.

> The instructor has been working around in the course for a little while. I've recently tried setting everything
> to most recent version. I've also tried setting everything to the current version.
> I think I saw this before on a previous course.
> Has anyone seen this, does anyone have suggestions as to what is causing it and any
> suggestions on how to fix it?

First of all, it's a warning, not an error. Students will not see it. The action of using "most recent" is likely appropriate.

> Where is versioning information stored for the course? Resourceversions? Anywhere else?

It could be hard-coded into published sequences, too. If you want me to have a look, make me a CC.

- Gerd.

More information about the LON-CAPA-admin mailing list