[LON-CAPA-admin] problem with exam upload in DOCS

Nathan Schoenack nathan.schoenack at NDSU.EDU
Wed Sep 21 17:11:09 EDT 2005


I've got a very strange problem.  I imported a published document (an  
exam upload problem) into DOCS in the Main Course Documents area.  I  
uploaded the scores without any problems.  Then the professor for  
which I was doing this found 3 errors in the key he used to correct  
the problem.  So, I figured what I'd do was to make a new problem  
(exam upload type again), and then upload the corrected scores to  
this problem.

However, when I remove the problem from DOCS (or hide it) and import  
the new problem it won't show up in the NAV menu--all I see is the  
old problem (even after deleting the folder and problem).  But it is  
definitely visible if I go through the DOCS menu.  While in DOCS if I  
click on the new problem I get a message:

LON-CAPA Access Control

Access  : Browse resources
Resource: /res/ndsu/physics/ExamUpload/ 
Action  : Invalid Access

What's really irritating/confusing me is that if I log in as a  
student I can see the new problem in my NAV menu, but when I click on  
it I get the same error message as shown above.

I've tried:
1. Re-initializing the course after every time I delete the problem  
and if I import the new one
2. A different browser (same behavior with Firefox or Safari)
3. Re-publishing the problem.

I feel I should mention that, for this new problem I wrote to upload  
the corrected test scores, I just copied and pasted the XML  
code...but the problem has a different name  
(Exam1_Scores_PHYS211.problem vs.  
Exam1_Scores_PHYS211_corrected.problem).  I also should mention that  
if I click on the old problem I don't get a PGRD button in my remote.

I'm thoroughly confused and would greatly appreciate any help.  It's  
driving me nuts.

Nathan Schoenack
IT Research Support Specialist
NDSU Physics
(701) 231-7047
nathan.schoenack at ndsu.edu

More information about the LON-CAPA-admin mailing list