[LON-CAPA-users] EXT question

loncapa_admin lon-capa-users@mail.lon-capa.org
Wed, 13 May 2009 22:37:11 -0400

Robert... thanks for pointing out the popup requirement for the RAT.  I didn't even realize I had my browser set to block them.  Seems to work now, and I'm feeling a little dumb for not thinking about this.  You've definitely saved me piles of time trying to sort it out this summer.  I was convinced this was some cross-platform issue.

Thanks again.

Michael Dugdale
Department of Physics
John Abbott College
21275 Lakeshore Road
Ste. Anne de Bellevue, Québec
H9X 3L9

(514) 457-6610 X 5888
From: lon-capa-users-admin@mail.lon-capa.org [lon-capa-users-admin@mail.lon-capa.org] On Behalf Of Robert_Brewington@er.monroe.edu [Robert_Brewington@er.monroe.edu]
Sent: May 13, 2009 21:20
To: lon-capa-users@mail.lon-capa.org
Subject: Re: [LON-CAPA-users] EXT question

Ah, found my first problem - Firefox was blocking popups. The RAT needs popups to work... So now I am seeing the screens Ray suggests.

So now I have set the mapalias parameter in four different places, in hopes of one working:

In WholeThing.sequence, I named the mapalias "A" for Part 0. I think this is the one Ray indicates should work.

Just for fun, I also set "B" to point to parameter_inputMass_mapalias, the mapalias for the particular part id="inputMass".

I set mapalias in the published First  problem to be "C". Ray has indicated that this will not work, but just trying to be thorough...

I also randomly tried to set the parameter in the part id=inputMass problem directly with
<parameter name="mapalias" id="110" default="D" type="string_type" description="mapalias" />. Interestingly, this seems to override the 'B' I set in the sequence.

Now, in Second.problem I have:

$v1 = &EXT('user.resource.resource.inputMyMass.myMass.submission', &EXT("A"));  # Ray says should work
$v2 = &EXT('user.resource.resource.inputMyMass.myMass.submission', &EXT("B"));
$v3 = &EXT('user.resource.resource.inputMyMass.myMass.submission', &EXT("C"));  # Ray indicates will not work
$v4 = &EXT('user.resource.resource.inputMyMass.myMass.submission', &EXT("D"));

Ray's note indicates that $v1 should get filled in (the value retrieved from First Problem should be 115).

I published First.problem, Second.problem, and WholeThing.sequence, imported all three into the course, and re-initialized the course.

I never see any of the variables v1-v4 in Second.problem filled in, either by

1) running the resources directly. Run First.problem followed by Second.problem. Don't think this is expected to work, but checking.


2) running the sequence WholeThing, filling in the value for First.problem, then moving to Second.problem.

So, I am still missing something. I removed the "B", "C" and "D" settings to try and get exactly what Ray suggests, with no change. Don't know what I am doing different from Ray.

I am running on the educog machine, which the login screen says is 2.7.1.

Getting somewhat closer,
-----lon-capa-users-admin@mail.lon-capa.org wrote: -----

To: lon-capa-users@mail.lon-capa.org
From: Ray Batchelor <batchelo@sfu.ca>
Sent by: lon-capa-users-admin@mail.lon-capa.org
Date: 05/13/2009 10:23AM
Subject: Re: [LON-CAPA-users] EXT question

Not sure what you are doing...
When I refer to "RAT", I mean the "Advanced Edit" mode for editing a
sequence in CSTR.

I just now, tried this out again and it works.

1) created a new assembled sequence in CSTR
2) clicked on it and selected "Simple Edit"
3)Imported a couple of problem resources.
5)clicked on "Advanced Edit".
6)clicked on the resource holder to which I want to apply an alias.
7)clicked on "Set Parameters"
8)located the parameter "Resource alias name for conditions [Part: 0]
9)typed a string of text into the "Value" vield
(in this example I entered "A" as my alias for the resource).
10) clicked on "Enter" link
11) in new popup clicked "Save"
(I realize there may be some redundancy in steps 9-11, but I am
describing what just worked...)
12) checked the box "Set?" for this parameter.
13) scrolled to the bottom of the form and clicked "Set" button.

14) Clicked "Save map and layout".

If I then publish this sequence and import it into my course, I can
then use the expression below (in any other published resource
included in the course)


to retrieve the current submission for part id="11" and response
id="12" for the aliased resource.

This works fine for me here.

I hope that your LON-CAPA installation can reproduce this?

If I bother to look in my published sequence file I see the xml:
<param to="1" value="A" name="parameter_0_mapalias" type="string" />
for what that's worth.  However, I never do so, because the procedure
above seems to work fine for me.

One final observation: once  "Advanced Edit"  has been used to save
this sequence including the map alias parameter, then I am no longer
allowed to use the "Simple Edit" option, but only see an "Edit" button
for this sequence, which opens the advanced edit mode.

If this does not work for you, then... "over to Stuart".

Good luck,

On Wed, May 13, 2009 at 6:21 AM,  <Robert_Brewington@er.monroe.edu> wrote:
> Wow, this is getting worse by the moment.
> When I run RAT, it doesn't allow me to import anything. In the import
> process I can select resoources, it gets to the screen where I can re-order
> the resources, but the "Finish Import" button does nothing.
> I used the simple editor to put two resources into the sequence. The I ran
> RAT hoping to set the mapalias parameter. There seems to be no editing
> capability? I can see a list of metadata (the <m> link), which refers to the
> mapalias but gives no ability to edit. There is a ? link which runs the
> resource. Clicking on the arrows between the two resources does nothing
> (used to bring up the decision editing block).
> Saving the map then deleted all the resources and left me with an empty
> map:(
> So, RAT doesn't seem to want to let me do anything. I tried setting the
> mapalias directly in the first problem, making up the statement
> <parameter name="mapalias" id="110" default="MyBusProblem"
> type="string_mapaliastype" description="mapalias" />
> which did not work, not surprising since I am making up statements:)
> I have previously set the mapalias to "BusProblem" using the Parameter
> Setting screen for the first problem. As Ray indicated, the second problem
> is not able to find the submission to the first problem.
> Any other clues? Stuart, et al have any suggestions?
> Thanks,
> brew
> _______________________________________________ LON-CAPA-users mailing list
> LON-CAPA-users@mail.lon-capa.org
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-users

Raymond J. Batchelor, Ph.D.
Department of Chemistry
Simon Fraser University
Burnaby, BC
V5A 1S8
LON-CAPA-users mailing list

_______________________________________________ LON-CAPA-users mailing list LON-CAPA-users@mail.lon-capa.org http://mail.lon-capa.org/mailman/listinfo/lon-capa-users