[LON-CAPA-users] EXT question

lon-capa-users@mail.lon-capa.org lon-capa-users@mail.lon-capa.org
Wed, 13 May 2009 21:20:43 -0400

<div>Ah, found my first problem - Firefox was blocking popups. The RAT need=
s popups to work... So now I am seeing the screens Ray suggests.<br><br>So =
now I have set the mapalias parameter in four different places, in hopes of=
 one working:<br><br>In WholeThing.sequence, I named the mapalias "A" for P=
art 0. I think this is the one Ray indicates should work.<br><br>Just for f=
un, I also set "B" to point to <tt>parameter=5FinputMass=5Fmapalias, the ma=
palias for the particular part id=3D"inputMass".<br><br></tt>I set mapalias=
 in the published First&nbsp; problem to be "C". Ray has indicated that thi=
s will not work, but just trying to be thorough...<br><br>I also randomly t=
ried to set the parameter in the part id=3DinputMass problem directly with<=
br>&lt;parameter name=3D"mapalias" id=3D"110" default=3D"D" type=3D"string=
=5Ftype" description=3D"mapalias" /&gt;. Interestingly, this seems to overr=
ide the 'B' I set in the sequence.<br><br>Now, in Second.problem I have:<br=
><br>$v1 =3D &amp;EXT('user.resource.resource.inputMyMass.myMass.submission=
', &amp;EXT("A"));&nbsp; # Ray says should work<br>$v2 =3D &amp;EXT('user.r=
esource.resource.inputMyMass.myMass.submission', &amp;EXT("B"));&nbsp; <br>=
$v3 =3D &amp;EXT('user.resource.resource.inputMyMass.myMass.submission', &a=
mp;EXT("C"));&nbsp; # Ray indicates will not work<br>$v4 =3D &amp;EXT('user=
.resource.resource.inputMyMass.myMass.submission', &amp;EXT("D"));<br><br>R=
ay's note indicates that $v1 should get filled in (the value retrieved from=
 First Problem should be 115).<br><br>I published First.problem, Second.pro=
blem, and WholeThing.sequence, imported all three into the course, and re-i=
nitialized the course.<br><br>I never see any of the variables v1-v4 in Sec=
ond.problem filled in, either by <br><br>1) running the resources directly.=
 Run First.problem followed by Second.problem. Don't think this is expected=
 to work, but checking.<br><br>OR <br><br>2) running the sequence WholeThin=
g, filling in the value for First.problem, then moving to Second.problem.<b=
r><br>So, I am still missing something. I removed the "B", "C" and "D" sett=
ings to try and get exactly what Ray suggests, with no change. Don't know w=
hat I am doing different from Ray.<br><br>I am running on the educog machin=
e, which the login screen says is 2.7.1.<br><br><br>Getting somewhat closer=
,<br>brew<br> </div><font color=3D"#990099">-----lon-capa-users-admin@mail.=
lon-capa.org wrote: -----<br><br></font><blockquote style=3D"border-left: 2=
px solid rgb(0, 0, 0); padding-right: 0px; padding-left: 5px; margin-left: =
5px; margin-right: 0px;">To: lon-capa-users@mail.lon-capa.org<br>From: Ray =
Batchelor &lt;batchelo@sfu.ca&gt;<br>Sent by: lon-capa-users-admin@mail.lon=
-capa.org<br>Date: 05/13/2009 10:23AM<br>Subject: Re: [LON-CAPA-users] EXT =
question<br><br><font size=3D"3" face=3D"monospace">Not sure what you are d=
oing...<br>When I refer to "RAT", I mean the "Advanced Edit" mode for editi=
ng a<br>sequence in CSTR.<br><br>I just now, tried this out again and it wo=
rks.<br><br>1) created a new assembled sequence in CSTR<br>2) clicked on it=
 and selected "Simple Edit"<br>3)Imported a couple of problem resources.<br=
>4)Saved.<br>5)clicked on "Advanced Edit".<br>6)clicked on the resource hol=
der to which I want to apply an alias.<br>7)clicked on "Set Parameters"<br>=
8)located the parameter "Resource alias name for conditions [Part: 0]<br>pa=
rameter=5F0=5Fmapalias".<br>9)typed a string of text into the "Value" vield=
<br>(in this example I entered "A" as my alias for the resource).<br>10) cl=
icked on "Enter" link<br>11) in new popup clicked "Save"<br>(I realize ther=
e may be some redundancy in steps 9-11, but I am<br>describing what just wo=
rked...)<br>12) checked the box "Set?" for this parameter.<br>13) scrolled =
to the bottom of the form and clicked "Set" button.<br><br>14) Clicked "Sav=
e map and layout".<br><br>If I then publish this sequence and import it int=
o my course, I can<br>then use the expression below (in any other published=
 resource<br>included in the course)<br><br>$v0=3D&amp;EXT('user.resource.r=
esource.11.12.submission','A');<br><br>to retrieve the current submission f=
or part id=3D"11" and response<br>id=3D"12" for the aliased resource.<br><b=
r>This works fine for me here.<br><br>I hope that your LON-CAPA installatio=
n can reproduce this?<br><br>If I bother to look in my published sequence f=
ile I see the xml:<br>&lt;param to=3D"1" value=3D"A" name=3D"parameter=5F0=
=5Fmapalias" type=3D"string" /&gt;<br>for what that's worth. &nbsp;However,=
 I never do so, because the procedure<br>above seems to work fine for me.<b=
r><br>One final observation: once &nbsp;"Advanced Edit" &nbsp;has been used=
 to save<br>this sequence including the map alias parameter, then I am no l=
onger<br>allowed to use the "Simple Edit" option, but only see an "Edit" bu=
tton<br>for this sequence, which opens the advanced edit mode.<br><br>If th=
is does not work for you, then... "over to Stuart".<br><br>Good luck,<br>Ra=
y<br><br><br><br>On Wed, May 13, 2009 at 6:21 AM, &nbsp;&lt;Robert=5FBrewin=
gton@er.monroe.edu&gt; wrote:<br>&gt; Wow, this is getting worse by the mom=
ent.<br>&gt;<br>&gt; When I run RAT, it doesn't allow me to import anything=
. In the import<br>&gt; process I can select resoources, it gets to the scr=
een where I can re-order<br>&gt; the resources, but the "Finish Import" but=
ton does nothing.<br>&gt;<br>&gt; I used the simple editor to put two resou=
rces into the sequence. The I ran<br>&gt; RAT hoping to set the mapalias pa=
rameter. There seems to be no editing<br>&gt; capability? I can see a list =
of metadata (the &lt;m&gt; link), which refers to the<br>&gt; mapalias but =
gives no ability to edit. There is a ? link which runs the<br>&gt; resource=
. Clicking on the arrows between the two resources does nothing<br>&gt; (us=
ed to bring up the decision editing block).<br>&gt;<br>&gt; Saving the map =
then deleted all the resources and left me with an empty<br>&gt; map:(<br>&=
gt;<br>&gt;<br>&gt; So, RAT doesn't seem to want to let me do anything. I t=
ried setting the<br>&gt; mapalias directly in the first problem, making up =
the statement<br>&gt;<br>&gt; &lt;parameter name=3D"mapalias" id=3D"110" de=
fault=3D"MyBusProblem"<br>&gt; type=3D"string=5Fmapaliastype" description=
=3D"mapalias" /&gt;<br>&gt;<br>&gt; which did not work, not surprising sinc=
e I am making up statements:)<br>&gt;<br>&gt; I have previously set the map=
alias to "BusProblem" using the Parameter<br>&gt; Setting screen for the fi=
rst problem. As Ray indicated, the second problem<br>&gt; is not able to fi=
nd the submission to the first problem.<br>&gt;<br>&gt; Any other clues? St=
uart, et al have any suggestions?<br>&gt;<br>&gt; Thanks,<br>&gt; brew<br>&=
gt;<br>&gt; =5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=
=5F LON-CAPA-users mailing list<br>&gt; LON-CAPA-users@mail.lon-capa.org<br=
>&gt; <a href=3D"http://mail.lon-capa.org/mailman/listinfo/lon-capa-users">=
>-- <br>Raymond J. Batchelor, Ph.D.<br>Department of Chemistry<br>Simon Fra=
ser University<br>Burnaby, BC<br>Canada<br>V5A 1S8<br>=5F=5F=5F=5F=5F=5F=5F=
=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F<br>LON-CAPA-users mailing lis=
t<br>LON-CAPA-users@mail.lon-capa.org<br><a href=3D"http://mail.lon-capa.or=