[LON-CAPA-users] units in submission bug?

Gerd Kortemeyer lon-capa-users@mail.lon-capa.org
Tue, 6 Jan 2009 17:35:07 -0500


On Jan 6, 2009, at 4:00 PM, William Paddock wrote:

> One of my students just discovered that if you type a letter before  
> the number in a numerical response, any required units will be  
> ignored.
> For example...
> Correct answer is 34.5 g
> 34.5 returns "units required"
> 34.5 kg returns "incorrect"
> and so on... as expected... however...
> s34.5 returns correct.
> And I've tried it in my own versions of the problems several times.   
> I've tried this on several questions, with several different  
> letters, and different required units, and seems to work.  The  
> numerical part of the answer must be the same as the value CAPA has  
> as the correct answer, but a student wouldn't need to know the  
> correct units.  Is this a bug?  Has anyone else observed this?

Certainly looks like a bug to me. I just tried it out, and indeed, any  
initial letter in the answer seems to substitute for the unit that the  
instructor entered :-(


- at least, the students need to guess the unit that the instructor  
gave and calculate the correct numerical result in that unit.

- Gerd.