[LON-CAPA-users] edit default.sequence for a course?

Gerd Kortemeyer lon-capa-users@mail.lon-capa.org
Mon, 18 Jun 2007 09:05:52 -0400


On Jun 17, 2007, at 7:16 PM, James Sullivan wrote:

> I'm getting an error message: "Error: multiple use of link index  
> 43." in my coursedocs.

Interesting - I did not get that error (just tried again). It doesn't  
show up for me - I am domain coordinator and went in through the  
"Select Course" feature, maybe that's why.

But the message is correct. When I rescued the accidently deleted  
folder, I copy/pasted the link structure, but forgot to change the  
index. My fault.

> I can't see any folders, file, navigation pages, or anything. Just  
> the basic course docs page. I can't create anything new. "Navigate  
> Contents" seems to show the folder structure as I would expect it  
> to be. I have strong suspicion that there is an error in the  
> "default.sequence" file associated with the course.

Yes, I messed it up when I fixed the other thing. It's fine now.  
Please log out, and log back in.

> Is there some way (without command line access) to edit/fix that  
> file? I'm dead in the water for this course unless it can get fixed.

No, at the moment, command line is all that works (and for a messed  
up sequence like the one I made from the command line, it will also  
always have to be fixed from the command line).

In the future, "Recover Deleted Resources" will work again, Guy  
immediately fixed it after I had filed the bug. 2.4.2 will have it  
working correctly.

Sorry I also only got your email today somehow.

- Gerd.