[LON-CAPA-dev] Re: LON-CAPA prereq missing dependencies

Stuart Raeburn lon-capa-dev@mail.lon-capa.org
Fri, 15 Aug 2008 10:53:56 -0400


This issue affected Fedora 8 (32 bit).

I have built a new rpm for perl-RTF-HTMLConverter for that distro/arch  
and replaced the existing rpms in both the repository used by  
production servers
(http://install.loncapa.org/fedora/linux/loncapa/8/i386) and in the  
testing repository used by development servers:  

yum clean all

yum update

should update LONCAPA-prerequisites to 1-12 and install the  
dependencies required for LON-CAPA 2.6.99.X and CVS HEAD.

This was unrelated to Stefan's issue on Centos5 with the perl-Error  
dependency (for the perl-RTF-HTMLConverter package).

The original rpm for perl-RTF-HTMLConverter provided for Fedora8 (32  
bit) was built on a 64 bit instance of Fedora 8 running in 32 bit mode  
with a target set to i386. as I didn't have a Fedora 8 32 bit instance  
available to me at that time.  Apparently dependencies on 64 bit  
libraries were included in the resulting rpm - hence the unsatisfied  
64 bit dependencies.

A solution would have been to get the src rpm from


build the rpm on the 32 bit Fedora 8 machine, then install.

Stuart Raeburn

> Hello All,
> I tried updating my workstation to run bleeding edge CVS and install  
> the latest LON-CAPA-prerequisites on it.
> The LON-CAPA-prerequisites won't install.  I get the following message:
> Missing Dependency: libc.so.6()(64bit) is needed by package  
> perl-RTF-HTMLConverter
> Missing Dependency: libc.so.6(GLIBC_2.2.5)(64bit) is needed by  
> package perl-RTF-HTMLConverter
> Missing Dependency: libc.so.6(GLIBC_2.3.4)(64bit) is needed by  
> package perl-RTF-HTMLConverter
> My workstation is 32 bit.  I think this might be related to Stefan's  
> CentOS Update issues.  It could also be related to the fact that my  
> workstation has a bunch of other software on it other than LON-CAPA.  
> I've had to remove packages in the past to get LON-CAPA working.
> Felicia
> -- 
> Felicia Berryman
> Instructional Systems Team
> Academic Technology Services
> Michigan State University
> (517)432-4040
> LON-CAPA Technical Support Available at:
>     http://www.loncapa.msu.edu - MSU Users
>    http://www.help.lon-capa.org - General