[LON-CAPA-admin] installing loncapa prerequisites fails

Stuart Raeburn raeburn at msu.edu
Sat Sep 23 13:07:01 EDT 2017


> Error: Package: lapack-devel-3.4.2-4.el7.x86_64
> Error: Package: blas-devel-3.4.2-4.el7.x86_64

The problem here is that the base Red Hat channel:  
rhel-x86_64-server-7 includes lapack and blas, but does not include  
lapack-devel or blas-devel.

These two -devel packages are dependencies of the R statistics  
package, which itself is a LON-CAPA dependency.

To support installation of LON-CAPA on Red Hat 7 instances which have  
not yet set up subscriptions to Red Hat, but have just downloaded the  
free rhel7 server .iso  (lapack-devel and blas-devel are not in the  
.iso), the two -devel packages are included in the LON-CAPA repo at:


However, as of 9/22 versions of lapack-devel and blas-devel were both  
3.4.2-4, but the latest versions of lapack and blas from the rhel  
channel for 7.4 are 3.4.2-8.

Anyway I have now updated the lapack-devel and blas-devel packages in  
the loncapa rhel7 repo to 3.4.2-8

If you do:

yum clean all

yum install LONCAPA-prerequisites

that will now work.

To avoid issues in the future, you should add a subscription to the  
Red Hat channel (rhel-x86_64-server-optional-7), which provides  
lapack-devel and blas-devel with this command:

rhn-channel -a -c rhel-x86_64-server-optional-7 -u <rhn-username> -p  

(where <rhn-username> and <rhn-password>are your username and password  
for your subscription to RHN).

Stuart Raeburn
LON-CAPA Academic Consortium

Quoting "Neubauer, Paul" <pneubauer at bsu.edu>:

> I'm trying to configure a new (replacement) server for our lon-capa  
> box. Using Red Hat Enterprise Linux Server release 7.4 (Maipo)
> I have installed the OS and completed through step 4 from the doc at

> install.loncapa.org/RHEL7_install.html
> Including (in particular) the rhel7_loncapa_yum.conf
> HOWEVER, when I execute:
> yum install LONCAPA-prerequisites
> .
> .
> .
> ---> Package perl-Module-Load.noarch 1:0.24-3.el7 will be installed
> ---> Package ttmkfdir.x86_64 0:3.0.9-42.el7 will be installed
> --> Finished Dependency Resolution
> Error: Package: lapack-devel-3.4.2-4.el7.x86_64
>             Requires: lapack(x86-64) = 3.4.2-4.el7
>             Available: lapack-3.4.2-4.el7.x86_64  
> (rhui-REGION-rhel-server-releases)
>                 lapack(x86-64) = 3.4.2-4.el7
>             Available: lapack-3.4.2-5.el7.x86_64  
> (rhui-REGION-rhel-server-releases)
>                 lapack(x86-64) = 3.4.2-5.el7
>             Installing: lapack-3.4.2-8.el7.x86_64  
> (rhui-REGION-rhel-server-releases)
>                 lapack(x86-64) = 3.4.2-8.el7
> Error: Package: blas-devel-3.4.2-4.el7.x86_64
>             Requires: blas(x86-64) = 3.4.2-4.el7
>             Available: blas-3.4.2-4.el7.x86_64  
> (rhui-REGION-rhel-server-releases)
>                 blas(x86-64) = 3.4.2-4.el7
>             Available: blas-3.4.2-5.el7.x86_64  
> (rhui-REGION-rhel-server-releases)
>                 blas(x86-64) = 3.4.2-5.el7
>             Installing: blas-3.4.2-8.el7.x86_64  
> (rhui-REGION-rhel-server-releases)
>                 blas(x86-64) = 3.4.2-8.el7
>   You could try using --skip-broken to work around the problem
>   You could try running: rpm -Va --nofiles --nodigest
> I'm not sure that I want to "skip-broken" at least not without  
> knowing whether I definitely do not need  
> lapack-devel-3.4.2-4.el7.x86_64 or blas-devel-3.4.2-4.el7.x86_64.
> This is brand-new system with a fresh OS. The "requires" and  
> "available" lines look like the install ought to work, i.e., if  
> 3.4.2-4.el7 is required and lapack-3.4.2-4.el7.x86_64 is available,
> would think the install ought to be OK. I'm evidently missing something.
> I don't want to continue and break something. Any advice
> Thanks,
> Paul
> _______________________________________________
> LON-CAPA-admin mailing list
> LON-CAPA-admin at mail.lon-capa.org

More information about the LON-CAPA-admin mailing list