[LON-CAPA-admin] installing loncapa prerequisites fails

Neubauer, Paul pneubauer at bsu.edu
Fri Sep 22 10:40:50 EDT 2017

I'm trying to configure a new (replacement) server for our lon-capa box. Using Red Hat Enterprise Linux Server release 7.4 (Maipo)

I have installed the OS and completed through step 4 from the doc at http://install.lon-capa.org/RHEL7_install.html
Including (in particular) the rhel7_loncapa_yum.conf

HOWEVER, when I execute:

yum install LONCAPA-prerequisites
---> Package perl-Module-Load.noarch 1:0.24-3.el7 will be installed
---> Package ttmkfdir.x86_64 0:3.0.9-42.el7 will be installed
--> Finished Dependency Resolution
Error: Package: lapack-devel-3.4.2-4.el7.x86_64 (loncapa-updates-basearch)
           Requires: lapack(x86-64) = 3.4.2-4.el7
           Available: lapack-3.4.2-4.el7.x86_64 (rhui-REGION-rhel-server-releases)
               lapack(x86-64) = 3.4.2-4.el7
           Available: lapack-3.4.2-5.el7.x86_64 (rhui-REGION-rhel-server-releases)
               lapack(x86-64) = 3.4.2-5.el7
           Installing: lapack-3.4.2-8.el7.x86_64 (rhui-REGION-rhel-server-releases)
               lapack(x86-64) = 3.4.2-8.el7
Error: Package: blas-devel-3.4.2-4.el7.x86_64 (loncapa-updates-basearch)
           Requires: blas(x86-64) = 3.4.2-4.el7
           Available: blas-3.4.2-4.el7.x86_64 (rhui-REGION-rhel-server-releases)
               blas(x86-64) = 3.4.2-4.el7
           Available: blas-3.4.2-5.el7.x86_64 (rhui-REGION-rhel-server-releases)
               blas(x86-64) = 3.4.2-5.el7
           Installing: blas-3.4.2-8.el7.x86_64 (rhui-REGION-rhel-server-releases)
               blas(x86-64) = 3.4.2-8.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I'm not sure that I want to "skip-broken" at least not without knowing whether I definitely do not need lapack-devel-3.4.2-4.el7.x86_64 or blas-devel-3.4.2-4.el7.x86_64.
This is brand-new system with a fresh OS. The "requires" and "available" lines look like the install ought to work, i.e., if 3.4.2-4.el7 is required and lapack-3.4.2-4.el7.x86_64 is available, I would think the install ought to be OK. I'm evidently missing something.

I don't want to continue and break something. Any advice appreciated.

More information about the LON-CAPA-admin mailing list