[LON-CAPA-admin] domain coordinator cannot log in on new system

Neubauer, Paul pneubauer at bsu.edu
Thu Aug 9 12:20:31 EDT 2012

HELP! I'm (re)creating a test system lon-capa-test.bsu.edu for internal/testing use. I'm using CentOS 6.2 and lon-capa 2.10.1.

I've followed all the instructions at http://install.lon-capa.org/centos6_install.html, and I created a domain coordinator in step 6, then started loncontrol and httpd, but when I tried to log in as bsudc, the domain coordinator, I got the message:

Username and/or password could not be authenticated.

I determined that this was not due to an incorrect password. In fact, I ran passwd and reset the password to be absolutely positive. I still got no improvement.  So I created another domain coordinator, again using /root/loncapa-2.10.1/loncom/build/make_domain_coordinator.pl and that one could not log in either. I tried expiring bsudc's privs with /root/loncapa-2.10.1/loncom/build/expire_DC_role.pl and readding with add_domain_coordinator_privilege.pl, but that simply failed. So I deleted the two users I had created using deluser (and delgroup) and tried again from the beginning. I restarted loncontrol and tried again to log in as bsudc. This time I get:

 Sorry ...
Information needed to verify your login information is missing, inaccessible or expired.
Please log in again.
Login problems?

If I log in to the system at the OS level, bsudc is capable of that, so I know that OS authentication is working.

I'm completely flummoxed.

Any ideas?


More information about the LON-CAPA-admin mailing list