[LON-CAPA-admin] Domain coordinator cannot log in after upgrade

Stefan Bisitz st.bisitz at fh-wolfenbuettel.de
Sat Oct 18 14:05:03 EDT 2008

Hi Paul,

Some comments which hopefully help a bit:

- User accounts cannot be totally removed in the current LON-CAPA
version. Just make sure that nobody can login with the invalid user,
e.g. set to internally authenticated and set a random password.

- I guess you have consulted
? However, from what you write I assume that you already successfully
passed the important steps.

- I slightly remember that I also had troubles to login with an already
existing DC account after having changed the server hardware, the OS,
the IP adress, ... and (nearly) the rest of the world... ;-)

I assume that "normal" users can login, just the DC (domain coordinator)
cannot. If so, my suggestions:

a) Create a _new_ DC account with an so far unused user name for your
domain. Then log in with this new user and change the password for the
_old_ DC account ("bsudc").

b) It is possible that file system authentication is the origin for the
issues, but this is the method new DC accounts automatically have. I
think you don't need this kind of authentication. In this case, switch
the authentication method of your old DC account to internally
authenticated and enter a password. This should work.

Good luck!
Stefan Bisitz

----- Original Message -----
From: "Neubauer, Paul R." <pneubauer at bsu.edu>
Date: Friday, October 17, 2008 11:53 pm
Subject: [LON-CAPA-admin] Domain coordinator cannot log in after upgrade

> Hi folks,
> I have (finally) upgraded the OS on our library server from Fedora 
> Core 4 to Centos 5.2. It's a long story, and I don't feel like 
> going into the whole nine yards at the moment. I will post a real 
> description of the process soon though. The result is that right 
> now *nearly* everything works. The notable exception is that the 
> domain coordinator account cannot log in.
> I have more or less concluded that we do not actually have a domain 
> coordinator right now. After some poking around, I found 
> /root/loncapa-2.7.1/loncom/build/make_domain_coordinator.pl and 
> tried to run it.
> I did the following:
> cd /root/loncapa-2.7.1/loncom/build
> perl make_domain_coordinator.pl bsu bsudc
> Then, I entered the password at the prompt and got the message:
> **** ERROR **** bsudc is already a linux operating system user.
> For security reasons, this script will only automatically generate
> new users, not pre-existing users.
> If you want to make 'bsudc' a domain coordinator, you
> should do so manually by customizing the MANUAL PROCEDURE
> described in the documentation.  To view the documentation
> for this script, type 'perldoc ./make_domain_coordinator.pl'.
> So I ran the perldoc command and got instructions there. I got up 
> to step 9:
>       9. (as www). Run CVS:loncapa/doc/rolesmanip.pl:
>            Command: [prompt %] perl rolesmanip.pl DOMAIN USERNAME
>            Example: [prompt %] perl rolesmanip.pl 103 dc103
> However, I cannot find rolesmanip.pl anywhere. Where is it? It is 
> certainly not in /root/loncapa-2.7.1/loncom/doc (which does not 
> exist).
> To add insult to injury, I also accidentally ran:
> perl make_domain_coordinator.pl bsudc bsu
> and accidentally created a domain coordinator named "bsu" for the 
> (nonexistent) "bsudc" domain instead of a coordinator named "bsudc" 
> for the (real) "bsu" domain. I deleted the user, but how do I 
> delete the database entry for the spurious user?
> Thanks, 
> Paul
> _______________________________________________
> LON-CAPA-admin mailing list
> LON-CAPA-admin at mail.lon-capa.org
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-admin

More information about the LON-CAPA-admin mailing list