[LON-CAPA-admin] JSmol and /adm/ folder location

Bob Gonzales rgonzal at binghamton.edu
Mon Nov 9 14:43:52 EST 2015


I've coded up a problem using JSmol and it does work.  The only
documentation I found was in this post:


I used this invocation, as mentioned in the post:

<script src="/adm/jmol/Jmol.js" type="text/javascript"></script>
<script type="text/javascript">jmolInitialize("/adm/jmol"); jmolApplet(250,
"load /res/sfu/somepath/somefile.pdb");

There is another example invocation following this one in the post which
shows many options being set.

The one I used worked for the Chrome and Firefox browsers but not for
Safari and Internet Explorer.  This might be solved with the second
invocation and setting the proper variable but I have no idea which
combination(s) might fix it.

Bob Gonzales
Binghamton University
Chemistry Dept

On Mon, Nov 9, 2015 at 1:36 PM, Bynum, Lee Hamilton <leebynum at illinois.edu>

> Hello,
> I've been asked to confirm that 2.11.1 includes JSmol.  Looking at the
> documentation, it appears that it should.  However, I've looked into the
> /home/httpd/html/adm/ folder and have not found JSmol or updated versions
> of jmol.  I suspect I am either looking in the wrong location or that the
> javascript modules didn't update with the updater.  The former is much more
> likely.
> Can someone point me to where these modules live on the server?
> Thanks,
> Lee
> _______________________________________________
> LON-CAPA-admin mailing list
> LON-CAPA-admin at mail.lon-capa.org
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-admin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.lon-capa.org/pipermail/lon-capa-admin/attachments/20151109/744411b8/attachment.html>

More information about the LON-CAPA-admin mailing list