[LON-CAPA-users] error on new course

Mueller, James A. mueller at pitt.edu
Thu Sep 15 16:23:57 EDT 2016

Thanks for the very detailed instructions.  I now have a related problem and some understanding of what might have been the cause of my problem before.

There are a set of .problem files that were written 7-8 years ago by a professor who has since retired.  What is strange is that he did not create these under his own author area but somehow in an area I would associate with the domain coordinator  “/res/pitt/XXXXXX” where XXXXXX is the username for the domain coordinator.  Now we have just been cloning the course every year, and that works fine from the physics server, but they cannot be seen from the math server.  Thus cloning failed when run from the math server.
Now that the course is set up, I see students who end up on the math server still can’t view those problems.  From the physics server, for students in my course, they click on the problem and all is fine.  But if they are on the math access server, they see an error message like “Unable to find MeteoroidsInertial.problem”.
In addition, if as course coordinator I try to browse resources (from either server), it shows and Area XXXXXX under /res/pitt, but if I click on it, it says “Directory does not exist”.  On the other hand, I can log into the library server, do an ls on that area (/home/httpd/html/res/pitt/XXXXXX”) and see all the files.  So I guess I need to copy all the .problem files over to a valid author area (mine probably), republish them, and move the links in my course to new versions of the problems for future terms.

One thing I found in doing this was that the math IT person, has moved the math server over to a vm on a machine in the universities data center.  This allows them to use the university single login rather than the local login that is used by the physics servers.  Probably not a good idea to have the math access server run differently from the physics access and library servers, so that is something we should probably standardize in the near future.


On Aug 28, 2016, at 11:54 AM, Stuart Raeburn <raeburn at msu.edu<mailto:raeburn at msu.edu>> wrote:


Yes, I see the problem in the course you originally created -- course initialization as Course Coordinator fails because the default.sequence file (i.e., top level map) is missing, hence you can't use:

(a) Settings > Course Settings > Display (General course settings checked) to change the course title


(b) People > Users > Automated Enrollment to disable automated enrollment.

That said (as you reported), your use of Main Menu > "View or modify a course or community" as Domain Coordinator to remove the institutional course code will have effectively disabled automated enrollment in the course.

Similarly (as Domain Coordinator) expiring all roles in the course effectively means no one will be aware of this "broken" course.

However to the "fix" the course and, to use (a) and (b) above, you'd need to use command line access to the course's home server to add a default.sequence file.

You would use a text editor as user www to save the following:

<resource id="1" src="" type="start"></resource>
<link from="1" to="2" index="1"></link>
<resource id="2" src="" type="finish"></resource>

to the file:


on the Physics-Astronomy LON-CAPA library server.

Once that had been done I would expect you'd be able to successfully initialize the course from your roles screen, albeit with a top-level map containing no resources.

As an aside, I expect the default.sequence file created when cloning, as well as other .sequence files created in the new course would have been found in


on homework.math.pitt.edu<http://homework.math.pitt.edu>

at least until cleaned up by cleanup_file_caches.pl (run nightly) which removes files in /home/httpd/html/userfiles not accessed in the past 24 hours (i.e., the value in seconds of lonExpire in /etc/httpd/conf/loncapa.conf on that server).

Stuart Raeburn
LON-CAPA Academic Consortium

Quoting "Mueller, James A." <mueller at pitt.edu<mailto:mueller at pitt.edu>>:

Cloning worked the second time.  Thanks. The only problem is  renaming the failed course
On Aug 25, 2016, at 7:14 AM, Stuart Raeburn wrote:

You could then rename the current ?2171_24834 PHYS 0081 Space &  Time, Light & Matter" course, disable auto-enrollment, and expire  all roles.
Within loncapa, I don?t see a way to rename the course.  As Domain  Coordinator, I can change the course code, so I did that, but I am  not sure how to change the course title or disable auto enrollment  without entering that course.  I can list all users who have roles,  and it looks like it is only me as course coordinator, so I revoked  that.  I think with the course code changed to an invalid value,  there will be will be no way for auto-enrollment to add any  students.  I was never able to enter the course, so there is no work  there to lose.


On Aug 25, 2016, at 7:14 AM, Stuart Raeburn  <raeburn at msu.edu<mailto:raeburn at msu.edu><mailto:raeburn at msu.edu>> wrote:


What might have gone wrong here, and is there any way to fix it?

It sounds as though copying from the course being cloned to the new  course failed for the top-level map (i.e., the default.sequence  file) in the old course.

The courseID of the new course tells me that your session was hosted  on pittmath1, i.e., the Pitt Mathematics department's access server  when you created the new course, and not Physics-Astronomy's library  server (pittphyast1).

That means that there would have been a number of calls to retrieve  sequence files (including default.sequence) from the library server,  followed by copying, then modification (to replace instances of the  old courseID with the new in any src attributes in the  default.sequence file), and lastly notification to the homeserver  for the new course (i.e., the library server) to copy the modified  sequence files from the access server to the library server for  permanent storage.

The routines in lonclonecourse.pm which are used for cloning do not  currently return any information about success or failure of the  various operations which occur when cloning a course, so you'd need  to look in /home/httpd/perl/logs/lonnet.log on the access server,  and/or /home/httpd/perl/logs/lond.log on the library server for  information about failed replication.  However, since lonnet.log is  rotated, the information in the lonnet.log file may no longer be  around, if you created the new course more than a few days ago.

What to do?

Depending on how much work you have done in the new course, since  cloning, you could just create another course, (again with cloning),  but this time with a web session hosted on the library server.  You  could then rename the current "2171_24834 PHYS 0081 Space & Time,  Light & Matter" course, disable auto-enrollment, and expire all roles.

Or you could attempt to repair the 6E101732148bb57dcpittmath1 course  by using  command line access (as user www) to copy the  default.sequence file from  /home/httpd/lonUsers/pitt/$1/$2/$3/$clonedcourse/userfiles/default.sequence  to  /home/httpd/lonUsers/pitt/6/E/1/6E101732148bb57dcpittmath1/userfiles/default.sequence, and then use a text editor to replace any instances of $clonedcourse with 6E101732148bb57dcpittmath1 (where $clonedcourse is the courseID of the course that was cloned, and $1, $2, $3 are the first three characters in that  courseID).

Of course it may be that other sequence files, besides  default.sequence, were also not copied/modified from the old course  to the new course, so you might need to do the same for them.

Stuart Raeburn
LON-CAPA Academic Consortium

The other day, I cloned a course from last fall for use in the   coming term.  I thought it worked, but now when I try to access that   course as course coordinator, I get the following error message:

The following problems occurred:

Map not loaded: The file   /home/httpd/html/userfiles/pitt/6E101732148bb57dcpittmath1/default.sequence   does not exist.

What might have gone wrong here, and is there any way to fix it?

-Jim Mueller

LON-CAPA-users mailing list
LON-CAPA-users at mail.lon-capa.org<mailto:LON-CAPA-users at mail.lon-capa.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.lon-capa.org/pipermail/lon-capa-users/attachments/20160915/8d096d84/attachment-0001.html>

More information about the LON-CAPA-users mailing list