[LON-CAPA-dev] LONCAPA-prerequisites 1-23

Stuart Raeburn raeburn at msu.edu
Sun Aug 11 15:57:25 EDT 2013


This message is intended for people who are running bleeding edge  
LON-CAPA on a development machine/VM.

/home/httpd/lib/perl/LONCAPA/Checksumming.pm 1.1 (and later)
requires perl-Digest-SHA1 (except Ubuntu 12.04, which requires  

/home/httpd/lib/perl/Apache/lonplot.pm 1.159 (and later) requires  
gnuplot 4.4 (or newer) -- see: bug 2886.

/home/httpd/lib/perl/Apache/inputtags.pm 1.3 (and later)
/home/httpd/lib/perl/Apache/lonhtmlcommon.pm 1.324 (and later)

utilize the jQuery javascript file: query.spellchecker.js, and require  
aspell dictionaries for the following 'supported' languages:  
'en','de','he','es','fr','pt','tr' -- see: bug 838.

For those distros for which LON-CAPA is supported, and for which the  
gnuplot version available from the standard repos is 4.2 or older, a  
gnuplot 4.4 package has been built.

Similarly, aspell language packages have been built for any of the  
seven languages listed, for which the appropriate aspell-<lang>  
rpm/deb is not available from a distro's standard repos.

Lastly, ImageMagick and ImageMagick-perl rpms have been built for any  
supported distros for which the version in the standard repo is 6.2 or  
older -- see bug 6652.

These packages, and LONCAPA-prerequisites 1-23, which advertises the  
dependency on perl-Digest-SHA1, and the >= 4.4 version requirement for  
gnuplot, have been deployed in the LON-CAPA testing repos found at:


For information about using the testing repos with a development VM or
server see:


LONCAPA-prerequisites-1.23 and any dependencies will be moved to the  
LON-CAPA production repos in the next day or so, in readiness for the  
release of LON-CAPA 2.11.0

Let me know if you have any questions.

Stuart Raeburn
Technical Director
LON-CAPA Academic Consortium

More information about the LON-CAPA-dev mailing list