Subject: [LON-CAPA-dev] Probably should start doing this

From: Guy Albertelli II <[email-masked]>
Date: Fri, 5 Sep 2003 01:19:39 -0400 (EDT)

So we have been doing 

use strict;

But we need to start doing

use warnings FATAL => 'all';
no warnings 'unintialized';

This all warnings into fatal errors, except for those that involve
treating unitialized values as 0 or ''.

-- 
[email-masked]  LON-CAPA Developer  0-7-6-1-

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 5 Sep 2003 08:10:38 -0400

Can we make this conditional?

development machine => blow up
production machine => keep on running, hoping for the best

On Friday, September 5, 2003, at 01:19  AM, Guy Albertelli II wrote:

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev