Subject: Re: [LON-CAPA-dev] The new look of LON-CAPA

From: [email-masked]
Date: Fri, 08 Feb 2002 17:17:45 EST

In a message dated Fri, 8 Feb 2002  5:05:34 PM Eastern Standard Time, Gerd Kortemeyer <[email-masked]> writes:

> Hi Josh and Nishreen,
> 
> Nice start, this looks a lot spiffier than the old stuff.

Thanks.

> 
> But as we are doing this: Is there any way to extend the screen over the full width of the browser window? At least the top green, the grey and green line, and the
> white should be continued. This looks rather cut off.

The problem with this is the images.  What I was thinking is to put another rounded edge on the cut off side and center the whole table on the page.

> Also, within the white part, the logo looks really queezed in to the left, and the "Username" etc directly
> collides with the green.
> 
> *** "Minor" point: I cannot login at all, the page does not submit. The image "Login" does not do anything.
> 

I'll change this to an <input type=image> instead.  Then  have <form onSubmit="send()">.  That might fix things with the onClick event.(hopefully)
  
> - Gerd.

 - Josh

---

From: Benjamin Tyszka <[email-masked]>
Date: Fri, 8 Feb 2002 20:09:42 -0500

>> But as we are doing this: Is there any way to extend the screen over 
>> the full width of the browser window? At least the top green, the grey 
>> and green line, and the
> The problem with this is the images.  What I was thinking is to put 
> another rounded edge on the cut off side and center the whole table on 
> the page.
>
>

I really like the way that the webpage looks.

If you chop the header into two and use table backgrounds, you can get 
the page to stretch across the screen as shown here:

http://www.tyszkanews.net/loncapa/loncapa_test.html

You can download the page with the chopped image/backgrounds from:
http://www.tyszkanews.net/loncapa/loncapa_page.tar

I recommend, Josh, that you recut the images and backgrounds rather than 
use mine. I cut your jpeg images and then saved them again as jpeg, 
adding additional loss. It's better to do this to the originals.

As far as you Netscape 4.76 bugs, I think that you can eliminate the 
problems with colors between tables if you use a longer background image 
in the middle column (i.e. background2.gif(jpg) needs to be wider) and 
fill in the additional space with white, but keep the column width the 
same. I've had to do this numerous times, and I did it in my above test 
page. Unfortunately,  I no longer have Netscape 4.xx to test it out.

As far as browser compatibility goes, I've tested your page and the 
above page on:
Internet Explorer 5.1.3 for OS X
Opera 5.0 for OS X
Mozilla 9.8 for OS X
Omniweb 4.1 Beta for OS X
and both pages render correctly (as far as I can tell).

Ben

---

From: Gerd Kortemeyer <[email-masked]>
Date: Sat, 09 Feb 2002 13:36:57 -0500

> The problem with this is the images.  What I was thinking is to put another rounded edge on the cut off side and center the whole table on the page.

I would leave a little more room on the sides, round off the edges, and then at the edge of the image simulate a drop-shaddow, so that it looks like the login screen is
a little bit deeper than the intense green color background. Maybe Nishreen can do. Centered will look bad, I am afraid.

The first splash screen needs to be color coordinated with the login screen. If one does it the cute way, the splash screen features the background images of the login
screen. After the re-route, then the text of the login screen pops up.

> I'll change this to an <input type=image> instead.  Then  have <form onSubmit="send()">.  That might fix things with the onClick event.(hopefully)

You can also do a <a href="javascript:send();"><input type=image border=0 ...></a> - we must never ever submit the form with the plain text login and password. The
above mechanism might make a JavaScript-challenged browser submit this info.

- Gerd.

---

From: Gerd Kortemeyer <[email-masked]>
Date: Sat, 09 Feb 2002 13:36:57 -0500

- Gerd.