Subject: [LON-CAPA-dev] Generic Page Header/Footer

From: "Bynum, Lee Hamilton" <[email-masked]>
Date: Wed, 6 Jun 2018 15:06:39 +0000

Hello Dev List,

I'm digging into the code with the intent of adding some code to every page of lon-capa for EU GDPR purposes.  I haven't worked with the page assembly scripts much, so forgive me if this is a stupid question.

Is there a central place where headers are generated?  It is looking to me as though the various page types have independent wrappers that form their html.  If that is the case, I may need to rethink my approach.

Thanks,

Lee

---

From: "H. K. Ng" <[email-masked]>
Date: Wed, 6 Jun 2018 12:35:23 -0400

Hi,

A sty file will probably accomplish what you want to do. I use them to give
all problems a uniform look and also, insert a copyright notice at the end.
If you are interested, let me know and I can send one privately.

Regards,
-hk

On Wed, Jun 6, 2018 at 11:29 AM Bynum, Lee Hamilton <[email-masked]>
wrote:

> Hello Dev List,
>
>
>
> I’m digging into the code with the intent of adding some code to every
> page of lon-capa for EU GDPR purposes.  I haven’t worked with the page
> assembly scripts much, so forgive me if this is a stupid question.
>
>
>
> Is there a central place where headers are generated?  It is looking to me
> as though the various page types have independent wrappers that form their
> html.  If that is the case, I may need to rethink my approach.
>
>
>
> Thanks,
>
>
>
> Lee
>