Subject: Re: [LON-CAPA-dev] STABLE

From: <[email-masked]>
Date: Mon, 29 Apr 2002 16:12:27 EDT

Dear Guy:

Good news:
make tardist and
./UPDATE basically works off of STABLE.

(basically.. cough cough..)

Quasibad news:
1) loncom/build/parse.pl should be removed
2) make build breaks because
   doc/man
   doc/scripts
   doc/lib/perl/Apache
   are not part of STABLE and this breaks the build

Since doc/man, doc/scripts, doc/lib/perl/Apache
are only for dynamic build making anyhow...
maybe these shouldn't be in CVS but rather
should be dynamically created?  What do you think?

Regards,
Scott

Guy Albertelli II <[email-masked]> said:

> Hi All,
> 
> STABLE tag has been moved.
> 
> I plan to update s4 to be running this version sometime tonight.
> 
> -- 
> [email-masked]        BM: n^20 t20 z20 qS 
> Guy Albertelli -7-8-7-  O-
>     My fingers type, but sentences do not I form -Richh
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev
>

---

From: Guy Albertelli II <[email-masked]>
Date: Mon, 29 Apr 2002 16:40:23 -0400 (EDT)

Hi Scott,

> (basically.. cough cough..)

Yeah!

> 1) loncom/build/parse.pl should be removed

Gone now.

>    are not part of STABLE and this breaks the build

There are no files in these directories, and thus I can't cause CVS to
create them. CVS doesn't really understand directories.

> should be dynamically created?  What do you think?

Yep, I think that make build should know how to create these
directories if they don't exist.

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-7-  O-
    ...nobody messed with Don Quixote. He was nuts.