Subject: [LON-CAPA-dev] Re: LON-CAPA-mysql

From: Scott Harrison <[email-masked]>
Date: Tue, 12 Mar 2002 18:36:31 -0500

Dear Martin:

Short answer:
* there are no plans to revisit LON-CAPA-mysql
* and, I assume, since the compilation was standard,
  mysql uses shared zlib library

Long answer:
LON-CAPA-mysql is a standard compilation of mysql on a RedHat 6.2
system.

Initially done from source:
DBI-1.13.tar.gz  Msql-Mysql-modules-1.2209.tar.gz  mysql-3.22.32.tar.gz

To quote my writing in:
CVS:doc/mysql_note.txt

BeginQuote
There were problems with using the RedHat packages since the three
different RedHat packages were somewhat noncompatible with each other
in terms of expected file locations. (The Debian linux distribution,
on the other hand, has a working set of these packages).
EndQuote

We are now working on a more focused post-installation approach
to LON-CAPA installation.

For RedHat 7.* systems, see the note I wrote
"Regarding MySQL." in CVS:doc/how_to_install_on_RedHat7.2.tx

RedHat 7.* can/should use rpm packages for mysql, though LON-CAPA-mysql
still works in this scenario.

Please let me know if you think we/all are still facing a glitch here.

Regards,
Scott

Martin Siegert wrote:
> 
> Hi Scott,
> 
> the zlib bug makes me check how many packages I must reinstall - currently
> I don't even know where to start - there are so many.
> 
> One package I came across is LON-CAPA-mysql: mysql is one of the 500
> packages that are listed on the zlib site as a program that uses zlib.
> 
> Now I ran "rpm -V LON-CAPA-mysql" on our LON-CAPA server (dalton.chem.sfu.ca)
> and it shows that basically all files are missing.
> 
> Is LON-CAPA-mysql no longer needed? Or have the files been moved to other
> places (cvs upgrade?) - if yes where?
> 
> Hopefully mysql uses the shared libz library otherwise this is bad news.
> 
> Cheers,
> Martin

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: Martin Siegert <[email-masked]>
Date: Tue, 12 Mar 2002 15:59:44 -0800

> Please let me know if you think we/all are still facing a glitch here.

Hmm. 

# cd /usr/local/mysql-3.23.33-pc-linux-gnu-i686/bin
# ldd mysqld
	not a dynamic executable
# ldd mysql
	not a dynamic executable

This looks like as if those binaries are compiled with static libraries.
... which is bad news.

Thus, what is the easiest way of fixing this on RH 6.2? Would rebuilding the 
src.rpm with a prefix /usr/local work? Or do you have a src.rpm for
LON-CAPA-mysql that I can modify to use shared libraries?

Under RH 7.2 using the mysql-server rpm I find:
# ldd /usr/libexec/mysqld
	libdl.so.2 => /lib/libdl.so.2 (0x40022000)
	libpthread.so.0 => /lib/i686/libpthread.so.0 (0x40026000)
	libz.so.1 => /usr/lib/libz.so.1 (0x4003b000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x40049000)
	libnsl.so.1 => /lib/libnsl.so.1 (0x40076000)
	libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3 (0x4008c000)
	libm.so.6 => /lib/i686/libm.so.6 (0x400cf000)
	libc.so.6 => /lib/i686/libc.so.6 (0x400f2000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

Thus this does used shared libraries. Would rebuilding the src.rpm of this
package for RH 6.2 work?

Cheers,
Martin

---

From: Scott Harrison <[email-masked]>
Date: Tue, 12 Mar 2002 19:49:07 -0500

Dear Martin:

Okay. I read redhat errata, and based on your ldd testing...

STATUS:
Thanks for checking and letting me know.  Okay.. we gotta
rebuild.  I suppose I will do this unless I can plead/beg
for any other involvement somehow.

REGARDING YOUR SRC.RPM IDEA: 

I know all there is to know about src.rpm and...

I find the CVS:loncom/build/make_rpm.pl script that I wrote
to be much easier to use than the .src.rpm system.
It is a one line command; file listing in, and out pops the rpm.

So a procedure is, build/compile mysql with new zlib into tmpperltarget
directory, and then

find tmpperltarget | perl make_rpm.pl LON-CAPA-mysql 3.4 '' ''
tmpperltarget

Out pops (cleanly as well)
LON-CAPA-mysql-3.4-1.i386.rpm

A sixth argument can specify an xml file which will customize
the rpm software package's metadata.

You can do
perldoc make_rpm.pl to read the documentation..

The DBI and Msql-Mysql perl modules belong in the someday
loncapa-perlplus
rpm. But are currently in LON-CAPA-mysql.

Regards,
Scott

Martin Siegert wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev