Subject: [LON-CAPA-dev] Automated version numbering in cvs

From: Stefan Bisitz <[email-masked]>
Date: Fri, 25 Jan 2008 10:22:33 +0100

Hi,

What is necessary to get a script using the automated version numbering
process in cvs?

There are two reasons for asking:
1) I found at least one loncapa script which doesn't have a version
number included.
2) I would like to put our selfenrollment script into cvs.

For both I'd like to use the advantages of the version numbering.

Thanks,
Stefan Bisitz

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 25 Jan 2008 07:22:27 -0500

Hi,

> What is necessary to get a script using the automated version  

I am not sure what you mean.

> 1) I found at least one loncapa script which doesn't have a version

Which one is it? It may be something that is dynamically generated.

> 2) I would like to put our selfenrollment script into cvs.

cvs add [file]
cvs commit

- Gerd.

---

From: Stefan Bisitz <[email-masked]>
Date: Fri, 25 Jan 2008 17:11:37 +0100

> I am not sure what you mean.

Ok, this was not clear enough, sorry. I meant the header in each loncapa
script, e.g.

----------------
# The LearningOnline Network
# Login Screen
#
# $Id: lonlogin.pm,v 1.100 2008/01/24 15:06:21 bisitz Exp $
#
# Copyright Michigan State University Board of Trustees
#
# This file is part of the LearningOnline Network with CAPA (LON-CAPA).
#
# LON-CAPA is free software; you can redistribute it and/or modify
[...]
----------------

The cvs version number, last update date and update user is
automatically updated:
-> # $Id: lonlogin.pm,v 1.100 2008/01/24 15:06:21 bisitz Exp $

resetpw.pm has a header but without this cvs line.

My question was how this line could be added to a script so that cvs
will update this line each time when a new version of this script is
commited.

Stefan

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 25 Jan 2008 11:42:50 -0500

Hi,

> will update this line each time when a new version of this script is

Just add a line

# $Id: $

and CVS will fill in the rest at commit time.

- Gerd.