Subject: [LON-CAPA-dev] List of things to get done for next release.

From: Guy Albertelli II <[email-masked]>
Date: Thu, 2 Jan 2003 14:06:50 -0500 (EST)

The result of today's meeting ended up with this rough barebones
of whats needs get done. Obviously this is a minimum not a maximum.

Feel free to claim things. :-)

Otherwise i was going to assign people to things next week. Most
likely after creating/finding the bug id. All bugs these will be set
to blocker status.

let me know if something is terse to the point of unidentifiable.

1) LOL must be finished off

2) exams / quizzes / anonymous (finish  off CAPA func)
      a) finishing printing
      b) bubbled input
      c) online input
      d) grade per student

3) lonc/d 
      a) dumpcurrent
      b) metaserve - hosts.tab/domains.tab
      c) dynamic / multiple connections

4) interface committee cleaning
      a) remote control
      b) cc/stu/au interface org

5) centralised caching mechanism 
      a) stats
      b) sprs
      c) lonnet internal

6) SPRS needs way to easily add up a sequence

7) Documentations (Docs)
      a) more updating of help.loncapa.org
      b) manuals - DC, CC, AU, ST
      c) online

8) attempt symb with sequence hierarchies
      a) if it works start on conditions

9) Publication
      a) peer review mechanism
      b) domain based restrictions.

--- other
 feature enhancements
      a) /Or + gnuplot enhance
      b) getting a list of the order of ids
      c) CC quick grades + excel
      d) add  name attribute to <part>

--- Resource creation maintenance
      a) Test version of Read it to me
      b) Msuphysicislib maintenance
      c) examlib creation

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-7-7-  O-
    I honor my personality flaws, for without them I would have no
    personality at all.   
 LocalWords:  BM qS Albertelli honor

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 10 Jan 2003 13:59:27 -0500

Hi All,

I just got done with the faculty workshops. This was a very good
experience, since for the first time I had the feeling that faculty
really liked LON-CAPA. Besides frequent "This is much easier than I
thought" and "This is nicer than LectureOnline," I had lots of "Wow!"
and other utterances of pleasant surprise :-) People are impressed with
what this can do.

Amazingly, nobody really complained about the interface, with the
exception of some little suggestions here and there. In the framework of
the ITR grant, we are going to have a systematic usability study, as
well as a faculty focus group on interface issues. I am looking forward
to the results, but apparently this is not quite the burning issue
anymore that it used to be - let's wait what those studies produce.

The only thing that still bites are the bugs. Besides the "blockers"
which will hopefully be fixed in 0.6.1, there are lots of small little
annoyances and weirdnesses - I cannot remember all of them, since it is
hard to study some weirdness in detail while presenting (instead,
naturally, you try to brush over it).

Regarding functionality, I really like the list below which we compiled
at our first meeting this year.

Overall, me usually being the pessimist in the group, I am pretty
excited about where we have come (which is a long way!).

- Gerd.

Guy Albertelli II wrote:

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev