Subject: [LON-CAPA-dev] too many binaries in cvs repository

From: Scott Harrison <[email-masked]>
Date: Fri, 1 Nov 2002 10:18:18 -0500

Hi,

It seems (to my dialup connection and my legacy laptop's small hard drive)
that there are too many binaries in the loncapa cvs repository--certainly
when compared to many other software projects.

I do not have a great solution in mind, especially considering
that many of these graphics and other binaries are currently
critical to the loncapa interface (e.g. loncom/html/adm/lonInterFace).

Any ideas?  (Is there a CVS flag which filters out binary files?)

Regards,
Scott

-- 
Scott Harrison, [email-masked]

---

From: Guy Albertelli II <[email-masked]>
Date: Fri, 1 Nov 2002 13:43:55 -0500 (EST)

Hi Scott,

> Any ideas? 

How about a reorganize?

> (Is there a CVS flag which filters out binary files?)

Nope, but you could try pruning your local repository of directories
you don't want and/or heavier user of -l

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-7-7-  O-
    Why do ducks have webbed feet?  To stamp out fires.
    Why do elephants have flat feet?  To stamp out burning ducks.

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 01 Nov 2002 14:45:56 -0500

Please don't change anything in our code repository structure now.

Our biggest challenge is to achieve a stable, reliable, and much-bug-reduced
release. Scott is right, we do have a lot of binaries in CVS, which sucks on a
phone connection, but ... please ... we do have to get a stable release out
the door, and every time we rock the boat, we introduce the possibility of new
bugs and problems.

There have been significant budget cuts at MSU, and a challenge to us repeated
over and over in the NSF site visit is to get out of the pre-competitive mode.

Guy Albertelli II wrote:

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

---

From: Scott Harrison <[email-masked]>
Date: Sun, 3 Nov 2002 22:41:02 -0500

Plaintext files inside modules directory: 2.9 megabytes
Binary files inside modules directory: 2.5 megabytes
Plaintext files for the loncapa cvs checkout: 11.4 megabytes
Binary files for the loncapa cvs checkout: 16.5 megabytes

30+ megabytes across 1600+ files and 133 directories.

I understand now is not the time for reorganization.  But when
it is time, the benefits of a well-structured source code base
could be significant both in terms of portability and the ability
to remember and intuitively find which files to work on.
(And hitting a solid structure sooner rather than later reduces
problems....)

> > you don't want and/or heavier user of -l

Content-Description: Card for Gerd Kortemeyer

--