Subject: [LON-CAPA-dev] authentication

From: [email-masked]
Date: Mon, 4 Apr 2005 18:42:59 -0400 (EDT)

Hi,

I just went to set someone to local authentication. We were still having 
problems logging in as him. I found the password was being stored as clear 
text in the passwd file.

What's the scoop? Have I broken something on this end or is this a bigtime 
bug in 1.3.3? (I have to make a couple of mods for local things - I may 
have missed something in a backport.)

Mark

----------------------------------------------------------------------------
Mark Lucas					email: [email-masked]
252D Clippinger Lab  				phone: (740)597-2984
Department of Physics and Astronomy             fax:   (740)593-0433
Ohio University
Athens, OH 45701

---

From: Guy Albertelli II <[email-masked]>
Date: Mon, 4 Apr 2005 19:36:26 -0400 (EDT)

Hi Mark,

> bug in 1.3.3?

I think it is likely to be something on your end.

lond around line 1737 ish has:

     if ($howpwd eq 'internal') {
         &Debug("internal auth");
	 my $salt=time;
	 $salt=substr($salt,6,2);
	 my $ncpass=crypt($npass,$salt);
	 if(&rewrite_password_file($udom, $uname, "internal:$ncpass")) {

Which looks good to me.

as does line 5474ish

   my $salt=time;
   $salt=substr($salt,6,2);
   my $ncpass=crypt($npass,$salt);
   {
       &Debug("Creating internal auth");
       my $pf = IO::File->new(">$passfilename");
       if($pf) {
	       print $pf "internal:$ncpass\n"; 

-- 
[email-masked]  LON-CAPA Developer  0-7-2-9-

---

From: [email-masked]
Date: Mon, 4 Apr 2005 20:50:11 -0400 (EDT)

Hi,

Mea culpa. It's been so long since I set someone to internal 
authentication that I set them to local authenitlocal authentication 
instead of internal. The plain text password freaked me out, but I just 
realized it's probably because there's no real routine for 
local_authentication 
here.

Later,
Mark

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev
>