Subject: [LON-CAPA-dev] httpi vs. apache

From: Guy Albertelli II <[email-masked]>
Date: Thu, 31 Oct 2002 12:55:29 -0500 (EST)

Hi Gerd,

the lonhttpd (httpi) 

can handle 1/3 as many requests per second as the already running
apache

And takes on average about 2.5 times as long to service a specific
request

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-7-7-  O-
    Explaining the ineffable can be difficult -E.O. Wilson

---

From: Scott Harrison <[email-masked]>
Date: Thu, 31 Oct 2002 16:49:09 -0500

If not httpi, I'm sure there is a lightweight fast solution out there:
http://www.linuxlinks.com/Software/Internet/WebServers/

On Thu, Oct 31, 2002 at 12:55:29PM -0500, Guy Albertelli II wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

-- 
Scott Harrison, [email-masked]

---

From: Gerd Kortemeyer <[email-masked]>
Date: Thu, 31 Oct 2002 20:10:32 -0500

The real question is if httpi keeps Apache from forking a whole bunch of child
processes with >10 MB of non-shared memory while serving loads of small fry
resources. We had implemented this after the access servers died while
swapping memory.

---

From: Guy Albertelli II <[email-masked]>
Date: Fri, 1 Nov 2002 13:34:50 -0500 (EST)

Hi Gerd,

> resources. We had implemented this after the access servers died while

Doing the load testing against apache, the newly forked apache
children were using <1MB of non-shared memory.

Just trying to get some numbers out there.

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-7-7-  O-
    My intuition nearly makes up for my lack of good judgement.