Subject: [LON-CAPA-dev] latest help question

From: Scott Harrison <[email-masked]>
Date: Thu, 11 Apr 2002 13:20:55 -0400

Ron etc,

Given anybody's work with lonc/lond (and ability to describe things),
I would greatly appreciate your help with answering the following
help.lon-capa.org question.

*** QUESTION ***
http://help.loncapa.org/cgi-bin/fom?=&auth=cke336b032e701&editCmds=show&file=58
Can reducing the number of servers in hosts.tab increase efficiency of
my server?

*** ANSWER ***
Shortest answer=Yes.

Shorter answer=
In an ideal sense, NO.  The network connections (lonc/lond)
in LON-CAPA (countable by hosts.tab) are designed to AVOID
reducing the efficiency of the server.

Practically speaking, YES, but the only real efficiency
cost would be due to the probability of connecting to servers
with improperly installed and implemented lonc/lond software.
(We are heavily focused right now on creating the
best possible installation and implementation of lonc/lond,
due to this potential concern.)

The low-cost network connections
(lonc/lond on the TCP/IP layer) are what allow LON-CAPA
to be SCALABLE.  That is, the network should be able to grow
to include a huge number of servers without any noticeable
load beyond the NUMBER OF USERS accessing the web
servers at a given time.

If anything, the more servers you have the more efficient
any one server should be in processing individual
homework/classroom transactions because the load is
balanced across the network.  It is important to PLAN
for having multiple server computers at your institution.

END ANSWER

I want to be reasonably precise.  Does the above answer work?

Regards,
Scott

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: Guy Albertelli II <[email-masked]>
Date: Thu, 11 Apr 2002 13:40:27 -0400 (EDT)

Hi Scott,

> Can reducing the number of servers in hosts.tab increase efficiency of

Future Shortest Answer = No.

Future Shoter Answer = No. The lonc/lond connections are dymanically
brought up and down based off of the timeout field and the max number
of connections fields in hosts.tab

(Ron and I have chatted about ways to improve the lonc/d efficiency and
he is most likely this summer implement a timeout field for
connections and the ability to hve multiple lonc/d connections between
hosts that are talking to each other alot.)

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-9-4-  O-
    I am learning that criticism is not nearly as effective as sabotage.

---

From: Scott Harrison <[email-masked]>
Date: Thu, 11 Apr 2002 13:52:08 -0400

Okay.  I will answer the question more briefly then with a
positive spin

plus

a one-liner about the "only" potential
problem is for machines in the network
with improper lonc/lond implementations.

...

It still is fun and instructive though to give a
DARQUE twist to the world-is-ending-sky-is-falling
aspect of it though. (But uhhh that's just me.)

Regards,
Scott

Guy Albertelli II wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev