Subject: [LON-CAPA-dev] 2.0.2 pre announce

From: Guy Albertelli II <[email-masked]>
Date: Sat, 1 Oct 2005 03:14:41 -0400 (EDT)

Hi All,

So this 2.0.2 is running on MSU machines.

Let me know if I got any typos.

New Version 2.0.2 Released

Some nice cleanups here and there, I'd highly suggest installing.

Notable Bug Fixes:
- 'View Recent Activity' works again
- zombied resources could cause resources to not appear in DOCS
- course db file is once again built from scratch on login
- resource metadata was being cached for 24 hours rather than the expected
   10 minutes
- CODEs are really the specified length
- handgrade problems no longer show up with a difficulty of 1.0 in the
   What's New
- more help on printing added
- encrypted urls were failing to work correctly on SuSE 9.2
- system wide browse possible with a custom role
- lots of bridge task updates
- submitting a file with , in the name no longer confuses essayresponse
- assigning a grade to everone in a class works again
- .exam extension applies to all parts now
- can disable the automatic addition of points to the printout
- modify parameters sorts them more intelligently
- CSV upload creation of slots

To install this update:

1) You will need to be running Fedora Core 2 or 3 or 4, RHEL ES 4, 
      Suse 9.2 or 9.3

2) If running Fedora, use yum to update your machine and then install the
      LONCAPA-prerequisites (if not already installed).

yum update
yum install LONCAPA-prerequisites

    If running SuSE, use you to update your machine.
    if running RHEL, use up2date to update your machine.

3) Download the new LON-CAPA tarball from
wget http://install.lon-capa.org/versions/loncapa-2.0.2.tar.gz

and untar it

tar xzvf loncapa-2.0.2.tar.gz

4) Run the UPDATE script as root
cd loncapa-2.0.2
su
./UPDATE

5) restart the Lon-CAPA system services
/etc/rc.d/init.d/loncontrol stop
/etc/rc.d/init.d/loncontrol start

6) restart the webserver:

Fedora/Red Hat Enterprise:
/etc/rc.d/init.d/httpd stop
/etc/rc.d/init.d/httpd start

SuSe:
/etc/init.d/apache stop
/etc/init.d/apache start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org

-- 
[email-masked]   0-7-2-1-27,137

---

From: Felicia Berryman <[email-masked]>
Date: Mon, 03 Oct 2005 07:49:16 -0400

Hi Guy,

>Notable Bug Fixes:

Should the problem with the ScriptVars link that you fixed for me the 
other day be listed?  Feel free to contact me off the list if this was 
just my problem.

Felicia

---

From: Guy Albertelli II <[email-masked]>
Date: Mon, 3 Oct 2005 10:09:09 -0400 (EDT)

Hi Felicia,

> other day be listed? 

It didn't make the cut off. Sorry, It'll be in a 2.0.3

(The bug affects users who are doing rather odd things in variables
like the hamlin problems might do.)

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Wed, 05 Oct 2005 17:20:14 -0400

Hi Guy, 

Suggested changes:
1) You will need to be running Fedora Core 2 or 3 or 4, RHEL ES 4, Suse 9.2 
or 9.3, or SLES 9 

2)
    If running SuSE, use you to update standard packages on your machine, 
then use yast to (a) refresh your installation sources, and then (b) update 
the LONCAPA-prerequisites package.
    If running RHEL, use up2date -u to update your machine. 

Typos: everyone for everone in 

 - assigning a grade to everyone in a class works again 

Stuart 

Guy Albertelli II writes: 

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev 
>