Subject: [LON-CAPA-dev] <chem>'s a hit how about <num> or <parse> ?

From: Guy Albertelli II <[email-masked]>
Date: Fri, 18 Feb 2005 00:40:19 -0500 (EST)

Hi All,

So 

<display>&prettyprint($number,"3E");</display>
<display>&xmlparse($some_xml);</display>

annoy people, and rightly so.

So I was thinking in the spirit of <chem>

<num format="3E">$number</num>

and

<parse>$some_xml</parse>

Should get made.

Like/dislike?

-- 
[email-masked]  LON-CAPA Developer  0-7-3-2-

---

From: Joshua Tacey <[email-masked]>
Date: Fri, 18 Feb 2005 03:03:58 -0500

Looks good to me, save a lot of typing

josh

---

From: "Guy Ashkenazi" <[email-masked]>
Date: Fri, 18 Feb 2005 10:14:36 +0200

> <num format="3E">$number</num>

Good idea! Maybe do <num>$number:3e</num> instead?
It is less XMLish, but it is faster to write...

    Guy.

---

From: Guy Albertelli II <[email-masked]>
Date: Fri, 18 Feb 2005 03:36:01 -0500 (EST)

> Good idea!

Thanks.

> Maybe do <num>$number:3e</num> instead?

Nah, last thing I want to do is to start inventing syntax.