Subject: [LON-CAPA-dev] Meeting Notes 12-05-2007

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Fri, 14 Dec 2007 14:45:43 -0500

12-5-2007 

Stuart
 - user management - bulk changes to access dates or sections
(in course context) from user listing
 - modifycourse  - fixes so breadcrumb links function on all pages
 - help request, package update alert, and ISE report e-mails sent to
 recipients specified via Domain Configuration
 - Assisted with integration of LDAP authentication and auto-enrollment at 
VCU
A - elimination of ENRL; migration of functionality -> CUSR (in
course context).
 - testing user management changes
 - update s12
 - ./UPDATE check for installation of LONCAPA-prerequisites
 - co-owner addition interface
 - course parameter - show/hide entry in the course catalog
 - s16 replacement (Spamassassin/Anti-virus)
 - visibility of student ids (for Zpid addition)
 - domain coordinator guide 

Guy
 - 2.5.99.0
 - HTMLArea removed from CVS repository
 - s10 out of memory error caused by recursive .page
 - Sort mechanism efficiency improved for collapsing linear maps.
 - Alternative unsorted map data also available (more efficient)
 - Hidden attribute now editable in PARM (as well as DOCS).
 - Edit XML style files smilar interface to edit HTML files in CSTR.
A - account clean-up
 - shipping machinees 

Mark
 - FIRST - exploring additional use cases
A - visit to Purdue (longitudinal midfield database) 

Felicia
 - tickets
A - med school in-lab quizzes.
 - set-up for Board meeting 

Gerd - text entry display/hide option for password input field 

Stefan - updated some German translations

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Fri, 14 Dec 2007 15:30:29 -0500

Meeting Notes 12/12/2007 

Felicia
 - med school online quizzes (IP-restrictions).
 - final exams Q & A
A - Board Meeting
 - MSU Faculty seminars 12/18-12/19
 - Test WYSIWIG, gnuplot fonts, Jmol, Jsmath etc
 - Establish time/place for Spring semester developer meetings 

Stuart
 - DC can set which user information fields can be modified in author or 
course context
 - DC can configure which types of user (any, none, institutional, or 
non-institutional) can be created in author or course context
 - forceID change checkbox only shown when ID changes permitted
 - row counts in course catalog table
 - alternation of row colors correct in "Log-in data" table for picking user 
authentication type
 - For DCs auth option defaults to "Do not change log-in" for existing users
 - List of users includes radio buttons to switch username link
 between "About Me" page and "Modify User"
 - Blank student number/IDs can be made non-blank without requiring forceID 
checkbox to have been checked.
 - update LON-CAPA install scripts to support SuSE 10.3
 - case sensitivity for username in delete actions in allusers MySQL table
 - if portfolio quota was default, show this in user modification result 
page.
 - changes to a user's environment.db via CUSR use lonnet::modifyuser() so 
allusers MySQL table is updated.
 - default quota values displayed correctly on DC's CUSR screen
 - alert when moving COM message to a different folder only shown if no 
destination folder was selected.
 - All user management from a single icon/button/text link
A - fix status validator for entry to MSU training registration form
 - 2.5.99.1
 - MSU faculty seminars 12/18-12/19
 - inline nav/resource separator on MSU production servers for 12/18
 - 2.6 on MSU production servers 12/19
 - remaining user management issues (can create user checking etc.)
 - Test namespacing
 - Test propagation of changes in ID/student number 

Mark
 - FIRST meeting at Purdue (longitudinal study) discussion about 
FERPA-related policies
A - meeting with LC&T about policies for FIRST data access 

Guy
 - fix ISE when grading essay problems for multiple students
 - prevent infinite loop in uri for filelocation,
 - Improve efficiency for DOCS display of top-level folder with lots of 
resources
 - Phil's changes to lonplot to display text on axes 

Ron
 - Added missing post center correction to the div align=center processing 

Stefan
 - update german translations
(added some new translations, optimized others and eliminated some 
duplicates)