Subject: [LON-CAPA-dev] 1.1 plans

From: Guy Albertelli II <[email-masked]>
Date: Tue, 23 Sep 2003 14:17:56 -0400 (EDT)

Hi All,

We had the 1.1 chat and this is what we came up with as out internal
priority list:
 
1. Exams (Scantron, Name free, Student pictures) (Guy)

2. STAT (optionresponse analysis) (Matthew)

3. FDBK improvements (Threaded discussion, move button to on the page)
(?Gerd or Jeremy?)

4. Searchcat.pl needs fixing (Gerd/Matthew)

5. Automated Classlist management (links to university data) (Stuart)

6. What's New? button (???)

7. Localization (Gerd et al)

8. lonManage (automated push of domain.tab/hosts.tab) (Ron)

9. symb hiding (need for 1.2 expected changes) (Gerd)

10. Upload scores improvements (static fields, points not pcr, better
summary of what was done, detection of multiple records) (Guy)

11. install on RH 9/10 (Matthew)

Already done but that need alot more testing
- simple problems
- clone course

Small things that would be nice
- pickcourse in CUSR
- domain defaults to no remote mode
- upload .zip file
- better spare.tab (maybe add config of this to UPDATE)

Large things that if one has time would be nice but probably won't be
done until 1.2ish
- dynamic metadata in MySQL
- activity.log searching

Delayed to 1.2
- conditionals
- timed intervals
- QTI
- student groups
- student classification
- <graceplot>

-- 
[email-masked]  LON-CAPA Developer  0-7-5-6-

---

From: Mark Lucas <[email-masked]>
Date: Wed, 24 Sep 2003 09:51:25 -0400 (EDT)

For those of us out of the loop, what is the timetable for 1.1 and 1.2?

Later,
Mark

----------------------------------------------------------------------------
Mark Lucas					email: [email-masked]
252D Clippinger Lab  				phone: (740)597-2984
Department of Physics and Astronomy             fax:   (740)593-0433
Ohio University
Athens, OH 45701

---

From: Helen Keefe <[email-masked]>
Date: Wed, 24 Sep 2003 09:56:01 -0400

Hi Guy,

What are the timeframes for 1.1 and 1.2?

Helen

Guy Albertelli II wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

---

From: Guy Albertelli II <[email-masked]>
Date: Wed, 24 Sep 2003 15:07:14 -0400 (EDT)

Hi All, 

I excpet 1.1 and 1.2 will stick to our regularly scheduled release
plan.

1.1 should be done Late Nov. Early December.

1.2 should be done Early to Mid Aug.

Bug fix releases will come out on an as needed basis.

---

From: Gerd Kortemeyer <[email-masked]>
Date: Thu, 25 Sep 2003 10:06:58 -0400

> Already done but that need alot more testing

- dump DOCS to Construction Space