Subject: [LON-CAPA-dev] 2.0 email draft

From: Guy Albertelli II <[email-masked]>
Date: Wed, 17 Aug 2005 13:29:37 -0400 (EDT)

Hi All,

2.0 announce email let me know if I mucked anything up, or forgot to
mention any big/nice/important features/changes.

----

New Version 2.0.0 Released

Notable Changes:
- things should be faster
- lots of documentation updates
- /etc/init.d/loncontrol reload (tells lonc & lond to reread hosts.tab)
- internal caching updates faster 
- bridge tasks
- What's New page for Course Coordinators
- SPRS is faster
- Cut, Copy, and Paste items in DOCS
- new tags <chem> <num> <parse> <algebra> ease display of data
- score upload allows more formats and upload by ID
- IMS import of WebCT 4
- New Role 'Assitant Author' for authors that shouldn't have access to 
    anything outside of CSTR
- PARM screens has been reorganized and made easier to use
- DOCS has ability to recover from accidental resource removal
- ability to automate course creation
- format a number to n significant figures 
- scantron support of number and letter formats
- scantron support of numerical CODES and of lengths other than 6
- <m> tag output configurable and authors can optionally force the
   use of a specfic display mechanism
- display partially correct problems improved
- trackstudent can now show full student history
- public browsing users can now interact with all types of problems
- IMS export enabled (We have done WebCT 4.0 -> Lon-CAPA -> WebCT 4.0)
- lots of bugfixes

To install this update:

1) You will need to be running Fedora Core 2 or 3 or 4, RHEL ES 4, Suse 9.2
   (SuSE 9.3, and SLES 9 support is coming soon.)

2) Use yum to update your machine and then install the
      LONCAPA-prerequisites

yum update
yum install LONCAPA-prerequisites

3) Download the new LON-CAPA tarball from
wget http://install.lon-capa.org/versions/loncapa-2.0.0.tar.gz

and untar it

tar xzvf loncapa-2.0.0.tar.gz

4) Run the UPDATE script as root
cd loncapa-2.0.0
su
./UPDATE

5) restart the system services
/etc/rc.d/init.d/loncontrol stop
/etc/rc.d/init.d/loncontrol start
/etc/rc.d/init.d/httpd stop
/etc/rc.d/init.d/httpd start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org

-- 
[email-masked]   0-7-2-3-27,137

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Wed, 17 Aug 2005 16:41:06 -0400

Hi Guy, 

Step 1: 

Typos: 

New Role 'Assitant Author' _change to_ New Role 'Assistant Author' 

use of a specfic display mechanism _change to_ use of a specific display 
mechanism 

Suggested changes: 

_change to_ 

 - IMS export enabled 

[note of explanation: IMS export does not currently re-convert .problem 
files back into QTI-like XML used by WebCT 4, although we do export course 
structure and static files (html, pdf etc.) in IMS format which will 
re-import into WebCT]. 

Suggested addition: (nice, but not necessarily big or important change): 

 - Upload of HTML files to DOCS prompts for embedded images, objects etc. 

Step 2: 

Suggested changes: 

2) If running Fedora, use yum to update your machine and then install the
      LONCAPA-prerequisites.
  If running SuSe, use you to update your machine.
  if running RHEL, use up2date to update your machine. 

Step 5: 

5) restart the Lon-CAPA system services
/etc/init.d/loncontrol stop
/etc/init.d/loncontrol start 

6) restart the web server: 

Fedora/Red Hat Enterprise:
/etc/init.d/httpd stop
/etc/init.d/httpd start 

SuSe:
/etc/init.d/apache stop
/etc/init.d/apache start 

Stuart 

P.S. One thing that I know is still missing from v 2.0.0 ....
A CHECKRPMS.rhel is needed that calls up2date via CLI (I know the long term 
plan is a unified CHECKRPMS). 

Guy Albertelli II writes: 

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev 
>

---

From: Guy Albertelli II <[email-masked]>
Date: Wed, 17 Aug 2005 16:56:57 -0400 (EDT)

Hi Stuart,

Thanks for the suggestions

> plan is a unified CHECKRPMS). 

With no known RHEL users I can wait until 2.0.1 for that.

Let me know if there is anything else. I plan on sending it out around
8 p.m. tonight.

Notable Changes:
- New Role 'Assistant Author' for authors that shouldn't have access to 
   use of a specific display mechanism

To install this update:

2) If running Fedora, use yum to update your machine and then install the
      LONCAPA-prerequisites (if not already installed).

yum update

and untar it

6) restart the webserver:

SuSe:
/etc/init.d/apache stop
/etc/init.d/apache start

----NOTES

-- 
[email-masked]   0-7-2-1-27,137