Subject: [LON-CAPA-dev] LON-CAPA and the 35 CPAN distributions

From: Scott Harrison <[email-masked]>
Date: Sun, 11 Aug 2002 18:26:44 -0400

Dear All:

Note that 12 out of the approximately 33 CPAN distributions
(external to standard perl modules) that LON-CAPA depends on
have been updated since LON-CAPA-systemperl was last generated.

I have almost completed a scary solution for this.

Until then, LON-CAPA walks into a hut with 33 CPAN dwarves
and eats an applet.

Regards,
Scott

-- 
Scott Harrison, [email-masked]

---

From: Guy Albertelli II <[email-masked]>
Date: Sun, 11 Aug 2002 21:52:43 -0400 (EDT)

Hi Scott,

I just want to make sure that you remember that we need a special
patched version of HTML-Parser, based on version 3.26

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-4-  O-
    My intuition nearly makes up for my lack of good judgement.

---

From: Scott Harrison <[email-masked]>
Date: Sun, 11 Aug 2002 23:23:25 -0400

Thanks.

Yes, I have not yet gotten to the autocompile stage
where I was going to begin work on the special stuff...
The patch is currently documented in the soon-to-be-deprecated
doc/otherfiles/perl_modules.txt

I will also remember to check for the patch in the
yet-to-be-committed new version of perltest.pl.

Joy. :)

Regards,
Scott

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev
> ------( NOTE )------------->
> This E-mail was scanned for viruses by Ramcell Online (http://www.ramcell.net/antivirus.asp)
>

---

From: Jeremy Bowers <[email-masked]>
Date: Mon, 12 Aug 2002 16:51:41 -0500

> patched version of HTML-Parser, based on version 3.26

Low priority question: What does the patch to HTML-Parser do? It occurs 
to me that I am almost certainly using a stock version of HTML-Parser 
unless the build sneaks a patch process by me, so I'm curious what I 
should expect to break. (Everything I've tried is working OK, but there 
are chunks of the system I haven't used much yet on my home system, like 
all the course stat stuff; no courses to speak of.) Or perhaps newer 
versions work as the patch does?

(I observe that one side effect of getting LON-CAPA running on my Gentoo 
system is that I'm running a quite different set of program versions 
then traditional installs. Perl 5.6.1 for instance, instead of 5.005.)

---

From: Guy Albertelli II <[email-masked]>
Date: Mon, 12 Aug 2002 16:34:52 -0400 (EDT)

Hi Jeremy,

> Low priority question: What does the patch to HTML-Parser do?

<img src=/path/to/file.gif>

Doesn't get parsed, You would only notice this when trying to print.

(Not that with " in the proper locations it is fine only without does
it not parse the tag.)

This id documented in doc/otherfiles/perl_modules.txt

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-4-  O-
    I have the power to channel my imagination into ever-soaring levels
    of suspicion and paranoia.