Subject: [LON-CAPA-dev] 1.1.99.4

From: Guy Albertelli II <[email-masked]>
Date: Tue, 10 Aug 2004 17:08:08 -0400 (EDT)

Hi All,

New Version 1.1.99.4 Released

Hopefully no changes will be needed between this release and the real
1.2.0 (which should be out on Monday.)

If you can install and run this version I'd really like that. It'll
help stop there being a 1.2.1 that quickly.

Notable Changes:
- lcuseradd and lchtmldir work again
- added/changed servers
- 'Switch Server' link works
- Fedora maintance now much easier through use of yum and dependencies rpm
- grades use part 'display' value
- DOCS reinit button stays up as long as it is needed
- lonindexer notices changes more quickly
- printing large classes won't timeout when converting to PDF
- can upload files to a help request
- replication on a multidomain machine is no longer dysfunctional
- testbank import works in more cases
- nested tables should print better
- lond no longer takes forever to check on children

Known Issues:
- 1.1 servers are unable to host sessions for course running on 1.2
   servers, you will need to upgrade all machines in the cluster at the
   same time. (Or at least the access servers need to be updated
   before the library servers)
- TEST is broken

To install this update:

1) You will need to be running Fedora Core 2 or RedHat 7.3
     for this release to work

2) if you are running RedHat 7.3 and you will need to install the
     3.13 systemperl rpm

First get:
http://install.loncapa.org/resources/LON-CAPA-systemperl-3.13-rh7.i386.rpm

Install it by doing:
rpm -e `rpm -q -a | grep systemperl`
rpm --install --force --nodeps LON-CAPA-systemperl-3.13-rh7.i386.rpm

Verify it is installed by doing:

$ rpm -q LON-CAPA-systemperl

RedHat 7.X will show
LON-CAPA-systemperl-3.13-rh7

3) if you are running Fedora Core 2

   You will need to do things after running UPDATE

4) Download the new LON-CAPA tarball from

RH 7.3:
wget http://install.lon-capa.org/versions/loncapa-1.1.99.4.tar.gz

Fedora Core 2:
wget http://install.lon-capa.org/versions/loncapa-fedora-1.1.99.4.tar.gz

and untar it

tar xzvf loncapa-1.1.99.4.tar.gz
or
tar xzvf loncapa-fedora-1.1.99.4.tar.gz

5) Run the UPDATE script as root

cd loncapa-1.1.99.4
su
./UPDATE

6) If you are running Fedora Core 2 you will need to use yum to update
     your machine and then install the LONCAPA-prerequisites

yum update
yum install LONCAPA-prerequisites

7) restart the system services
/etc/rc.d/init.d/loncontrol stop
/etc/rc.d/init.d/loncontrol start
/etc/rc.d/init.d/httpd stop
/etc/rc.d/init.d/httpd start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org

-- 
[email-masked]  LON-CAPA Developer  0-7-3-9-

---

From: "H. K. Ng" <[email-masked]>
Date: Wed, 11 Aug 2004 09:42:47 -0400

I got this warning when loncapa 1.1.99.4 was installed on a brand new 
server. LON-CAPA-systemperl-3.13 is installed.
- hk

WARNING: LON-CAPA-systemperl-3.10 does not appear to be installed.

---

From: "Matthew Brian Hall" <[email-masked]>
Date: Wed, 11 Aug 2004 12:27:14 -0400

> WARNING: LON-CAPA-systemperl-3.10 does not appear to be installed.

Thanks for reporting this.   It's (now) taken care of for the 1.2 release. 

Matthew 

 ---------------------------------------
Matthew Hall           [email-masked]
LON-CAPA developer
Michigan State University
 ---------------------------------------