Subject: [LON-CAPA-dev] Re: ./TEST errors

From: Helen Keefe <[email-masked]>
Date: Fri, 02 Aug 2002 16:51:16 -0400

Hi Steve,

I am forwarding your message to the programmers' list, since they are
more likely to help with solving your problem than me.

If you don't hear from someone soon, please contact me and I will ask
Guy or Matthew to assist you.

Helen

Steve Bellenot wrote:
> 
> This is for your information, an error with a fix that doesn't quite
> fix it.
> 
> I'm trying to install loncapa-0.4 on a redhat7.2 system.
> 
> ./TEST says I'm missing
> a bunch of (perl mods) stuff and to download
> LON-CAPA-systemperl-3.4-rh72.i386.rpm
> and run
> rpm -Uvh --force LON-CAPA-systemperl-3.4-rh72.i386.rpm
> But it looks like the perhaps there are two modules
> still missing.
> 
> ./TEST still fails, it says I'm still missing
> MISSING Apache/File.pm
> MISSING Apache/Constants.pm
> 
> Here is the full text:
> root 611#> ./TEST
> /tmp/loncapa-0.4/loncom/build
> TESTING LPML INSTALLATION CODE
> cd ../test; perl filecomparetest.pl
> Test 1...ok
> Test 2...ok
> Test 3...ok
> Test 4...ok
> Test 5...ok
> Test 6...ok
> Test 7...ok
> Test 8...ok
> Test 9...ok
> Test 10...ok
> Test 11...ok
> Test 12...ok
> Tests: 12/12 successful (100.0 %)
> TESTING SYSTEM DEPENDENCIES
> cd system_dependencies; make
> /tmp/loncapa-0.4/loncom/build/system_dependencies
> make[1]: Entering directory `/tmp/loncapa-0.4/loncom/build/system_dependencies'
> perl perltest.pl
> Scanning for perl modules...
> MISSING Apache/File.pm
> MISSING Apache/Constants.pm
> You are missing perl modules on your system.
> Please visit: http://install.lon-capa.org/3.1/latestRPMS/
> Download an RPM looking like: LON-CAPA-systemperl-*.*-rh72.i386.rpm
> Upgrade: rpm -Uvh --force LON-CAPA-systemperl-*.*-rh72.i386.rpm
> (Note that you will need to replace the '*' asterisks with
> the most up to date version number present within the latestRPMS
> directory.)
> make[1]: *** [perltest] Error 2
> make[1]: Leaving directory `/tmp/loncapa-0.4/loncom/build/system_dependencies'
> make: *** [TEST_system_dependencies] Error 2
> 
> --
> http://www.math.fsu.edu/~bellenot
> bellenot <At/> math.fsu.edu
> +1.850.644.7189 (4053fax)

-- 
Helen Keefe
LON-CAPA/ ITR Project Manager
Laboratory for Instructional Technology in Education
111 North Kedzie Labs
East Lansing, MI 48824

E-mail: [email-masked]
Web:   http://www.lite.msu.edu/
Phone: 517-432-9867
Fax:   517-432-5653

---

From: Scott Harrison <[email-masked]>
Date: Fri, 2 Aug 2002 17:18:30 -0400

Dear Steve:

Are you running RH7.2 or RH7.3?

Apache/File.pm is part of the mod_perl software package.

Is it on your system?
(find /usr/lib/perl5 -type f -maxdepth 1000 | grep Apache/File.pm)

Regards,
Scott

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

-- 
Scott Harrison, [email-masked]

---

From: Scott Harrison <[email-masked]>
Date: Sat, 3 Aug 2002 11:38:08 -0400

Dear Steve:

> I think that I still have serious perl/version problems. Currently
> apache will not start and ./TEST fails because it cannot connect to
> mysql.

/usr/bin/perl --version
   Does it say "This is perl, v5.6.1"
or does it say "This is perl, v5.6.0"?

> Unfortunately, I can't just start over as the machine is used by
> others, so I can't upgrade to 7.3. (It is RH7.2). The machine was
> also configured to match a solaris network which had /home automounted
> but I'ved turned this off for the moment.

My current recommendation is that:
  LON-CAPA run on a dedicated server that *only* runs LON-CAPA.

It makes the installation very straightforward
  (see http://install.lon-capa.org/docs/install/rh73.html)

And prevents potential conflicts with other server activities
as well as when many students are using a LON-CAPA server
(right before a homework deadline), there is significant CPU
and memory load.

> There are three (lightish) activities on this machine one of which 
> already uses perl/apache but I've seemed to have broken apache.
> 
> I saw the CHECKRPMS script and I sort of hope it would give me a
> list of things to install. It said I needed things but not what.

CHECKRPMS should produce output like this:

bash-2.05$ ./CHECKRPMS 
Using mirror.pa.msu.edu for ftp transaction...(please be patient)
**** WARNING **** You need to update at least 25 RPMS shown in 
the list below.  THIS IS IMPORTANT FOR SECURITY.

apache-1.3.22-6.i386.rpm
apache-1.3.22-6.i386.rpm
apache-1.3.22-6.i386.rpm
cpp-2.96-108.7.2.i386.rpm
gcc-2.96-108.7.2.i386.rpm
.
.
.

Instead, try running commands like:
perl loncom/build/check-rpms -ftp distro.ibiblio.org/pub/linux/distributions/redhat/updates/7.2/en/os

perl loncom/build/check-rpms -ftp limestone.uoregon.edu/redhat/updates/7.2/en/os

perl loncom/build/check-rpms -ftp opnsrc.support.compaq.com/linux/redhat/updates.redhat.com/7.2/en/os

until you find an FTP server that works.  For a list of RedHat mirrors,
visit http://www.redhat.com/download/mirrors.html

> And checking 
> root 683#> rpm -i perl-DBI-1.18-1.i386.rpm 
> file /usr/lib/perl5/site_perl/5.6.0/i386-linux/Bundle/DBI.pm from install of perl-DBI-1.18-1 conflicts with file from package LON-CAPA-systemperl-3.4-1

Recommended action:
rpm -i --force perl-DBI-1.18-1.i386.rpm

Even though you are working RH72 instead of RH73, you can still
closely follow the actions and steps given in doc/install/redhat7.3/install.pl.

This will, at least, help get all the packages you need for MySQL.

LON-CAPA-systemperl was a necessary in-house implementation of
MySQL+PerlDBI for RedHat 6.2.

RedHat 7.* can and should just use the standard MySQL and PerlDBI
RedHat rpms.

Regards,
Scott