Subject: [LON-CAPA-dev] browsing db files

From: "P. David Flammer" <[email-masked]>
Date: Mon, 27 Jan 2014 18:26:40 -0700

I would like to browse some of the db files, to get a better feel for how
the data is being stored. Unfortunately, outside of writing a perl script to
do it, I can't seem to find an efficient way to browse them. Is anyone aware
of a program (on linux) that has the ability to dump the contents to plain
text or to browse them?

Thanks,

David

---

From: Gerd Kortemeyer <[email-masked]>
Date: Mon, 27 Jan 2014 20:31:13 -0500

Hi,

On Jan 27, 2014, at 8:26 PM, P. David Flammer <[email-masked]> wrote:

> I would like to browse some of the db files, to get a better feel for how the data is being stored. Unfortunately, outside of writing a perl script to do it, I can’t seem to find an efficient way to browse them. Is anyone aware of a program (on linux) that has the ability to dump the contents to plain text or to browse them?

http://source.lon-capa.org/cgi-bin/cvsweb.cgi/loncom/debugging_tools/dump_db.pl

- but what in the world do you want to do with this?! :-)

- Gerd.