Subject: [LON-CAPA-dev] make build and capa.so

From: Scott Harrison <[email-masked]>
Date: Tue, 12 Nov 2002 20:41:33 -0500

Hi Guy:

Any illuminating ideas?  This is based on a fresh checkout
and "make build":

cp caparesponse.pm blib/lib/caparesponse.pm
cp Makefile.pl blib/lib/Makefile.pl
cp capa.pm blib/lib/capa.pm
gcc -c  -I../../../CAPA/pProj -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -march=i386 -mcpu=i686   -DVERSION=\"\" -DXS_VERSION=\"\" -fpic "-I/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE"  -g -O0 -D_GNU_SOURCE -DPERL_POLLUTE capa_wrap.c
capa_wrap.c: In function `_swig_create_magic':
capa_wrap.c:411: warning: assignment from incompatible pointer type
capa_wrap.c:412: warning: assignment from incompatible pointer type
capa_wrap.c: At top level:
capa_wrap.c:502: conflicting types for `boot_capa'
capa_wrap.c:426: previous declaration of `boot_capa'
make[2]: *** [capa_wrap.o] Error 1
make[2]: Leaving directory `/home/harris41/cvs/loncapa/loncom/homework/caparesponse'
cp: cannot stat `blib/arch/auto/capa/capa.so': No such file or directory
Can't locate loadable object for module capa in @INC (@INC contains: /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendor_perl .) at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 117
	DynaLoader::croak('Can\'t locate loadable object for module capa in @INC (@INC c...') called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 195
	DynaLoader::bootstrap('capa') called at capa.pm line 7
make[1]: *** [../../loncom/homework/caparesponse/capa.so] Error 255
make[1]: Leaving directory `/home/harris41/cvs/loncapa/loncom/build'
make: *** [build] Error 2

Regards,
Scott

-- 
Scott Harrison, [email-masked]

---

From: Guy Albertelli II <[email-masked]>
Date: Thu, 14 Nov 2002 16:48:07 -0500 (EST)

Hi Scott,

> Any illuminating ideas?  This is based on a fresh checkout

My guess is the older swig we specify is nolonger creating proper
headers for perl 5.8.0

Build fine on 6.2 7.2 and 7.3 RH.

Some googling leads me to
http://lists.debian.org/debian-perl/2002/debian-perl-200209/msg00020.html

Which seems to support my theory.

We may need to recomend a new swig RPM for 8.0.

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-7-7-  O-
    No man is an isthmus.