Subject: [LON-CAPA-dev] sysadm goals

From: Scott Harrison <[email-masked]>
Date: Mon, 25 Feb 2002 12:14:01 -0500

Dear All:

*** WHAT ***
With the goals of:
* having an automagic system administration vanilla layer
* having an interface to automate hosts.tab updating and 
* having an interface to view rpm status with
  Martin's new check-rpms script
* and organizing the other monitoring and configuration
  scripts/interfaces that are building up
* And keeping this secure (probably under something other than
  htpasswd????)

*** HOW ***
I WOULD SUGGEST that we either:
* add a sysadm (or adm) button to 
  domain coordinator
And/Or create a new user type called system administrator.

Of course, some system monitoring should be under the
htpasswd layer and accessible outside of the LON-CAPA
web interface.

*** WHY ***
Protecting rpm status viewing is important because
we want to have an option where rpms are downloaded
and perhaps perhaps perhaps installed through the
web interface.

It really is too much to expect someone at every institution
to read Edward Bailey's "Maximum RPM".  Or to even type
"man rpm" and read the ten pages of documentation there.
(Or to ever type "man anycommand"...)

Alternatively, we can name the button "HANDHOLD"...
ADM is an oblique name since everything is administration.

Also, I would like to own a new bugzilla component called
System Administration.

I'm not as cynical as I sound...... hmmmmm...... I'm open
to other ideas for the button naming, user role type, and
access-handling architecture for all this...

Regards,
Scott

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: Felicia Berryman <[email-masked]>
Date: Mon, 25 Feb 2002 12:29:58 -0500

Hi Scott,

> And/Or create a new user type called system administrator.

I like the new user type better.  For example, I can see myself, a
domain coordinator, also as a system administrator.  I don't think
domain coordinators for the physnet group want the risk of system
administrator though.  The physnet group does want multiple users to
have the ability to be a domain coordinator though.

> ADM is an oblique name since everything is administration.

Don't take this personally Scott - I hate the name "HANDHOLD".  I can
add new printers to the printcap file AND I can use printtool.  I choose
printtool almost always.  I don't think of it as HANDHOLDing, just and
easier interface.  This is still a crappy name, but I think "GUI ADM" is
more along the lines.  In fact, a button on the remote control that says
"ADM" or "RPM" seems the most intuitive to me.

Felicia
--
Felicia Berryman
LON-CAPA Coordinator
Michigan State University
  Email:  [email-masked]
  Phone:  (517)432-9866  
http://www.lon-capa.org

---

From: Scott Harrison <[email-masked]>
Date: Mon, 25 Feb 2002 12:50:01 -0500

Dear All:

In a positive sense, I like "HANDHOLDing".. that's why
my research cluster runs redhat as opposed to slackware.
(Of course, I was using the term in a humorful sense...but
yes it is a silly choice.)

I understand.. a well-defined interface (a "car") is superior to 
a toolbox (nuts, bolts, screwdriver, etc and do-it-yourself manual
to build the car with).

A new user type called system administrator makes even more
sense, since at some point we want them to select from a more
meaningful range of choices than "ADM"...

In other words, use your RPM button idea, and maybe have
ADDHOST, REMOVEHOST, etc.

(There is a small caveat to an interface which is it must work very
well... my experience with linuxconf (not necessarily printtool)
is that it mucks things up occasionally and I prefer the certainty
of manually editting a significant range of configuration files.)

But the larger issue which I think we all see is that there is
truly too much uncertainty (and chance for human error) without
any vanilla layer.

Ship-em-a-blank-computer-and-make-em-write-all-the-software Regards,
Scott

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

---

From: Guy Albertelli II <[email-masked]>
Date: Mon, 25 Feb 2002 17:31:54 -0500 (EST)

Hi Scott,

> And/Or create a new user type called system administrator.

I like this idea best.

Note we already have a user type "Adminstrator" so maybe a better name
is still needed.

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-9-8-  O-
    In the force if Yoda's so strong, construct a sentence
    with words in the proper order then why can't he?

---

From: Felicia Berryman <[email-masked]>
Date: Tue, 26 Feb 2002 17:02:31 -0500

Hi Scott,

> yes it is a silly choice.)

I'm not arguing your idea.  I like it very much.  I just find the term
"handhold" offensive.  It makes me think that I need the "special"
interface instead of the "safe" interface.  (Think of "special" in the
politically correct "special" needs population sense).  

Most users that install CAPA have added many users to their systems, but
have never edited the passwd file directly because they are used to GUI
tools.  I think your idea makes perfect sense.  Many administrators are
going to be coming from a windows background instead of a Linux
background and are going to expect to see administration tools that you
suggested.

Felicia

---

From: Felicia Berryman <[email-masked]>
Date: Wed, 27 Feb 2002 12:52:50 -0500

Hello,

It seems that Scott and I are in a heated debate over the work
"handhold".

Scott gave me a bunch of other suggestions which I liked.  If Scott
implements "Handhold", there is nothing I can do about it.  I just
personally hate the word.  Maybe it's just me.  

Because many CAPA users are familiar with asking me for help, I propose
the button "Felicitous System Guru".  Plus, Akos has been calling me
"Guru" for about 2 years now :-)

Please vote for your favorite at:

http://oscar.lite.msu.edu/veryimportantsurvey.html

:-)

Felicia

---

From: Scott Harrison <[email-masked]>
Date: Wed, 27 Feb 2002 13:32:02 -0500

What the )@(#*$_)@(*_)@#&

I AGREE THAT WE SHOULD NOT HAVE HANDHOLD AS A TERM.

How many times/ways can I say it?

What is going on here?

For crying out loud.  Where is the heated debate and
where is the notion that I'm going to implement the
"handhold" term.

AHHHHHHHHHHHHHHHHHHHH!!!!!!!!!!!!!!!!!!!!!!!!!!!

Cut it out.

Regards,
Scott

---

From: Helen Keefe <[email-masked]>
Date: Wed, 27 Feb 2002 13:51:36 -0500

Hi Felicia,
I voted.
I think you should get your choice because of the historical relevance,
and because you're almost a movie star, and almost champion athlete.

Helen

-- 
Helen Keefe
LON-CAPA/ ITR Project Manager
Laboratory for Instructional Technology in Education
111 North Kedzie Labs
East Lansing, MI 48824

E-mail: [email-masked]
Web:   http://www.lite.msu.edu/
Phone: 517-432-9867
Fax:   517-432-5653

---

From: Scott Harrison <[email-masked]>
Date: Wed, 27 Feb 2002 13:59:06 -0500

Okay.. okay... I get it.. Felicia was being funny.

Sorry if I was misreading.

Ahh..

Regards,
Scott