Subject: [LON-CAPA-dev] Tentative Perliminary GUTS schedule

From: Guy Albertelli II <[email-masked]>
Date: Thu, 30 May 2002 14:37:01 -0400 (EDT)

Hi All,

Hopefully someone will file in times/breaks/lunches etc.

Day 1 (June10th)

Gerd            - Intro/Demo -- lonc/d replication and load balancing
Gerd or Matthew - Apache Handlers (loncapa_apache.conf) - auth- access
                   handlers - session environment overview
Guy             - Roles + lonnet/loncommon useful functions 
Guy             - How to install - proper test/debug cycle for
                  handlers - coding/documentation guidelines
Guy             - Worktime (make a new handler, debugging/testing)

Day 2 (June11th)

Gerd            - Roles - data storage - parameters
Matthew         - spreadsheet
Gerd            - publication - content maps - course maps
Guy             - xml handler (simple tags, globals, multiple targets,
                               style files)
Guy             - Worktime (store (temp/remote) data - hash <-> dbfile
                            mapping - make a new tag)

Day 3 (June12th)

Guy             - problem engine / specialty targets (grade/edit/print)
Matthew         - statistics/chart
Gerd            - lonsql
Guy             - CVS / bugzilla intro
Guy             - worktime (undirected)

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-5-  O-
    The next time the universe knocks on my door, I will pretend I
    am not home.

---

From: Scott Harrison <[email-masked]>
Date: Thu, 30 May 2002 16:11:19 -0400

Dear Guy:

> Guy             - How to install

If it helps, you can look at and/or use the current pdf installation manual
http://install.lon-capa.org/index.pdf.

This is built by "make pdfdoc" in loncom/build/Makefile.
The current index.pdf is several weeks old with respect
to CVS->doc.

In the future, plans are for this to be the authoritative
installation/upgrade/configuration manual.

It would be nice to get it up to speed.
Now may/may not be the best time to do that.

Regards,
Scott

-- 
Scott Harrison, [email-masked]

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 31 May 2002 09:22:22 -0400

I am currently putting together the GUTS manual, which is quite a lot of
work. Since we do need to have this printed, I would like to have it done
by Tuesday to meet deadlines.

Please send me anything you would like to have included in the manual for
your session whenever it is ready - even if it is only a small part.

I would like have both the content material and the exercises in the
handout.

A good way might be to check it into CVS and give me the filename.

Thanks!

- Gerd.

Guy Albertelli II wrote:

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

---

From: Guy Albertelli II <[email-masked]>
Date: Wed, 5 Jun 2002 22:44:11 -0400 (EDT)

Hi Scott,

> http://install.lon-capa.org/index.pdf.

BTW, this doesn't appear to exist, ist is a 0 byte file on
install.loncapa.org

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-4-  O-
    I honor my personality flaws, for without them I would have no
    personality at all.

---

From: Scott Harrison <[email-masked]>
Date: Thu, 6 Jun 2002 02:58:15 -0400

Dear Guy:

Fixed.

Note that the contents are very similar to the web pages.

Regards,
Scott

---

From: Guy Albertelli II <[email-masked]>
Date: Thu, 6 Jun 2002 03:07:51 -0400 (EDT)

Hi Scott,

> Fixed.

Thanks.

> Note that the contents are very similar to the web pages.

Yep I generated a version locally. (Thought I might suggest that your
test check if html2ps is in the path before assuming it isn't
installed. I modified the Makefile by hand.)

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-4-  O-
    Well I best be going . . . crack don't smoke itself you know 
                                           -C.Chambers