Subject: [LON-CAPA-dev] capa-converter files

From: Scott Harrison <[email-masked]>
Date: Fri, 26 Apr 2002 11:31:50 -0400

Is it correct to say that all files within loncom/homework/CAPA-converter
are dependencies for building caparesponse.so?

-- 
Scott Harrison, [email-masked]

---

From: Guy Albertelli II <[email-masked]>
Date: Fri, 26 Apr 2002 12:35:18 -0400 (EDT)

Hi Scott,

> are dependencies for building caparesponse.so?

Nope.

All the files in CAPA-convertor build the convert binary, and even
then only a subset are used.

additionally convert is not and official part of loncapa

caparesponse.so is built out of the files in loncapa/CAPA/pProj

Depends are:
capaLexerFun.c capaParserFun.c capaFormulaParser.c capaFunction.c \
capaParserUtils.c capaMapExpr.c capaUnit.c com.c linpack.c ranlib.c \
capaCgiUtils.c capaSubjective.c capaRQO.c capaFormulaLexer.c \
capaFormulaParser.c capaCommon.c

And 

capaToken.h -> capaGrammarDef.y

capaForumla.h -> capaFormula.y

capaParserFun.c -> capaGrammarDef.y

capaLexerFun.c -> capaLexerDef.flex capaToken.h

capaFormulaParser.c -> capaFormula.y

with (->) means "is generated from"

GLabel.class can get built from GLabel.java in loncapa/CAPA/JavaTools

I don't believe LON-CAPA dpends on any other part of CAPA
-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-9-  O-
    ...nobody messed with Don Quixote. He was nuts.

---

From: Scott Harrison <[email-masked]>
Date: Sun, 28 Apr 2002 01:22:53 -0400

> caparesponse.so is built out of the files in loncapa/CAPA/pProj

Also, I think you needed to mention
capaCommon.h
ranlib.h
capaCGI.h
capaFunction.h
capaRQO.h
capaParser.h
lex_debug.h

Yes???

Regards,
Scott

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

Whatever you do will be insignificant, but it is very
important that you do it. --Mahatma Gandhi

---

From: Guy Albertelli II <[email-masked]>
Date: Sun, 28 Apr 2002 13:39:00 -0400 (EDT)

Hi Scott,

> Also, I think you needed to mention

Yep, Sorry forget the headers.