Subject: [LON-CAPA-dev] Meeting Notes 6-14-2007

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Thu, 26 Jul 2007 13:25:38 -0400

06-14-2007 

Gerd - Meeting on clickers. LON-CAPA's proposed solution where students 
"register" their clicker in their user profile across classes/semestera 

 - Work on clicker functionality 

 - Contacted sys admins about 2.4.0 

 - Intramural grant on Research in Online Learning Environments was 

unfortunately turned down 

 - Working with Financial Times reporter. She will likely visit Georgetown 
University and MSU within the coming month 

 - New domains: John Abbott, Palomar, Pewamo-Westfalia 

A- Finish up clicker functionality 

 - Write up budget request for coming fiscal year 

 - Invoice from UIUC on conference 

Phil - gnuplot enhancements 

A - template courses for thedump 

 - more gnuplot (style focus) 

Mark - FIRST project
       - REU students exploring PDF parsing 

 - cpath budget manipulations 

A - NSF panel 

Felicia - met with Kathy Lovell  (outreach to other institutions?) 

 - Reza's BT documentation 

 - workshop logistics 

A - move lovell files to immunology, bmb-medschool 

 - more logistics for workshop 

 - framework for author manual (cf CC manual) 

 - explore idesa re: printing user-specified chunks of manual 

Rick - bug 5143 - role descriptions for TA, IN etc 

A- traverse bug list, new assignments? 

Guy - propagation of part_0 

 - declutter res removal causing issues (simple pages) 

 - log-linear (not in 2.4.1), log-log gnuplot 

 - proof of concept on random order in a sequence 

 - portfolio upload follows href links 

 - lonmaxima: killing finished clients with system calls instead of Expect 

 - maxima: some distros sensitive to working directory 

 - hostids on multidomain machine
A - 2.4.1 general release e-mail 

 - integrating Phil's changes 

 - randomized order in .sequence 

 - review author usability study 

 - portfolio upload -> follow references 

 - add error message on bad ranges in gnuplot with log scaling 

Stuart  - hardware review 

 - SuSE 9.3 on Xen 

 - fix to register.pm 

 - update price quotes cse101 hardware 

 - contact wolfenbuttel re maxima. 

A - FC7 installation instructions 

 - order cse10 RAID key/DIMM _+ cage 

 - updates production FC3/4 -> FC7 

 - bug list exploration

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Thu, 26 Jul 2007 13:28:32 -0400

6-21-2007 

Guy - sequence restoration from zombie state now works 

 - lonmaxima understands parentheses in formularesponse 

 - icon for paste buffer 

 - domain info included in student portfolio file metadata 

 - lonc reconnect more targeted 

 - integrated Phil's changes in lonplot (line width) 

 - course can specify math display engine 

 - fix directory location for jsmath fonts 

 - e-mail verification for lonparmset supports more cases 

 - lonrights supports user-specific rights (uncommitted) 

A - look at .page issues for CSM course 

 - work on random ordered sequences 

 - more robust paste buffer in londocs 

 - 2.4.2 ?? 

Rick - bug reconciliation 

 - bug 3796 - browse for image files (listed files restricted to image files) 

 - lonindexer familiarization 

A - 4733 lonindexer - select multiple resources at once via checkbox for 
folder 

Felicia - logistics for Teachers' workshop 

A - Teachers' workshop 

 - maybe create accounts (if MSU server for workshop) 

Phil - gnuplot linewidth 

 - looking at more font options in gnuplot 

A - contact teachers about courses to offer as template courses for cloning 

 - thedump requests in RT 

 - Teachers' workshop 

Stuart - Fedora 7 install instructions 

 - work on cloning capability for DCs (uncommitted) 

 - relational database for bs111 SIRS data 

 - ordered cse101.lite hardware 

A - Teachers' workshop 

 - order refurbished parts for PE440 tape drive/controller 

 - multidomain amalgamation for s12, nsdl, demo? 

 - wandering bug list 

Gerd - clicker preferences 

Ron - scantron grading: radiobutton response for > 10 foils 

     span multiple lines.

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Thu, 26 Jul 2007 13:31:33 -0400

6-28-2007 

Rick - lonindexer check all and uncheck all 

A - remember which were checked when opening/closing folders 

(look at breadcrumbs code for possible re-use) 

Guy - rights file interface allows users to be included 

 - fix printing .page files 

 - add repcopy for domain images 

 - CAT button on .pages with encrypted URLs 

 - TA roles now have access to all grading functionality for encrypted 
resources 

 - PPRM buttom conforms to privs in .page 

 - CLI for adding dc role 

 - encryption moved from loncommon -> lonnet 

A - 2.4.2 likely 

 - look at transparency issue for png icons in IE 

 - more work on random order in sequences 

 - paste buffer in londocs 

Gerd - new domains 

 - meetings with Med School - Bridge Task functionality? 

 - clickers (support additional vendor?) 

A - budget for 2007-8 

 - presentation/workshop McMaster 

Mark  - NSF review panel 

 - Bridge Tasks - discussions with Jane Rice 

 - FIRST (IMS stuff etc) 

A - Meeting with TE408 

Stuart - Centos and Scientific Linux for 32 bit 

 - clean up course creation for restriction on cross-domain cloning 

 - Teachers' workshop 

A - bug fixing 

Felicia - Teachers' workshop

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Thu, 26 Jul 2007 13:36:12 -0400

7-05-2007 

Felicia - Looking at non-credit enrollment for LIR 

A -  bug reporting - bugs identified in Teachers' Workshop 

 - Training for Human Medicine 

Mark - more FIRST work 

A - exporting BS111 homework data 

 - out at OSU 

Phil - Teachers' workshop follow-up 

 - adding problems to thedump 

 - re-order Chemistry section in thedump 

A - template courses in physics 

 - update LON-CAPA student guide to conform with 2.4 

Gerd - McMaster presentation (LON-CAPA to be one of two centrally 

supported LMS) 

 - med school group
  - using custom response
  - want to retrieve the
raw student submission 

 - clickers - interwrite PRS supported 

A - clicker work - documentation (including images) 

 - out 7/9 - 7/17 prep: study abroad program 

Stuart - batchcreation more logging 

 - cloning restriction code moved to loncommon 

 - loncreateuser - access institutional data when creating users 

A- commit loncreateuser work 

 - more bugs (e.g., COM) 

 - looking into Jenzabar datafeeds
 - restrict user creation by CCs to within a domain 

 - CampusSource inc 2.4.2 

 - order parts for PE4400. 

Guy - lonusersate now using randompickseed 

 - work on random ordering 

  - radiobutton response - random order tied down for a target 

 - londocs xhtml compliant, top menu bar can now wrap 

 - paste buffer more persistent, single paste buffer shared by 

main/supplemental 

 - @ sign allowed in usernames 

 - icon transparency fix for IE 

A - 2.4.2 -> s* 

 - looking for feedback on randomly ordered sequences (printed exams 

not supported) 

 - bug list trawling 

Ron 

 - print right header when print all resources 

 - printing tables was putting borders when html didn't want them 

A - data validation for multi-line scantron 

Rick - 4773 lonindexer - check all completed 

A - bug list to satisfy user dreams

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Thu, 26 Jul 2007 13:50:29 -0400

7-12-2007 

Guy - uncheck/check all buttons show only when usable in lonindexer 

 - essayresponse now operative for .page 

 - nested folders no longer show resources in multiple locations in 

spreadsheet 

 - external resource editable via DOCS 

 - icon for courses button 

 - wording changes on edit course docs 

 - lonmaxima code documemtation 

 - capaLexerDef.flex now supports flex 2.5.33 

 - groupsort headers fixed 

 - restores correct resource by ID 

 - Advanced RAT work 

 - loncommon POD 

A - restore of deleted resources from advanced RAT 

 - 2.4.2 to go out 

 - Teachers' workshop bugs 

Rick - help display in pop-up? 

A - lonindexer - check cleanliness of page after selections 

Phil - dump tickets
      - some are multiple resource addition requests 

      - added about 50 resources + 30 others tested 

 - reworked user guide 

 - chemistry re-ordering almost done 

A - request template course 

 - more dump addition request tickets 

Felicia - Med school training 

 - print testing for Med school from testbank import 

 - would like to be able to print metadata with resource from a library 

(bug report to follow) 

 - met with LIR 

A - LIR - essay exams -> import to LON-CAPA (also to BT), to provide options 

 - look at submission record for a BT in CSE (will this data suffice for 

med school needs?) 

 - spreadsheet for re-use in med school 

Stuart - ubuntu installation (32 bit) - deb packages built.
      -  apache  needs work (seg faults when running startup.pl). 

 - 64 bit packages and yum.conf for Centos5 

A - createuser institution integration 

 - createuser restriction 

 - plagiarism checking 

Gerd - clicker documentation 

 - templates for multi-answer problems

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Thu, 26 Jul 2007 13:58:08 -0400

7-19-2007 

Future meetings discussion. Agreed on new time: 

Wednesday 10 -> 11 in 212 NKL starting 8/29 (room res. 10 -12). 

Felicia - BT for Med School 

 - prep for MSU IT conference (8/1) 

A - out 7/26-7/27 

 - LIR: exams -> essayresponse or BT? 

 - CHM: create sty file for printing metadata 

      create custom spreadsheet for CHM - by mid-Aug 

Alex - setup up FGCU server 

A - server installation continuing 

Mark - attended workshop on STEM infrastructure at OSU 

    - using Moodle for gathering data from students' taking concept
inventories (most likely multiple-choice).
     - plan to use Shibboleth for authentication 

A - FIRST database group 

Phil - dump problems - 39 added 

 - Chemistry re-ordering largely complete 

 - work on update student guide 

 - template course to include all physics resources in dump (~ 200) 

A - send out chem re-organization 

 - complete student user guide 

 - having fun 

Stuart - Disable display of icons/buttons except direction arrows in 

PARM 

 - student-viewable roster - can be set to be opt-in. 

 - hardware - peripheral bay for fifth drive. 

 - createuser interfaces to institutional directory 

 - ITOG 

A - plagiarism checking 

 - complete createuser work 

 - commit the lonviewclasslist 

Rick - 5080 help pop-up even if remote control disabled 

 - bug 5084 - select image warns in CSTR if index selected but not saved 

before leaving page 

A - bug 2023 download tarball of CSTR 

 - more bugs need to be assigned. 

Guy - advanced RAT now supports recovery of multiple IDs 

 - Paste buffer supports inclusion of multiple pastes of same sequence 

 - usernames containing underscores work with rights file 

 - rights update faster 

 - DOCS warning about possible grades loss not displayed if resource does not 
have associated
grades 

 - unwanted persistemnce of supplemental DOCS target when using DOCS no 

longer occurs 

 - resize browser when launching Remote Control stopped 

 - COM default to INBOX not last visite folder 

 - e-mail address displayed in CC's view of classlist 

 - help now initializes properly (was causing tth errors) 

 - random ordered sequences fixes.  Feedback welcome 

 - 2.4.2 out 

A - 2.4.99.0 

 - support for imageresponse in .page.  Honors submit button for 

submission not click (location ID only).