Subject: [LON-CAPA-dev] Version 1.2.1

From: Guy Albertelli II <[email-masked]>
Date: Thu, 30 Sep 2004 16:35:28 -0400 (EDT)

It's uploaded and ready to go.

Let me know if there are any problems in this announcement.

New Version 1.2.1 Released

Codename "Speedy"

Enhancements:
- bug in groups management when creating filesystem authenticated users fixed
- loncnew would rapidly ocillate connections under very high loads
- idle loncnew are really idle
- fixes in autoenrollment for locked students
- can now scantron grade 'hidden' folders
- unfilled in bubbles now generate warnings
- scantron grading and printing now stop when the user hits stop on the
   browser
- instructors/TA in sections can no see answers in PGRD for students in
   their section
- scantron grading a blank <optionresponse> would grade it as if the 
   user had entered A
- scantron grading <rankresponse> was broken (everything was shifted by 1)
- CC printing for students a problem that uses <instructorcomment> now doesn't
   print those comments out on the student's assignment
- uploaded .txt files now get the buttons on the screen
- CUSR now shows all roles when the user has roles that only differ in the
   section
- NAV significantly faster
- editing problems with <part> significantly faster
- nav understands scantron grading correctly now 
- printing for Anonymous with answers, the answers on the second and
   subsequent printouts was incorrect
- <gnuplot> now has <lmargin> <rmargin> <tmargin> <bmargin>
     <major_ticscale> <minor_ticscale>
- external documents with : in url work 

To install this update:

1) You will need to be running Fedora Core 2 or RedHat 7.3
     for this release to work

2) if you are running RedHat 7.3 and you will need to install the
     3.13 systemperl rpm

First get:
http://install.loncapa.org/resources/LON-CAPA-systemperl-3.13-rh7.i386.rpm

Install it by doing:
rpm -e `rpm -q -a | grep systemperl`
rpm --install --force --nodeps LON-CAPA-systemperl-3.13-rh7.i386.rpm

Verify it is installed by doing:

$ rpm -q LON-CAPA-systemperl

RedHat 7.X will show
LON-CAPA-systemperl-3.13-rh7

3) If you are running RedHat 7.3, you will need to install 
       Martin Siegert's check-rpms 

rpm -Uvh http://www.sfu.ca/acs/security/linux/check-rpms-3.0.2-1.noarch.rpm

4) if you are running Fedora Core 2

   You will need to do things after running UPDATE

5) Download the new LON-CAPA tarball from

RH 7.3:
wget http://install.lon-capa.org/versions/loncapa-1.2.1.tar.gz

Fedora Core 2:
wget http://install.lon-capa.org/versions/loncapa-fedora-1.2.1.tar.gz

and untar it

tar xzvf loncapa-1.2.1.tar.gz
or
tar xzvf loncapa-fedora-1.2.1.tar.gz

6) Run the UPDATE script as root

cd loncapa-1.2.1
su
./UPDATE

7) If you are running Fedora Core 2 you will need to use yum to update
     your machine and then install the LONCAPA-prerequisites

yum update
yum install LONCAPA-prerequisites

8) restart the system services
/etc/rc.d/init.d/loncontrol stop
/etc/rc.d/init.d/loncontrol start
/etc/rc.d/init.d/httpd stop
/etc/rc.d/init.d/httpd start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org

-- 
[email-masked]  LON-CAPA Developer  0-7-3-2-

---

From: "Matthew Brian Hall" <[email-masked]>
Date: Thu, 30 Sep 2004 16:38:40 -0400

> - instructors/TA in sections can no see answers in PGRD for students in

No? 

 ---------------------------------------
Matthew Hall           [email-masked]
LON-CAPA developer
Michigan State University
 ---------------------------------------

---

From: "H. K. Ng" <[email-masked]>
Date: Fri, 01 Oct 2004 09:02:45 -0400

>- uploaded .txt files now get the buttons on the screen

Hi Guy,

Did you include the scantron upload file - will go back to the scantron 
select page rather than grading menu? Also, preselects the just uploaded 
file. (Is the above line referring to this?)

Thanks,
hk

---

From: Guy Albertelli II <[email-masked]>
Date: Fri, 1 Oct 2004 09:15:57 -0400 (EDT)

Hi Hon-Kie,

> file.

No. As with any bugfix release I only include things that developers have
specifically requested to be in the next release and that I concur
with.

If you would like this fix in a subsequent release you will nee to
send me personally an email that says which version(s) of which
file(s) you would like included.

I will continue to be a hard ass about this in all future releases.

> (Is the above line referring to this?)

No, this line referes to uploading a .txt file to be included as
material in your course. (BUG#3428)