Subject: [LON-CAPA-dev] Zaphod again...

From: "Matthew Brian Hall" <[email-masked]>
Date: Fri, 22 Nov 2002 09:14:13 -0500 (EST)

Well, Zaphod crashed again in spite of having new RAM.

The error given is a Machine Check Exception: 0000000000000004
Bank 0 F650210022200810 at 000000000a07e140
CPU Context corrupt
interrupt handler -  not syncing

The MCE listed indicates it crashed on access that was either a
'special cycle OR a I/O cycle', according to Appendix E of Intel's IA-32 Intel
Architechture Software Developer's Manual Volume 3.

parsemce (http://www.codemonkey.org.uk/cruft/parsemce.c/parsemce.c)
gives:

[matthew@kirk matthew]$ ./parsemce -e 0000000000000004 -b 0 -s
f650210022200810 -a 000000000a07e140
Status: (4) Machine Check in progress.
Restart IP invalid.
parsebank(0): f650210022200810 @ a07e140
        External tag parity error
        Uncorrectable ECC error
        CPU state corrupt. Restart not possible
        Address in addr register valid
        Error enabled in control register
        Error not corrected.
        Error overflow
        Bus and interconnect error
        Participation: Local processor originated request
        Timeout: Request did not timeout
        Request: Generic error
        Transaction type : Instruction
        Memory/IO : Memory access

Which appears to indicate a bad bus.  But the CPU could be dead, too.

So, we'll need to find a replacement machine somewhere and get Zaphod
to the hospital...

Matthew-
------------------------------------------------------------------
Matthew Hall           LON-CAPA developer         [email-masked]
123 North Kedzie Hall                    Michigan State University
------------------------------------------------------------------

---

From: Guy Albertelli II <[email-masked]>
Date: Fri, 22 Nov 2002 10:13:03 -0500 (EST)

Hi Matthew,

> Which appears to indicate a bad bus.  But the CPU could be dead, too.

can we just get a new CPU ordered?

Or send this Info to Dell and see what they say to replace?

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-7-7-  O-
    Today I will treat myself as I would my best friend--with sarcasm
    and neglect.