Subject: [LON-CAPA-dev] valid installation xml

From: Scott Harrison <[email-masked]>
Date: Mon, 15 Apr 2002 15:36:12 -0400

Dear All:

lpml.dtd now verifies loncapafiles.lpml (another wonderful
millimeter of progress for the whole project...jump for joy!).

Question: Does anybody know of a better perl-based XML validator
other than XML::DOM::ValParser?

Till then, lpml.dtd will have to be fairly primitive;
I would like to do more with ENTITY elements, the
way html.dtd does, but alas, it is only now that
XML validation seems fairly good for perl and a lot
still needs to happen at cpan.org.

Python-based validators have been much more robust over
the last year or so, however I really try to reduce
dependencies with the installation/compilation.
(I do not want to install software to install software.)

Hence, I stick with perl.
Again, loncom/build/lpml.dtd is not that critical...
for now.

Regards,
Scott

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: Guy Albertelli II <[email-masked]>
Date: Mon, 15 Apr 2002 16:35:12 -0400 (EDT)

Hi Scott,

> other than XML::DOM::ValParser?

They only other one I saw was XML::Checker::Parser but it seems
entertwined with XML::DOM:ValParser so I suspect you may have noticed
it.

I have read some very complimentary things about SAX and expat seems
quite popular, they are both validating parsers from what I have seen.

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-9-4-  O-
    I have the power to channel my imagination into ever-soaring levels
    of suspicion and paranoia.

---

From: Scott Harrison <[email-masked]>
Date: Tue, 16 Apr 2002 01:38:41 -0400

Dear Guy:

> quite popular, they are both validating parsers from what I have seen.

My experience with PerlSAX and expat to date is that they only
check the well-formedness of XML documents as opposed to DocumentType
validation.  But I could be mistaken.  (I'm still amazed that there
aren't more XML tools for perl...)

Thanks for responding.

Regards,
Scott

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev