Subject: [LON-CAPA-dev] Test Release of 2.4.1

From: Guy Albertelli II <[email-masked]>
Date: Wed, 13 Jun 2007 21:26:29 -0400 (EDT)

Hi All,

Sigh the every exisiting pain of the .0 release. Any hoo hoping to
announce tommorrow. Let me know if I got anything wrong/ badly worded.

New Version 2.4.1 Released

Important Bugfix release.

Notable Changes from 2.4.0:
- Some special documents (simple pages, navigate contents, etc) failed 
    to ever become 'initialized'
- pushing of delayed messages was failing to occur
- maxima should restart properly on SuSE platforms
- <while> with embedded <script> generates correct Script Vars links
    in answer target
- access times reset helper can also be found on the PARM page
- loncontrol nicer about stopping daemons (less apt to kill everything off)
- Portfolio references upload handles more cases correctly and has better
    text describing what is expected of the user
- Reference uploading in both Docs and Portfolio handle <a> referenced files
- jsmath and mimetex properly render <m>\$10</m>
- Setting of some string type parameters were failing to save in some cases

To install this update:

1) You will need to be running Fedora Core 5, 6, or 7, RHEL (AS|ES) 4 or 5,
   SUSE 9.3 10.1 or 10.2, SLES 9 or 10
     (Fedora Core 4 should continue to work but is deprecated.)

2) If running Fedora or RHEL 5, use yum to update your machine and
   then install the LONCAPA-prerequisites (if not already installed).

yum update
yum install LONCAPA-prerequisites

    If running SUSE 9.3 or SLES 9, you will need to use yast remove
       and readd the lon-capa repository source and then force the update of
       LONCAPA-prerequisites
    If running SUSE 10.2, 10.1 or SLES 10, use rug to update your machine.
    if running RHEL 4, use up2date to update your machine.

3) After updating check that you have version 1-9 of
   LONCAPA-prerequisities installed

rpm -q LONCAPA-prerequisites

4) Download the new LON-CAPA tarball from
wget http://install.lon-capa.org/versions/loncapa-2.4.0.tar.gz

and untar it

tar xzvf loncapa-2.4.0.tar.gz

5) stop the Lon-CAPA system services

/etc/rc.d/init.d/loncontrol stop

6) stop the webserver:

Fedora/RHEL:
/etc/rc.d/init.d/httpd stop

SUSE 9.X/SLES 9:
/etc/init.d/apache stop

SUSE 10.1/SLES 10:
/etc/init.d/apache2 stop

7) Run the UPDATE script as root
cd loncapa-2.4.0
su
./UPDATE

8) restart the Lon-CAPA system services
/etc/rc.d/init.d/loncontrol start

9) restart the webserver:

Fedora/RHEL:
/etc/rc.d/init.d/httpd start

SUSE 9.X/SLES 9:
/etc/init.d/apache start

SUSE 10.1,2/SLES 10:
/etc/init.d/apache2 start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org

-- 
[email-masked]   0-7-0-9-27,137

---

From: Stefan Bisitz <[email-masked]>
Date: Thu, 14 Jun 2007 10:29:18 +0200

Guy Albertelli II wrote:
> Let me know if I got anything wrong/ badly worded.

> [...]

...you will need to use yast _TO_(???) remove...

> wget http://install.lon-capa.org/versions/loncapa-2.4.0.tar.gz

2.4.1 would be better...

> tar xzvf loncapa-2.4.0.tar.gz

2.4.1

> 7) Run the UPDATE script as root

2.4.1

Stefan Bisitz