Subject: [LON-CAPA-dev] Meeting Notes 4-19-2007

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Thu, 03 May 2007 11:57:44 -0400

4-19-2007 

Rick - 

A - multiple file download for essayresponse submissions 

Guy - blank task template 

 - loncron rotation of auto-enroll, autocreate logs 

 - search can now search for strings including hyphens 

 - escaping or urls prior to allow check to handle spaces in URL 

 - student submission display largely complete. 

 - CC usability report => 3/4 items for 2.4 

A - usability change suggestions for 2.4 

 - maxima investigation
 - casing on gif/GIF 

 - bugs 

Stuart - Remove lonnet dependency from lonhttpd 

 - SUSE 9 clisp/maxima 

 - SuSE 10.2 LON-CAPA 

 - data2 - frozen at 2.3.3 

 - update loncapa.msu.edu/train 

 - COM bug -> Regular message -> User's record for dff priv. 

A -IMS import WebCT 4.1 

 - Summer training workshop for teachers registration 

 - complete virtiualization for 64 bit and 32 bit 

 - RHEL 5 install 

 - more work on COM bugs 

 - group portfolio listing in users PORT 

Mark - Review documentation for BT creation 

 - PT3 project -use slot mechanism for reservations? 

A - look at two new BT tasks 

 - Continue editing documentation on BT 

Felicia
 - author tasks for usability completed 

A - recruitment of participants for study 

 - usability study W, Th, F. 

 - stubs for placement of BT documentation 

Reza - Colorful editor docs. 

A - implement Mark's suggestions for documentation 

 - Convert docs -> LaTeX 

Gerd - ALT proposal complete 

 - CCLI resubmission for May deadline 

 - icons
 - preferences (+ others)
 - internationalization, labels 

A - ALT submission 

 - more CCLI

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Thu, 03 May 2007 11:59:34 -0400

4-26-2007 

Felicia - Recruitment for usability complete
A - BT stubs in documentation
 - Finals week
 - out Th,F 

Rick - multiple download - access control implemented
A - multiple files: deal with naming scheme and hierarchical structure 
(option for user?)
 - manifest included in zip? 

Guy - headers in remotemode
 - next homework due (exclude ones with no due date)
 - MIME types for file extensions of upper/lower case
 - annotation works correctly with encrypted URLs
 - lonmaxima fix to Timeout issue by changing operation during killall
A - student submissions
 - investigate CSM scantron issue
 - locking down 2.3.99
 - 2.4 release -> May 28th. 

Reza - Updates to BT docs with Mark's suggestions.
A - Edit mode docs to refer to "colorful editor" as edit mode
 - Meet with Felicia
 - conversion of docs to LaTeX 

Mark - documentation for slots review
 - explored slots for scheduling
 - usability study volunteer
A - ICTC assessments 

Stuart - RHEL5 install
 - commits on COM (e.g., record any message in user Notes).
 - MSO
A - COM bugs
 - IMS import WebCT 4.1
 - Summer training workshop for teachers registration
 - group portfolio listing in users PORT 

Gerd - ALT proposal submitted
 - Salerno added to cluster
A - CCLI proposal