Subject: [LON-CAPA-dev] Viewing Student sequences/Access Servers

From: Mark Lucas <[email-masked]>
Date: Fri, 8 Feb 2002 09:03:46 -0500 (EST)

(1) Is there any way to view a student's sequence (in our case
assignment4.page) as Course Coordinator?

(2) When setting up a second access server, load balancing is accomplished
     by .... ? Placing the server in the list spares.tab?

    How is the load at which the request is 'passed along' determined?

    How would I double my library server as an access server in a case of
    emergencies (ie., really high loads).

    I was seeing some peak loads in the >3 category for yesterday evening,
and there are some complaints about system access. On the order of 20-26
httpd children are kept alive most of the time.

					Thanks,

						 Mark

----------------------------------------------------------------------------
Mark Lucas					email: [email-masked]
252D Clippinger Lab  				phone: (740)597-2984
Department of Physics and Astronomy             fax:   (740)593-0433
Ohio University
Athens, OH 45701

---

From: Scott Harrison <[email-masked]>
Date: Fri, 08 Feb 2002 09:25:59 -0500

Some unofficial answers:

>      by .... ? Placing the server in the list spares.tab?

Yes.

>     How is the load at which the request is 'passed along' determined?

The least loaded server; lonnet.pm.
Determined essentially from /proc/loadavg (see lond).
cat /proc/loadavg; the fraction of processes that aren't getting
cpu time over the last minute, 5 minutes, 15 minutes, and then
I don't know the final two numbers.

# ------------------------------ Find server with least workload from
spare.tab

sub spareserver {
    my $tryserver;
    my $spareserver='';
    my $lowestserver=100;
    foreach $tryserver (keys %spareid) {
       my $answer=reply('load',$tryserver);
       if (($answer =~ /\d/) && ($answer<$lowestserver)) {
	   $spareserver="http://$hostname{$tryserver}";
           $lowestserver=$answer;
       }
    }    
    return $spareserver;
}

>     emergencies (ie., really high loads).

treat it like one; place it in spare.tab; library servers have
access server functionality (plus "much much more")

> httpd children are kept alive most of the time.

congratulations? :) hmmm... maybe we need to look at how many httpd
children
are allowed to work at any one time.. don't know

-Scott

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: Scott Harrison <[email-masked]>
Date: Fri, 08 Feb 2002 09:29:02 -0500

> I don't know the final two numbers.

and yes.. we base it off of the last minute

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 08 Feb 2002 09:40:02 -0500

>      by .... ? Placing the server in the list spares.tab?

Yes, the LON-CAPA hostid of it, for example msua1. One host per line.

>     How is the load at which the request is 'passed along' determined?

As Scott explained, from loadavg. There is also a config parameter in
access.conf (currently set to "2.00") when an access server starts looking
around for alternatives - in this case, 2.00 is considered 100 percent load.

>     emergencies (ie., really high loads).

I would actually do a two-tired approach: place your two access servers on a
round-robin IP scheme. Then in spare.tab, specify your library server as the
spare host.

> httpd children are kept alive most of the time.

Wow. I assume that was homework deadline night.

Little hint: put your deadline in the middle of the day - that will
automatically scatter the load a bit.

- Gerd.

---

From: Guy Albertelli II <[email-masked]>
Date: Fri, 8 Feb 2002 10:23:44 -0500 (EST)

> assignment4.page) as Course Coordinator?

Not that I know of.

Any suggestions as to where to add that functionality, and how it
should work?

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-9-8-  O-
    In the force if Yoda's so strong, construct a sentence
    with words in the proper order then why can't he?