Subject: [LON-CAPA-dev] 2.1.3 pre-announce

From: Guy Albertelli II <[email-masked]>
Date: Fri, 31 Mar 2006 17:44:41 -0500 (EST)

Hi All,

2.1.3 pre announce, any typos? bad english?
New Version 2.1.3 Released

- It's highly suggested to install this bugfix release.

Notable Bug Fixes since 2.1.2:
- search database was not being correctly built, such that many resources
  were not being included
- 'View Student Activity' data processing is 30-60 times faster
- course with large numbers of map conditions are evaluated significantly
  faster
- lond supports highly contended files correctly
- connecting to institutional student photo support improved 
  and fully functional
- scantron grading, the Unique CODE checking is now actually running 
  when it option is selected

Minor Bug Fixes since 2.1.2:
- added student photos to the enrollment screen if enabled
- searching multidomain machines correctly return results for a specific
  domain on the machine
- bridgetask grading screen easier to use
- can now do a bridgetask regrading of a specific user
- bridgetask grading queue screen easier to read
- CSV grade upload correctly ignores blank lines in the uploaded file
- simple problems when printed had extra blank lines inserted
- slots now honor the 'Reservation allowed start time'
- some issues with Apache 2 have been fixed
- <instructorcomment>s are now hidden when print CODEd exams
- searching specific domain works correctly
- slot management can now only show slots whose names matches a substring
- slot reservation now correctly denies access to slots that have
  overlapping 'Unique Periods'
- slot reservation system no longer allows users to deregister for a slot
  that is closed
- slot management allows instructors to quickly 'Remove All' users from
  a slot
- display of users in slot screens and bridgetask grading screens includes
  both username and full name
- some external URLs were not being properly handled

To install this update:

1) You will need to be running Fedora Core 3 or 4, RHEL ES 4, 
      SuSe 9.3, or SLES 9

2) If running Fedora, use yum to update your machine and then install the
      LONCAPA-prerequisites (if not already installed).

yum update
yum install LONCAPA-prerequisites

    If running SuSe or SLES, use you to update your machine.
    if running RHEL, use up2date to update your machine.

3) Download the new Lon-CAPA tarball from
wget http://install.lon-capa.org/versions/loncapa-2.1.3.tar.gz

and untar it

tar xzvf loncapa-2.1.3.tar.gz

4) Run the UPDATE script as root
cd loncapa-2.1.3
su
./UPDATE

5) restart the Lon-CAPA system services
/etc/rc.d/init.d/loncontrol stop
/etc/rc.d/init.d/loncontrol start

6) restart the webserver:

Fedora/Red Hat Enterprise:
/etc/rc.d/init.d/httpd stop
/etc/rc.d/init.d/httpd start

SuSe / SLES:
/etc/init.d/apache stop
/etc/init.d/apache start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org

-- 
[email-masked]   0-7-1-8-27,137

---

From: Rick Banghart <[email-masked]>
Date: Fri, 31 Mar 2006 15:42:00 -0800

See suggested changes in line.

>   when it option is selected

when its option is selected

>- searching multidomain machines correctly return results for a specific

- searching multidomain machines correctly returns results for a specific

>- simple problems when printed had extra blank lines inserted

- simple problems when printed have extra blank lines removed

>- slot management can now only show slots whose names matches a substring

- slot management can now only show slots whose names match a substring

>- some external URLs were not being properly handled

- external URLs are now being properly handled

>_______________________________________________
>LON-CAPA-dev mailing list
>[email-masked]
>http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

---

From: "H. K. Ng" <[email-masked]>
Date: Tue, 04 Apr 2006 07:17:19 -0400

Hi Guy,

Just install 2.1.3 -everything went fine except for the last step - 
when I tried to restart httpd. It complains of the following:

/etc/init.d/httpd start
Starting httpd: /etc/rc.d/init.d/functions: line 148: 
/usr/sbin/httpd: No such file or directory
                                                            [FAILED]

Any clue what is causing this? I am running FC4.

Thanks,
-hk

---

From: [email-masked]
Date: Tue, 4 Apr 2006 07:55:31 -0400 (EDT)

Hon-Kie,

My understanding is something is mucked up with the yum updates. Several 
of us had this issue when we updated at a certain point. My solution was 
to copy httpd from another machine.

A more formal method would be to uninstall apache and reinstall it.

I made it through my yum updates and LC upgrade yesterday morning with no 
problems.

Mark

  On Tue, 4 Apr 2006, H. K. Ng wrote:

> Hi Guy,
>
> Just install 2.1.3 -everything went fine except for the last step - when I 
> tried to restart httpd. It complains of the following:
>
> /etc/init.d/httpd start
> Starting httpd: /etc/rc.d/init.d/functions: line 148: /usr/sbin/httpd: No 
> such file or directory
>                                                           [FAILED]
>
>

----------------------------------------------------------------------------
Mark Lucas					email: [email-masked]
252D Clippinger Lab  				phone: (740)597-2984
Department of Physics and Astronomy             fax:   (740)593-0433
Ohio University
Athens, OH 45701

---

From: "H. K. Ng" <[email-masked]>
Date: Tue, 04 Apr 2006 08:11:51 -0400

Mark,

OK, managed to get it running. Seems that there are two problems.

1. httpd is missing from /usr/sbin
2. libmm.so.13 -> libmm.so.13.0.20 - file and link are missing from /usr/lib

Thanks,
-hk

At 07:55 AM 4/4/2006, you wrote:
>Hon-Kie,
>
>My understanding is something is mucked up with the yum updates. 
>Several of us had this issue when we updated at a certain point. My 
>solution was to copy httpd from another machine.
>
>I made it through my yum updates and LC upgrade yesterday morning 
>with no problems.
>
>Mark
>
>

---

From: Guy Albertelli II <[email-masked]>
Date: Tue, 4 Apr 2006 13:44:38 -0400 (EDT)

Hi Hon-Kie, 

> 1. httpd is missing from /usr/sbin

We have recently traced this to be likely some kind of interaction
between 'yum update' and the 'prelink' cron script.

Installing 2.1.3 does not cause this.

Your httpd executable was missing before you even downloaded ver 2.1.3

We are still trying to figure out exactly what causes this.

> 2. libmm.so.13 -> libmm.so.13.0.20 - file and link are missing from /usr/lib

Fedora has released an updated version of the libmm RPM that installs
libmm.so.14 (and thus removes the older libmm.so.13)

We have released an updated apache RPM that makes use of this updated
libmm and no longer needs the older one.

(For Fedora 4, apache-1.3.33-1.i386.rpm required libmm.so.13
and apache-1.3.33-1.i386.rpm requires libmm.so.14)