Subject: [LON-CAPA-dev] Re: loncapa.conf

From: Scott Harrison <[email-masked]>
Date: Tue, 12 Feb 2002 16:03:00 -0500

Dear Guy:

Ahhh...... obvious concern now I think...

    elsif ($buildmode==4) {
	if ($existence=~/no$/) {
	    exit(3);
	}
        elsif ($cvstime>0) {
	    exit(2);
	}
	elsif ($existence=~/^no/) {
	    exit(1);
	}
        else {
	    exit(0);
	}
    }

Because your /etc/httpd/conf/loncapa.conf is newer than
CVS:loncom/loncapa.conf, the system assumes either that:
* the system administrator knows what he is doing and
  has changed the /etc/httpd/conf/loncapa.conf file
* or more likely, the loncapa.conf file has been created
  from the existing CVS source
  (the time difference is natural since target is installed
   after a source update and install)

It's pretty easy to change the logic of any of this...
Let me know if you have any recommendations or ideas.

Regards,
Scott

Guy Albertelli II wrote:
> 
> Hi Scott,
> 
> > No quick ideas.
> >
> > The only files with the string "aliases" are httpd.conf and srm.conf.
> 
> The aliases thing is a misdirection it is just something an bash sheel
> says on startup (their .bashrc is screwy). And I have now fixed that
> sillyness.
> 
> > I might suggest seeing if it even runs the filecompare.pl script
> > (print TESTOUT "hello world"; inside filecompare.pl).
> 
> It does, make install runs fine and everything is updated. It is only
> configinstall that is strangely silent.
> 
> Running the command:
> perl filecompare.pl  ../../loncom/loncapa.conf /etc/httpd/conf/loncapa.conf
> 
> Verbose: 1
> Show: all
> Processing for mode: files
> Location #1: ../../loncom/loncapa.conf
> Location #2: /etc/httpd/conf/loncapa.conf
> ../../loncom/loncapa.conf       existence: yes:yes      cvstime: n/a
> age: 2209                       md5sum: different       size: -1
> lines: -1                       diffs: 0:1
> 
> However
> perl filecompare.pl -b4 ../../loncom/loncapa.conf /etc/httpd/conf/loncapa.conf
> 
> Prints nothing, and has a return code of 0, shouldn't it be something
> else?
> 
> > I'm happy to visit briefly today if it helps iron out one
> > of life's many 20 minute questions.
> 
> I'd like that if this doesn't give you enough ifo to solve it.
> 
> Feel free to log the restore configurations thing into the bugzilla
> database.
> --
> [email-masked]        BM: n^20 t20 z20 qS
> Guy Albertelli -7-9-8-  O-
>     ...nobody messed with Don Quixote. He was nuts.

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: Guy Albertelli II <[email-masked]>
Date: Tue, 12 Feb 2002 16:34:47 -0500 (EST)

Hi Scott,

> CVS:loncom/loncapa.conf, 

Do you mean the date of the last CVS revision of the date on the file
in my local repository?

(I have added the mysfu handler to the loncapa.conf file.)

> the system assumes either that:

The current situation is okay, I just would prefer a message saying
something about noticing that the files are different but I am
choosing not to install the version in CVS overtop of the version in
in the install location.

As it is, I think loncapa.conf is a static conf, and srm.conf is now a
conf file. (srm.conf eventually is going to not be installed by us at
all right? But rather let apache deal with it.)

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-9-8-  O-
    My intuition nearly makes up for my lack of good judgement.

---

From: Scott Harrison <[email-masked]>
Date: Tue, 12 Feb 2002 17:17:24 -0500

Dear Guy:

five points

***1***
> (I have added the mysfu handler to the loncapa.conf file.)

Yes.  /etc/httpd/conf/loncapa.conf is apparently newer than
      the CVS/Entries date corresponding to your
      local CVS:loncom/loncapa.conf

***2***
> choosing not to install the version in CVS overtop of the version in

Okay.  Easy to do.  I put this in bugzilla.

***3***
> all right? But rather let apache deal with it.)

For now loncapa.conf is a static conf... however as it acquires the
configurable values of access.conf, it becomes a "conf"... but this
gets into another intermediate issue..........see below....

***4***
A linguistic problem that also needs to be resolved.  We should have
(and I know we talked about something like this months ago)

protected conf --- be very paranoid about overwriting (mostly
                   just create .lpmlnew files with proper notification)

Example: srm.conf, and someday, httpd.conf and access.conf
Applicable method of changing: piml; post-installation markup language
    (see webserver.piml)

updated conf --- overwrite this on an update but save .lpmlsave if
                 there is a diff with proper notification

Example: loncapa.conf, hosts.tab
Applicable method of changing: loncaparestoreconfigurations

unprotected conf --- a file that is liberally overwritten like
                     any other file if there is a diff
Example: filetypes.tab; insertlist.tab; language.tab, etc.
Applicable method of changing: overwrite it

Quite a few times people think that "static conf" means
sticky, thus preserved&protected...
Whereas I originally meant static conf to be "unprotected conf"
and "conf" to be protected&updated.

***5***
I suppose we should also generate
http://MACHINENAME/lon-status/WARNINGS.txt

Regards,
Scott

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev