Subject: [LON-CAPA-dev] Code Freeze Reminder

From: Guy Albertelli II <[email-masked]>
Date: Thu, 14 Nov 2002 16:00:47 -0500 (EST)

Hi All,

Just a reminder that we are in a code freeze stage.

There is only 1 new feature we are wating on, the rest of the
commits should be bug fixes, it will be as hard for me to resist as it
will be for you, but I don't want to have to put out a 0.6.1

Please, please, please try the new code out and do things you wouldn't
normally do.

A list of ideas:
create classes, modify parameters, add a style file to your class, try
to make broken problems, see how weel the random number generator
works, login cross domain, try creating courses in different domain,
users in different domains, logging into courses in different domains,
try printing anything and everything, play with the spread sheet, play
with stats.

Later next week I will invite the MSU community at large to login and
have them try things out.
-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-7-7-  O-
    Today I will gladly share my experience and advice, for there
    are no sweeter words than "I told you so."

---

From: Gerd Kortemeyer <[email-masked]>
Date: Sat, 16 Nov 2002 14:15:23 -0500

*** This is a reminder of the attached reminder. ***

Yesterday evening on http://data.lite.msu.edu/, for two handlers  I
immediately got an "Internal Server Error"!

Today, Apache on http://data.lite.msu.edu/ is down.

* Code freeze means to be extra careful about what gets checked in - certainly
not handlers that throw "Internal Server Error"s before even doing anything
(yes, it happens to all of us, but let's be extra extra careful).

* Code freeze means testing, testing, testing, which is hardly possible if the
test server is down.

* Code freeze means fixing bugs with minimal code change, and "if it ain't
broken, don't fix it".

Guy Albertelli II wrote:

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

---

From: Scott Harrison <[email-masked]>
Date: Sat, 16 Nov 2002 15:12:19 -0500

> * Code freeze means fixing bugs with minimal code change, and "if it ain't

Do you agree that it is okay to develop software inside the modules/ directory
that is not part of the LON-CAPA tarball releases?

Regards,
Scott

-- 
Scott Harrison, [email-masked]

---

From: Gerd Kortemeyer <[email-masked]>
Date: Sat, 16 Nov 2002 15:18:08 -0500

Sure. data.lite.msu.edu is certainly not dysfunctional because of something in
/modules/

---

From: Guy Albertelli II <[email-masked]>
Date: Sun, 17 Nov 2002 00:36:04 -0500 (EST)

Hi Gerd

> immediately got an "Internal Server Error"!

This has nothing to do with the handler code but with the lack of a
new systemperl having been generated yet to support
SpreadSheet::WriteExcel
[Fri Nov 15 20:42:43 2002] [error] File::Spec version 0.8 required--this is only version 0.6 at /usr/lib/perl5/site_perl/5.005/File/Temp.pm line 124.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.005/File/Temp.pm line 124.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.005/Spreadsheet/WriteExcel/Worksheet.pm line 21.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.005/Spreadsheet/WriteExcel/Workbook.pm line 20.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.005/Spreadsheet/WriteExcel.pm line 17.
BEGIN failed--compilation aborted at /home/httpd/lib/perl/Apache/londropadd.pm line 44.

[Fri Nov 15 20:42:43 2002] [error] Undefined subroutine &Apache::londropadd::handler called.

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-7-7-  O-
    I'll take back my pinata, it's wasted on you. -TMBG