Subject: [LON-CAPA-dev] 1.3 plans

From: Guy Albertelli II <[email-masked]>
Date: Wed, 15 Sep 2004 16:40:14 -0400 (EDT)

Hey All,

So I'd like to have the 1.3 planning meeting next Tuesday.

We have already done a large body of additions to Lon-CAPA as a result
of a commercial bid we worked on (mainly having to do with
discussions and tracking students)

But we probably can get some more things in.

So vote/nominate your favorite things.

-- 
[email-masked]  LON-CAPA Developer  0-7-3-2-

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 17 Sep 2004 16:02:01 -0400

> So vote/nominate your favorite things.

Make 1.3 a clean-up release: cleaning up after commercial bit, and 
leftover bugs. We do not have the luxury of a summer testing term 
before January.

* Feature freeze now
* Debugging, working through Bugzilla except "enhancements"
* Extensive testing, including
   - stress-test on loncnew within development cluster, simulated 
submissions
   - printing tests
   - communications
   - encrypt and hidden
   - several Destroy LON-CAPA Sessions
   - IMS import/export
* Documentation, including
   - exams
   - work with Angela

The end-of-summer release (version 2.0???) can be revolutionary again.

- Gerd.

---

From: Gerd Kortemeyer <[email-masked]>
Date: Sat, 18 Sep 2004 06:37:53 -0400

> So I'd like to have the 1.3 planning meeting next Tuesday.

As it turns out, Ed and I got scheduled into a lunch meeting regarding 
the new company on that day. This was not our choice. We will need to 
postpone the 1.3 meeting by one week.

- Gerd.

---

From: Guy Albertelli II <[email-masked]>
Date: Sat, 18 Sep 2004 11:48:11 -0400 (EDT)

> postpone the 1.3 meeting by one week.

I'd really like to get it settled next week.

How's Thursday for everyone?