Subject: [LON-CAPA-dev] RE: Localenroll not called

From: "Cui, Chi" <[email-masked]>
Date: Thu, 21 Sep 2006 11:24:22 -0400

Problem solved. I didn't restart the loncontrol service: stupid
mistake:-).

Thanks.

Cissy

> _____________________________________________ 
> From: 	Cui, Chi  
> Sent:	Friday, September 15, 2006 10:33 AM
> To:	[email-masked]'
> Subject:	Localenroll not called
> 
> Hi, guys,
> 
> I'm trying to write a solution to use autoenrollment in Loncapa to
> synchronize the roster in BlackBoard and Loncapa. My idea is
> BlackBoard will generate a file with all student's information and put
> it in /home/httpd/perl/tmp/. Then localenroll.pm will parse the
> file,generate the xml file. Somehow, I feel my localenroll.pm was not
> even called after I ran Autoenroll.pl. I put a lonnet::logthis as the
> first line in localenroll::fetch_enrollment, but never saw the line in
> lonnet.log. The autoenroll.log gave me error message "No institutional
> classlist data could be retrieved for 8U82571f0a5dc4420fsuappsas1".
> Is there anyway I can know if my localenroll.pm is called? Can I
> plugin lonnet.logthis to debug? 
> 
> Thank you very much.
> 
> Cissy (Chi) Cui
> ----------------------------------------------------------------
> Coordinator, Computer Applications
> Center for Assessment & Testing, APPS
> UCC 1200
> Florida State University
> Tel: (850) 644-4484
> 
>

---

From: Ray Batchelor <[email-masked]>
Date: Tue, 28 Nov 2006 17:25:15 -0800

I'm just setting up my development server and am wondering if the domain name 
should be the same as the domain name for my existing servers in the 
production cluster or not.
If so, then should the primary library server be the same as my existing 
primary library server in the production cluster.

I suspect that since the clusters are separate, it may not matter?

I'm looking for immediate advice, because I need to leave this consol until 
tomorrow.... very soon.

Otherwise,
No worries.

Ray

---

From: Guy Albertelli II <[email-masked]>
Date: Mon, 4 Dec 2006 17:10:49 -0500 (EST)

Hi Ray,

> I suspect that since the clusters are separate, 

You are correct.

> it may not matter?

The primary library server needs to be an id for a machine that exists
in the cluster you are defining it in.

-- 
[email-masked]   0-7-1-6-27,137