Subject: [LON-CAPA-dev] Pre ANnounce 2.5.2

From: Guy Albertelli II <[email-masked]>
Date: Thu, 18 Oct 2007 18:00:29 -0400

Hi All,

2.5.2 announcenet let me know if anythings reads funny.

New Version 2.5.2 Released

This is a bugfix release.

Notable Changes from 2.5.1:
- lonBalancer tries to send users back to amachine if there is a valid
  session on the balanced to machines
- warning about missing javascript on the roles page
- support wildcard cloning restrictions
- add cloning config to course initialization
- support zypper on SuSE 10.2
- Typing in one part and clicking on a different part's Submit Answer
  button would submit the typed in answer instead of the part that was
  clicked
- Previous Tries link could be inaccurate in a .page
- IP restrictions work correctly on .page resources
- IMS import of WebCT 4 CE
- permenanet email can be set when creating a user
- German Translation updated
- interctructor removal of a student slot reservations works correctly
  for 'map' and 'map_map' style reservations
- scantron grading properly handles partial credit for multiple
  non option responses in a single part
- essayresponse file submission works when included in a .page
- Groups tools links available on group page
- gnuplots linewidths once again deafult to a width of 1
- gnuplot with filledcurves adn normal lines work correctly 

To install this update:

1) You will need to be running Fedora Core 5, 6, or 7, RHEL (AS|ES) 4 or 5,
   SUSE 9.3 10.1 or 10.2, SLES 9 or 10, CentOS 5, Scientific Linux 5
     (Fedora Core 4 should continue to work but is deprecated.)

2) If running Fedora or RHEL 5, use yum to update your machine and
   then install the LONCAPA-prerequisites (if not already installed).

yum update
yum install LONCAPA-prerequisites

    If running SUSE 9.3 or SLES 9, you will need to use yast to remove
       and readd the lon-capa repository source and then force the update of
       LONCAPA-prerequisites
    If running SUSE 10.2, use zypper to update your machine.
    If running SUSE 10.1 or SLES 10, use rug to update your machine.
    if running RHEL 4, use up2date to update your machine.

3) After updating check that you have version 1-9 of
   LONCAPA-prerequisities installed

rpm -q LONCAPA-prerequisites

4) Download the new LON-CAPA tarball from
wget http://install.lon-capa.org/versions/loncapa-2.5.2.tar.gz

and untar it

tar xzvf loncapa-2.5.2.tar.gz

5) stop the Lon-CAPA system services

/etc/rc.d/init.d/loncontrol stop

6) stop the webserver:

Fedora/RHEL:
/etc/rc.d/init.d/httpd stop

SUSE 9.X/SLES 9:
/etc/init.d/apache stop

SUSE 10.1/SLES 10:
/etc/init.d/apache2 stop

7) Run the UPDATE script as root
cd loncapa-2.5.2
su
./UPDATE

8) restart the Lon-CAPA system services
/etc/rc.d/init.d/loncontrol start

9) restart the webserver:

Fedora/RHEL:
/etc/rc.d/init.d/httpd start

SUSE 9.X/SLES 9:
/etc/init.d/apache start

SUSE 10.1,2/SLES 10:
/etc/init.d/apache2 start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org

-- 
[email-masked]   0-7-0-6-27,137

---

From: "Ray Batchelor" <[email-masked]>
Date: Fri, 19 Oct 2007 02:15:08 -0700

Hi Guy,

> 2.5.2 announcenet let me know if anythings reads funny.
                              ^^^
Yes.  Nothing that a spell-checker would not catch though, I think.
:-)

Ray