Subject: [LON-CAPA-dev] Icons?

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 6 Apr 2007 09:50:23 -0400

Hi,

To maybe get away from some of our PPRM, CSTR, etc, icons, how do you  
like these:

http://www.famfamfam.com/lab/icons/silk/

- Gerd.

---

From: "Mark Urban-Lurain" <[email-masked]>
Date: Fri, 6 Apr 2007 12:44:52 -0400

So, which of these icons would be used to replace which buttons?

There's a reason that human beings replaced hieroglyphics with alphabets
thousands of years ago.  I've never quite understood why computers have
caused us to regress to iconic representations that are clear only if known,
but not to the novice.  

Mark

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> Gerd Kortemeyer
> Sent: Friday, April 06, 2007 9:50 AM
> To: [email-masked]
> Subject: [LON-CAPA-dev] Icons?
> 
> 
> Hi,
> 
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev
> 
>

---

From: "Michael W Edwards" <[email-masked]>
Date: Fri, 6 Apr 2007 12:56:59 -0500

Like a novice knows what PPRM or CSTR are either :)

Mike

> From: [email-masked] [mailto:lon-capa-dev-
> [email-masked]] On Behalf Of Mark Urban-Lurain
> Sent: Friday, April 06, 2007 11:45 AM
> Subject: RE: [LON-CAPA-dev] Icons?
>

---

From: "Phil Fazio" <[email-masked]>
Date: Fri, 6 Apr 2007 14:05:57 -0400

Another suggestion: the Tango icons. They are free (CC) and being actively
developed.  The plus is that you get icons larger than 16x16, but there
isn't as wide a range of icons yet.

http://tango.freedesktop.org/Tango_Icon_Gallery

Phil

---

From: [email-masked]
Date: Fri, 6 Apr 2007 14:09:46 -0400 (EDT)

The key in other case will be having the mouseover text show up with 
something coherent.

I, too, am a bit concerned that the icons will make some sense. At least 
CHRT and STAT aren't too far from Chart and Statistics.

If this were stop, play, fastforward, I'd understand the icons. Here I'm a 
little more concerned that they'll make less sense than now.

One complaint I've heard reiterated is that the buttons don't show up in 
alphabetical order. They are grouped loosely by function, but people don't 
see that.

Mark

>>> http://www.famfamfam.com/lab/icons/silk/

----------------------------------------------------------------------------
Mark Lucas					email: [email-masked]
252D Clippinger Lab  				phone: (740)597-2984
Department of Physics and Astronomy             fax:   (740)593-0433
Ohio University
Athens, OH 45701

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 6 Apr 2007 21:08:33 -0400

I was thinking of giving users a preference setting to replace the  
remote control buttons CSTR, PPRM, etc, with these icons, but leave  
the text next to it alone (or have the default be the icons).

The problem is that I sometimes published stuff (PUBL) instead of  
printing it (PRT) - go figure, both with "P" in the beginning - or I  
constantly go CUSR instead of CCRS ... stuff like that.

---

From: Felicia Berryman <[email-masked]>
Date: Tue, 10 Apr 2007 10:25:49 -0400

Hi Gerd,

I think separating the functionality into larger chunks instead of all 
in one big column in the main menu might help as well.  In addition, the 
layout probably would benefit from being in two-columns.

For example:

(Icon of a person) Create or Modify User
(Icon of a green slate board with a chalk writing of something like A+ 
or 1+1 in it) Create New Course

In the examples above, the text is terse and there is a two column 
layout so we can use much larger, readable text with bigger icons.

We can also run some card sorting and labeling studies to figure out 
what icons and text goes best with which functionality in addition to 
how we should group them on the main menu.  Similar work can be done for 
the inline menu.

Felicia

Gerd Kortemeyer wrote:
> remote control buttons CSTR, PPRM, etc, with these icons, but leave the 
> text next to it alone (or have the default be the icons).
> 

-- 
Felicia Berryman
LON-CAPA Support Coordinator
Michigan State University
Phone:  (517)432-9866
Technical Support Available at:
    http://www.loncapa.msu.edu - MSU Users
    http://www.help.lon-capa.org - General

---

From: Gerd Kortemeyer <[email-masked]>
Date: Tue, 10 Apr 2007 22:44:52 -0400

Hi Felicia,

On Apr 10, 2007, at 10:25 AM, Felicia Berryman wrote:

>
> I think separating the functionality into larger chunks instead of  
> all in one big column in the main menu might help as well.  In  
> addition, the layout probably would benefit from being in two-columns.

I just put the infrastructure into place for that, check it out  
(should be on data2 tomorrow).

>
> We can also run some card sorting and labeling studies to figure  
> out what icons and text goes best with which functionality in  
> addition to how we should group them on the main menu.  Similar  
> work can be done for the inline menu.

It would be good to determine the main menu groupings asap. I just  
put in some random categories to see how it works for now.

- Gerd.

---

From: Phil Fazio <[email-masked]>
Date: Wed, 11 Apr 2007 18:04:37 -0400

Gerd Kortemeyer wrote:
>> how we should group them on the main menu.  Similar work can be done 
>> for the inline menu.
>
> It would be good to determine the main menu groupings asap. I just put 
> in some random categories to see how it works for now.
>
> - Gerd.
>
Wow, very nice improvement. I think it is immediately much easier to 
use.  I might play around with that on my machine in the near future. 

I'm willing to throw out some suggestions for categories if you're 
willing to accept them. Please let me know what you think.

Phil

------

As a Student:

    My Places:
       |-  Roles/Courses (unknown icon) - Switch to another user role
       |-  Portfolio (home directory icon) - Enter my portfolio space
       |-  Bookmarks (bookmark icon) - Use or edit my bookmark collection
 
    Course Content:
       |-  Documents (generic document icon) - View documents included 
in this course
       |-  Navigate Contents (folder with paper icon) - Navigate the 
table of contents for this course

    Communication:
       |-  Mail (email icon) - Send and Receive Messages
       |-  Chat (discussion bubble icon) - Enter the chatroom for this 
course
       |-  Blog (variant of RSS feed icon, combined with pencil) - Edit 
Blogs, RSS feeds, and podcasts
      
    Course Tools:
       |-  Groups (unknown icon) - Enter my groups in the course
       |-  Calendar (calendar icon) - Course announcements and my calendar
       |-  Grades (possibly heart monitor icon) - View current problem 
status and grading information
       |-  Search (magnifying glass icon) - Search the contents of this 
course
      
    Preferences and Tools:
       |-  My Preferences (toolbox or tools icon) - Set my user preferences
   
    Exit (logout icon) - Exit LON-CAPA

--------

As a CC:

    My Places:
       |-  Roles/Courses (unknown icon) - Switch to another user role
       |-  What's New (clock with new 'light splash' icon) - What's New?
       |-  Portfolio (home directory icon) - Enter my portfolio space
       |-  Bookmarks (bookmark icon) - Use or edit my bookmark collection
   
    Resources:
       |-  Browse (networked folder icon) - Browse published resources
       |-  Search (magnifying glass icon) - Search the database of 
published resources and portfolio files

    Course Content:
       |-  Documents (generic document icon) - Edit and view documents 
included in this course
       |-  Navigate Contents (folder with paper icon) - Navigate the 
table of contents for this course
   
    Course Management:
       |-  Parameters - (icon of sliders on a board) - Modify parameter 
settings (due dates, etc) for resources and the course
       |-  Groups - (unknown icon) - Edit any group in the course
       |-  Announcements and Calendar (calendar icon) - Course 
announcements and my calendar
  
    User Management:
       |-  Enrollment (icon of people) - Manage enrollment
       |-  Custom Roles (hard hat icon) - Create a user or modify the 
roles and privileges of a user

    Grades and Statistics:
       |-  Spreadsheets (spreadsheet icon) - View calculated grades
       |-  Course Assessment Chart (some variant of spreadsheet icon)  - 
View the course assessment progress chart
       |-  Statistics (chart icon) - View course assessment statistics

    Exit (logout icon) - Exit LON-CAPA