Subject: [LON-CAPA-dev] Re: [Lon-capa-msu] Re: Construction Navigation

From: Felicia Berryman <[email-masked]>
Date: Wed, 06 Feb 2002 09:56:11 -0500

Hi Gerd,

John did request that earlier, but my impression was that this was a
very simple request that the file name, i.e.
/bio/photosynthesis/problems/light.problem, show up on the top of
"View", "Edit", and "Edit XML".  I'm copying this to John in case I have
this wrong.

Felicia

Gerd Kortemeyer wrote:
> 
> John,
> 
> Yep, here's what's in the queue:
> 
> When you browse a resource and hit CSTR, you get directly to the editor for it
> (it will internally need to switch roles on you if you are "co-author" - that is
> the hard part).
> 
> Ron: instead of actually switching roles, the access handler loncacc could also
> simply check if the author is a valid co-author for that file.
> 
> The Remote does "know" what file the user is looking at, and could directly
> construct the URL for it.
> Example: you look at /res/msu/bio/stuff/cell.html. Pressing CSTR gets you to
> /priv/bio/stuff/cell.html if you are on the home server.
> 
> In short: we can do it. Hope we get around to that in the not-too-distant
> future.
> 
> - Gerd.
> 
> Felicia Berryman wrote:
> 
> > Hi John,
> >
> > Your about the third person to request this.  I would assume that it is
> > on the to-do list.  Guy and Gerd are good at adding requests to the
> > to-do list as they come in.  I'm copying this to them just in case.
> >
> > Felicia
> >
> > J Merrill wrote:
> > >
> > > Felicia:
> > > Just another little useability issue:
> > >
> > > When I'm in construction space, and click to view a resource (problem),
> > > when that page opens there is no indication anywhere of what the file name
> > > for that resource is. So, for example, if I see something wrong, I can't
> > > just jot down the name of the file to report the problem, fix it later, or
> > > whatever. I'd have to go back to the file list from which I came and hope I
> > > can remember what I clicked on. Somehow, it would be useful to have the
> > > name of the thing we're looking at.
> > > John
> > >
> > > ****** [email-masked] ******
> > > John Merrill
> > > Microbiology and Molecular Genetics
> > > Michigan State University
> > > East Lansing MI 48824 USA
> > > 517.355.6517
> > > http://www.msu.edu/~merrill3
> > > ************************
> >
> > --
> > Felicia Berryman
> > LON-CAPA Coordinator
> > Michigan State University
> >   Email:  [email-masked]
> >   Phone:  (517)432-9866
> > http://www.lon-capa.org
> 
> _______________________________________________
> lon-capa-msu mailing list
> [email-masked]
> http://hobbes.lite.msu.edu/mailman/listinfo/lon-capa-msu

--
Felicia Berryman
LON-CAPA Coordinator
Michigan State University
  Email:  [email-masked]
  Phone:  (517)432-9866  
http://www.lon-capa.org

---

From: Guy Albertelli II <[email-masked]>
Date: Wed, 6 Feb 2002 10:23:57 -0500 (EST)

Hi Felicia,

> "View", "Edit", and "Edit XML".  I'm copying this to John in case I have

His request will be statisfied by Ron's work on eliminating the frames
in the CSTR space. (Since once the frames are eliminated the Location
bar will update and be accurate.)

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-9-8-  O-
    The next time the universe knocks on my door, I will pretend I
    am not home.

---

From: Gerd Kortemeyer <[email-masked]>
Date: Wed, 06 Feb 2002 10:41:35 -0500

> "View", "Edit", and "Edit XML".  I'm copying this to John in case I have

Yes, that would be another good change (and very quick to do).

- Gerd.