Subject: [LON-CAPA-dev] Single Apache Server

From: Guy Albertelli II <[email-masked]>
Date: Thu, 16 May 2002 23:26:17 -0400 (EDT)

Hi,

I noticed something in a bugreport and I thought I would pass this
helpful hint along:

/etc/init.d/httpd stop
/usr/sbin/httpd -X

If you do this Apache will only start up a single child.

This makes some debugging easier since you don't have to worry if you
are always getting the same child.

I also have learned that you can use the perl debugger against a
server running this way.

You need to add the below to a .conf file that Apache reads _BEFORE_
any other mod_perl directives (which in the new setup means in
httpd.conf right before the Include conf/loncapa_apache.conf)

PerlModule Apache::DB
<Perl>
  Apache::DB->init;
</Perl>
<Location />
  PerlFixupHandler Apache::DB
</Location>

(One might want to surround this with a 
<IfDefine PERLDEBUG>
</IfDefine>

aand then use 
/usr/sbin/httpd -X -DPERLDEBUG

Have Fun!
-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-6-  O-
    I am grateful that I am not as judgmental as all those censorious,
    self-righteous people around me.

---

From: Scott Harrison <[email-masked]>
Date: Fri, 17 May 2002 14:01:45 -0400

Dear Guy:

I added your tip to help.lon-capa.org.  I created a new
category called "Software Developer Tips".

Should we add the <IfDefine PERLDEBUG></IfDefine> statement
to the beginning of loncapa_apache.conf?  Sounds very
useful, though I have not yet tried it out.
x
Regards,
Scott

On Thu, May 16, 2002 at 11:26:17PM -0400, Guy Albertelli II wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

-- 
Scott Harrison, [email-masked]

They may forget what you said, but they will never forget how
you made them feel. --Carl W. Buechner

---

From: Guy Albertelli II <[email-masked]>
Date: Fri, 17 May 2002 15:57:05 -0400 (EDT)

Hi Scott,

> category called "Software Developer Tips".

Thanks.

(Note that it <Perl> and </Perl> are turned into links.

> useful, though I have not yet tried it out.

If you want. I don't see a great need for it.

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-6-  O-
    I would love to but . . . I have some real hard words to look
    up in the dictionary.