Subject: [LON-CAPA-dev] Re: solution found

From: Scott Harrison <[email-masked]>
Date: Thu, 07 Feb 2002 11:06:15 -0500

Gerd Kortemeyer wrote:

> > I am going to CVS commit a change to lond which will make sure
> > this bug never ever ever ever happens to anyone.
> > <     chomp($ip);
> > >     chomp($ip); $ip=~s/\D+$//g;
> >
> Not a good solution ...
> 
> There are a lot more functions that read config files and assume UNIX-style
> linebreaks. The real solution is to never edit UNIX config files on DOS machines

The real solution is to have
A) either an entry interface to troubleshoot input
   (dashes in names, crappy hosts.tab entries, horrible
   access(loncapa).conf)
  
B) and/or a script that checks to see "if things look good"

C) and/or really thorough installation/configuration/upgrading
   documentation that nobody reads

I agree.. at some point we have to
hold the line against the GIGO (garbage in
garbage out) principle.

> ...
> - Gerd.

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: Gerd Kortemeyer <[email-masked]>
Date: Thu, 07 Feb 2002 11:19:20 -0500

> hold the line against the GIGO (garbage in

YEP on A) and B). The solution for C) is a staggered documentation approach -
"Installation for Dummies" (meaning, in reality, people who just want a box up and
running and not deal with details - vanilla install) with very few steps using A)
including B) . Then hyperlinks from within documentation to increasingly more
detailed information of how to tweak stuff if you want and dare to.