Subject: [LON-CAPA-dev] 2.2 cur status

From: Guy Albertelli II <[email-masked]>
Date: Tue, 30 May 2006 11:54:36 -0400 (EDT)

Hi All,

This is my idea of where things currently stand for the eventual 2.2
release.

Items in the list are pulled for the 2.2 plas we set.

Let me know if I have somehing wonrg.

Bits in () are my comments on the current status of and item.

Things in the 'in progress' and 'still likely' lists have names
associated. Please let me know if I have something wrong or you
want/need a change.

There are some ? where I am uncertain.

Doneish:
  - BT even more less appendixy (grading queue, slots (multiple open/due))
  - presentation layer separation work

  - groups sectionesque (user can belong to multiple groups, normal PARM etc
                         limitations that apply to sections also apply to all
                         groups user belongs too, basically it's
                         like a user has multiple sections)

  - BT - install condition changes on s*
       - change text Done -> 'Next Item', Stop -> 'Quit Grading',
                     Cancel -> add to regrade
       - support the needed JS & CSS
       - add 'section specific slots'
       - PGRD needs to support display of BT grading history
       - separation of PGRD from 'queue grading'

  - FDBK
      - switch to radio button (so they can only send to a single location)
      - keep the user specified title

In progress:
 St - 'sub course' grouping 
           -  a group has a mini internal
              course associated with it, a sepearete
              discussion area, portfolio area,  chat area, etc.)
               (getting there 
                  - roster funtionality needed
                  - mail needs restrictions
                  - portfolio needs accessor linkages, permission checkings
                  - discusion board creation etc.)
                
 Ri - instructors can return a file as part of the grading process
        (creation occurs, message sent, portfolio and problem
        announcements still needed)

 Ge - track instructor for (PARM change log particularly) 
             (Mostly there, filtering display improvements needed to
              make the screen managgable)
 Gu - reformulating the <task> xml...

Not done but still likely:
 St  - searching portfolio metadata (stu/intsr)
        - portfolio access controls
 Gu  - in PGRD (grade an entire sequence) ability to specify the
             CODE that user had seen.
 St  - fine grained cloning choices
 Ge? - better things than Exam Upload perhaps new chunk to GRDS
              for displaying external grading info 
              ( could very well end up delayed)
 St  - student initiated email based password changing
 Gu? - conditionals - stop punishing the student
 Ge  - implement accessibility changes
 Gu  - BT - TA's need to be prioritized to grade users not in any of 
         their sections
          - don't allow grade of users without a checkout of a BT
          - CSV upload of parameters
 Ge? - FDBK
          - add ability to change the text associated with the general 
            fdbk locations

Delayed:
 - Discussion groups (similar to Angel) where a Group
               really is a course with everything just renamed.
                                  (renaming of Course -> Group
                                  Course Coordinator -> Group Coordinator etc.)
 - students can see their previous submissions
 - student - roles screen enhancement 
                   (possibly show future? and hide expired?)
 - making it easier to change usernames
 - multiclick image response
 - clicker grant
 - QTI
 - sequences with 'random order' to resources
 - better 'snapshot' of what a student has done in a course 
    (problems done.. posts made.. mails sent... login times...)
 - Lon-capa time in menu mode somehow...
 - simple problem plagerism
 - BT - queue grading should be able to do any queue entry at all

Decoupled from release schedule:
 - Camtasia training session help files for things that people want
               help for

-- 
[email-masked]   0-7-1-8-27,137

---

From: melissa michael <[email-masked]>
Date: Tue, 30 May 2006 11:14:32 -0500

Guy,
This is the only one that I'd like to see moved up if possible.
  - students can see their previous submissions
Thanks
mm

>_______________________________________________
>LON-CAPA-dev mailing list
>[email-masked]
>http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

-- 
Melissa Michael
Director for MCB Core Curriculum
Assistant Director for Instructional Affairs
School of Molecular and Cellular Biology
University of Illinois at Urbana-Champaign
393 Morrill Hall, MC-119
505 South Goodwin Avenue
Urbana,  Illinois  61801

office: 252 Davenport Hall
email:  [email-masked]
Tel:  (217) 244-6238 (office/voicemail)
Tel:  (217) 244-6239 (administrative assistant
Fax: (217) 244-8202

---

From: Guy Albertelli II <[email-masked]>
Date: Tue, 30 May 2006 13:45:06 -0400 (EDT)

Hi Melissa,

>   - students can see their previous submissions

Okay I'll do what I can...

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Wed, 31 May 2006 15:26:43 -0400

Guy, 

The following entry: 

 - Discussion groups (similar to Angel) where a Group
               really is a course with everything just renamed.
                                  (renaming of Course -> Group
                                  Course Coordinator -> Group Coordinator 
etc.) 

should be moved from the "Delayed" category to the "In progress" category, 
with 'St' as the active developer. 

Also the "Not done but still likely" category should include LON-CAPA 
installation on FC5 and SuSE 10.1, as well as Apache 2 compatibility and SSO 
support. 

Stuart

---

From: Guy Albertelli II <[email-masked]>
Date: Fri, 16 Jun 2006 16:41:54 -0400 (EDT)

Hi All,

2.2 status updates,

Doneish:

  - FDBK
      - switch to radio button (so they can only send to a single location)
      - keep the user specified title
  - FC5 + 2.2
  - reformulating the <task> xml (some display oddities but functionally there)
  - track instructor for (PARM change log particularly) 
  - Apache 2 compatibility (FC5 seems to be working will be testing in
                            production cluster in July)
  - portfolio access controls (code not yet commited, to be done so today)

In progress:
 St - 'sub course' grouping 
           -  a group has a mini internal
              course associated with it, a sepearete
              discussion area, portfolio area,  chat area, etc.)
               (getting there 
                  - roster funtionality needed
                  - mail needs restrictions
                  - portfolio needs accessor linkages, permission checkings
                  - discusion board creation etc.)                
 Ri - instructors can return a file as part of the grading process
        (creation occurs, files show on problem and message returned,
         process somewhat buggy, portfolio needs to show old file) 
 St - Discussion groups (similar to Angel) where a Group
               really is a course with everything just renamed.
               (structure in place, more strings needs updating)
 Gu - SSO support
          (works, but need to provide SSO style logout, login in again link needs 
           to point to not /adm/login, login link goes to local server not login
           server, remote control users get stranded)
 Ge - implement accessibility changes
 Ma - ability to force some roles into the recent roles list
 Gu - slots + homework problems, (issues with sequence wide slots,
                                  multipart problems)

 St  - searching portfolio metadata (stu/intsr), browsing public portfolio
 Gu - students can see their previous submissions
 St - SuSE 10.1 install

Delayed:
 - better things than Exam Upload perhaps new chunk to GRDS
 - track instructor for DOCS