Subject: [LON-CAPA-dev] emacs and londefdef

From: Gerd Kortemeyer <[email-masked]>
Date: Tue, 18 Feb 2003 15:34:07 -0500

Does anybody know why my emacs keeps choking on londefdef.pm? I can
hardly type a few characters without it repositioning my cursor and
whining about unbalanced parenthesis - but it seems to compile fine.

---

From: Gerd Kortemeyer <[email-masked]>
Date: Tue, 18 Feb 2003 15:57:57 -0500

Hmm ... actually, add "use Apache::lonmeta;" to the top of londefdef.pm,
and the whole thing blows up. Any ideas on what is happening there, how
I can syntax-check londefdef, etc?

Gerd Kortemeyer wrote:

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

---

From: Guy Albertelli II <[email-masked]>
Date: Tue, 18 Feb 2003 15:58:11 -0500 (EST)

Hi Gerd,

> whining about unbalanced parenthesis - but it seems to compile fine.

Hrrm, I am not seeing that here, what area of londefdef are you
modifying?

-- 
[email-masked]  LON-CAPA Developer  0-7-7-4-

---

From: Gerd Kortemeyer <[email-masked]>
Date: Tue, 18 Feb 2003 16:04:02 -0500

Vicinity of start_img

---

From: Guy Albertelli II <[email-masked]>
Date: Tue, 18 Feb 2003 17:39:34 -0500 (EST)

Hi Gerd,

> Vicinity of start_img

Works fine here. (xemacs 21.1 and emacs 20.7.1)

---

From: Guy Albertelli II <[email-masked]>
Date: Tue, 18 Feb 2003 17:40:27 -0500 (EST)

Hi Gerd,

> I can syntax-check londefdef, etc?

Seem to work fine here with a use Apache:lonmeta;
and the more correct
use Apache::lonmeta();