Subject: [LON-CAPA-dev] New Files

From: Gerd Kortemeyer <[email-masked]>
Date: Mon, 18 Feb 2002 16:03:09 -0500

New Files

CVS: loncom/cgi/lonversions.pl
Target: /home/httpd/cgi-bin/.
Permissions: www+rx
utility cgi-script to view software versions of remote server

CVS: loncom/cgi/ping.pl
Target: /home/httpd/cgi-bin/.
Permissions: www+rx
cgi-script to ping other server

---

From: Scott Harrison <[email-masked]>
Date: Mon, 18 Feb 2002 17:32:05 -0500

Dear Gerd:

lonversions.pl and ping.pl are added to the specification.

Note: permissions are defined by the <categoryname>script</categoryname>
tag inside the <file></file> tag for each of these two files.

The permissions are:
<category name="script" type="runtime">
  <chmod dist='default'>0500</chmod><chown dist='default'>www:www</chown>
  <abbreviation>script</abbreviation>
</category>
<category name="script" type="development">
  <chmod dist='default'>0700</chmod><chown dist='default'>www:www</chown>
  <abbreviation>script</abbreviation>
</category>

Thus, all web scripts are configured to have the same permissions.
make CATEGORY='runtime' install will install with runtime permissions.
By default, development permissions are currently used for all
file categories.

Regards,
Scott

On Mon, Feb 18, 2002 at 04:03:09PM -0500, Gerd Kortemeyer wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

-- 
Scott Harrison, [email-masked]

The reason a lot of people do not recognize opportunity is
because it usually goes around wearing overalls looking
like hard work. --Thomas Alva Edison

---

From: Behrouz Minaei <[email-masked]>
Date: Tue, 19 Feb 2002 14:01:12 -0500

Hi,

New version of "lonchart.pm" is commited.

Source file: loncapa/loncom/interface/lonchart.pm
Target: /home/httpd/lib/perl/Apache/lonchart.pm

Added bottons for sorting the chart according to the "Email Name" (defualt),
"Last Name" and "Section".
Data are cached to local machine after the first time running.

Please let me know any feedback of this version.

Behrouz