Subject: [LON-CAPA-dev] LON-CAPA-systemperl-3.4-1.i386.rpm built

From: Scott Harrison <[email-masked]>
Date: Wed, 10 Apr 2002 02:23:11 -0400

Dear All:

LON-CAPA-systemperl-3.4-1.i386.rpm is made.
http://install.lon-capa.org/3.1/latestRPMS/LON-CAPA-systemperl-3.4-1.i386.rpm

So, this should be better for RedHat 6.2.
For RedHat 7.2, you can either do directory fixing
with this RPM, or alternate approach... both described at:
how_to_install_on_RedHat7.2.txt (written by Matthew and I).

Added:
* HTML::Parser version 3.26
* Pod::POM

Verified:
* LON-CAPA-systemperl should NOT be overwriting any of the perl rpm
files.
* Math::FFT was already included (I just forgot I added it).

Failed:
* PerlMagick would not compile on RedHat 6.2.
  It says it requires ImageMagick version 5.4.1.
  RedHat 7.2 has ImageMagick and ImageMagick-perl
  (strangely enough for version 5.3.8... sigh)

And, historical note (how to do it in case I get
                      run over by a bus):
get HTML-Parser.tar.gz from CPAN
get Pod-POM.tar.gz from CPAN
get LON-CAPA-systemperl-3.3-1.i386.rpm from
   http://install.lon-capa.org/3.1/latestRPMS/.
get http://www.cpan.org/authors/id/S/SH/SHARRISON/make_rpm-1.17.pl

tar xzvf HTML-Parser.tar.gz
tar xzvf Pod-POM.tar.gz
install -d targetroot/var/lib/rpm
rpm --nodeps --noscripts --root \
   /home/harris41/systemperl/targetroot -ivh \
   LON-CAPA-systemperl-3.3-1.i386.rpm
cd HTML-Parser
perl Makefile.PL; make
make PREFIX=/home/harris41/systemperl/targetroot/ install
cd ../Pod-POM
perl Makefile.PL; make
make PREFIX=/home/harris41/systemperl/targetroot/ install
cd ..
Create a file customize.xml:
BEGINFILE
<vendor>
Laboratory for Instructional Technology Education, Division of
Science and Mathematics Education, Michigan State University.
</vendor>
<summary>Files for the <tag /> component of LON-CAPA</summary>
<name>LON-CAPA-<tag /></name>
<copyright>Michigan State University patents may apply.</copyright>
<group>Utilities/System</group>
<AutoReqProv>no</AutoReqProv>
<description>
This package is automatically generated by the make_rpm.pl perl
script (written by the LON-CAPA development team, www.lon-capa.org).
This implements the <tag /> component for LON-CAPA.
For more on the LON-CAPA project, visit http://www.lon-capa.org/.
</description>
<pre>
echo "************************************************************"
echo "LON-CAPA  LearningOnline with CAPA"
echo "http://www.lon-capa.org/"
echo " "
echo "Laboratory for Instructional Technology Education"
echo "Michigan State University"
echo " "
echo "** Michigan State University patents may apply **"
echo " "
echo "This installation assumes an installation of Redhat 6.2"
echo " "
echo "The files in this package are for the <tag /> component."
echo "***********************************************************"
</pre>
ENDFILE

Run this command:

find /home/harris41/systemperl/targetroot/ | \
perl make_rpm.pl systemperl 3.4 '' '' \
/home/harris41/systemperl/targetroot customize.xml

and then

scp LON-CAPA-systemperl-3.4-1.i386.rpm
[email-masked]:~/public_html/3.1/latestRPMS/.

Regards,
Scott

---

From: Guy Albertelli II <[email-masked]>
Date: Wed, 10 Apr 2002 02:35:46 -0400 (EDT)

Hi Scott,

> LON-CAPA-systemperl-3.4-1.i386.rpm is made.

It isn't correct yet.

1) I get these erros when installing:
warning: user harris41 does not exist - using root
warning: group harris41 does not exist - using root
warning: user harris41 does not exist - using root
warning: group harris41 does not exist - using root
warning: user harris41 does not exist - using root
warning: group harris41 does not exist - using root
warning: user harris41 does not exist - using root
warning: group harris41 does not exist - using root

2) > * HTML::Parser version 3.26

You added the stock HTML::Parser 3.26, I need to have the patch in
loncapa/doc/otherfiles/perl_modules.txt applied to the stock
HTML::Parser 3.26.

I'll send you the email with more detailed instructions and a test
case.

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-9-4-  O-
    Today I will rely on the language of love and understanding. 
    If that doesn't work, I'll go back to intimidation and fear.

---

From: Scott Harrison <[email-masked]>
Date: Wed, 10 Apr 2002 10:58:36 -0400

Dear Guy:

Ok.  Patch applied.

Try again at:

Sorry... I'm not clear as to what an output test is, but
this should work now.

Regards,
Scott

Guy Albertelli II wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: Guy Albertelli II <[email-masked]>
Date: Wed, 10 Apr 2002 11:22:32 -0400 (EDT)

Hi Scott,

> Ok.  Patch applied.

Looks like it works.

> > warning: group harris41 does not exist - using root

when doing rpm -Uvh --force LON-CAPA-systemperl-3.4-1.i386.rpm

> Sorry... I'm not clear as to what an output test is,

All I meant was to run the test script I sent, and see what was
printed out.

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-9-4-  O-
    I would love to but . . . I'm in training to be a household pest.

---

From: Scott Harrison <[email-masked]>
Date: Wed, 10 Apr 2002 11:44:13 -0400

Dear Guy:

Hrmm... it is not clear to me why this is happening.
Okay... I am replicating bug on kirk.lite.msu.edu
(keep smiling Matthew).

Oh.  I see. ..../var/lib/rpm was owned by harris41 and
mistakenly piped through rpm creation procedure.

This works:
find /home/harris41/systemperl/targetroot/ | grep -v
"^/home/harris41/systemperl/targetroot/var" | perl make_rpm.pl
systemperl 3.4 '' '' /home/harris41/systemperl/targetroot customize.xml

Thanks for all the feedback.

Regards,
Scott