Subject: [LON-CAPA-dev] 2.0.1 Draft Notice

From: Guy Albertelli II <[email-masked]>
Date: Thu, 1 Sep 2005 18:27:53 -0400 (EDT)

Hi All,

Can you double check this notice for me?

-----
New Version 2.0.1 Released

Notable Bug Fixes:
- documentation fixes
- chemistry templates and math example files are now installed
- upped lonc connection attempts
- portfolio quota calculation is now correct
- caching of hostname lookups speeds startup
- batch course creation correctly creates new users
- userstatus.pl ignores public users
- IE no longer will right align the Insert boxes
- grading no longer considers an empty submission a plagirism of
  another empty submission
- usernames with underscore work on grade whole course screen
- conditional hints work properly again
- workaround for Safari bugs in Coordinate selection
- acc parm value of 'no' is ignored now
- <problem bgcolor=""> works again
- use of () in "re" type <stringresponse> works corectly
- searching on a machine with MySQL 4.X works
- Spreadsheet's can be editied again
- Spreadsheet's 'Save and make deafult' works correctly
- statitisics no longer forgets to untie the course hash
- EXT in a problem can ask questions about a different problem
- image replication works more correctly on a empty server
- forward and backward work again when there are several of the same
  resources in a row

To install this update:

1) You will need to be running Fedora Core 2 or 3 or 4, RHEL ES 4, Suse 9.2

2) If running Fedora, use yum to update your machine and then install the
      LONCAPA-prerequisites (if not already installed).

yum update
yum install LONCAPA-prerequisites

    If running SuSe, use you to update your machine.
    if running RHEL, use up2date to update your machine.

3) Download the new LON-CAPA tarball from
wget http://install.lon-capa.org/versions/loncapa-2.0.1.tar.gz

and untar it

tar xzvf loncapa-2.0.1.tar.gz

4) Run the UPDATE script as root
cd loncapa-2.0.1
su
./UPDATE

5) restart the Lon-CAPA system services
/etc/rc.d/init.d/loncontrol stop
/etc/rc.d/init.d/loncontrol start

6) restart the webserver:

Fedora/Red Hat Enterprise:
/etc/rc.d/init.d/httpd stop
/etc/rc.d/init.d/httpd start

SuSe:
/etc/init.d/apache stop
/etc/init.d/apache start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org

-- 
[email-masked]   0-7-2-1-27,137

---

From: "Stuart Peter Raeburn" <[email-masked]>
Date: Thu, 01 Sep 2005 19:00:22 -0400

Guy, 

some typos and/or creative spelling 

replace "grading no longer considers an empty submission a plagirism of
  another empty submission" with
       "grading no longer considers an empty submission a plagiarism of
  another empty submission" 

replace "use of () in "re" type <stringresponse> works corectly"
with "use of () in "re" type <stringresponse> works correctly" 

replace "Spreadsheet's can be editied again"
with "Spreadsheets can be edited again" 

replace "Spreadsheet's 'Save and make deafult' works correctly"
with Spreadsheet's 'Save and make default' works correctly 

replace "statitisics no longer forgets to untie the course hash"
with "- statistics no longer forgets to untie the course hash" 

replace "image replication works more correctly on a empty server"
with "image replication works more correctly on an empty server" 

Stuart 

Guy Albertelli II writes: 

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev 
>