Subject: [LON-CAPA-dev] text editor without shell

From: Scott Harrison <[email-masked]>
Date: Thu, 07 Feb 2002 17:52:59 -0500

Dear All:

Does anybody know of a good linux text editor that
does not provide the user with a shell?  Even vi
does.

I'm thinking of setting up a sudo user for
the lon-capa configuration files and/or
critical administrative tasks.

No worries.. :|
JUST fishing for ideas... not embarking on
an expedition...

Regards,
Scott

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: "Matthew Brian Hall" <[email-masked]>
Date: Thu, 7 Feb 2002 19:14:29 -0500 (EST)

pico?

<shudders>

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev
>

--
------------------------------------------------------------------
Matthew Hall           LON-CAPA developer         [email-masked]
123 North Kedzie Hall                    Michigan State University
------------------------------------------------------------------

---

From: Scott Harrison <[email-masked]>
Date: Thu, 07 Feb 2002 21:49:53 -0500

yes.. I think that is indeed the solution..
(I was also thinking of an
editor called joe; 'joe's own editor')..

thanks!

Scott

---

From: Martin Siegert <[email-masked]>
Date: Thu, 7 Feb 2002 19:07:31 -0800

> > > JUST fishing for ideas... not embarking on

Scott,

I must agree with Matthew's <shudders> remark.
pico is written by the authors' of pine.
pine has probably one of the worst security records of all packages that
get installed on a Linux box.
Thus, do you really want to use pico for security related work? <shudder>

Anyway, since pico is contained in the pine rpm the "proper" way of
installing it is:

# rpm -Uvh pine-4.44-1.62.0.i386.rpm
# cp /usr/bin/pico /usr/local/bin
# cp /usr/man/man1/pico.1.gz /usr/local/man/man1
# rpm -e pine

... you don't want to have pine lying around ... somebody might use it :-)

Cheers,
Martin

---

From: Scott Harrison <[email-masked]>
Date: Fri, 08 Feb 2002 10:17:16 -0500

hmmm.. pico wouldn't overwrite even when sudo invoked...
so I guess the solution is probably to sudo the /bin/cp
command... okeedokee..

---

From: Guy Albertelli II <[email-masked]>
Date: Fri, 8 Feb 2002 10:25:36 -0500 (EST)

Hi Scott,

> does not provide the user with a shell?  Even vi

Debian uses ae for this purpose.

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-9-8-  O-
    Today I will gladly share my experience and advice, for there
    are no sweeter words than "I told you so."