Subject: [Lon-capa-dev] dashes in domain names and lonIds?

From: Scott Harrison <[email-masked]>
Date: Tue, 05 Feb 2002 11:49:36 -0500

Dear Anybody:

Are dashes allowed in domain names and/or lonIds,
or only alphanumeric characters?

Regards,
Scott

---

From: Gerd Kortemeyer <[email-masked]>
Date: Tue, 05 Feb 2002 13:19:43 -0500

Scott,

I do not know - this has never ever been tested. If it does not work, it
can screw up things really bad for EVERYBODY in the network.

So: No, only alphanumeric characters are allowed in domain names and
lonIds.

NO dashes or other specials chars, not even "_" - how's that for playing
it safe? Please do!

- Gerd.

Scott Harrison wrote:

> _______________________________________________
> lon-capa-msu mailing list
> [email-masked]
> http://hobbes.lite.msu.edu/mailman/listinfo/lon-capa-msu

---

From: Scott Harrison <[email-masked]>
Date: Tue, 05 Feb 2002 13:30:15 -0500

Dear Gerd:

My recollection was that, among many
other incredible things happening,
we tried dashes in Zimbabwe, and it
didn't work.  I grepped through the hobbes
mail archives, but can't find the e-mail,
so it must have been through telephone or
non-listserv e-mail that Guy and I figured this out.

I will contact Robert at Halle about this
then.

Shall I add
<blink><h1>No non-alphanumeric lonDefDomain or
lonHostID values</h1></blink>

to the beginning of
all pages of install.lon-capa.org? :)

Regards,
Scott

---

From: Gerd Kortemeyer <[email-masked]>
Date: Tue, 05 Feb 2002 13:48:25 -0500

Scott,

Yes, without the blink. And even better: have your install screen eliminate
those characters.

- Gerd.

---

From: Martin Siegert <[email-masked]>
Date: Tue, 5 Feb 2002 10:57:39 -0800

> > can screw up things really bad for EVERYBODY in the network.

I am quite sure that we started with sfu-lc. That didn't work.
We then tried sfu_lc - that didn't work either. We grudgingly 
converged to sfulc.
Thus, I believe this is "well tested" ...

Martin

---

From: Scott Harrison <[email-masked]>
Date: Tue, 05 Feb 2002 23:54:12 -0500

Two choices:

Have a great upgrade procedure

Have a great installation CD

Though RedHat finally got around to both improving and
reasonably releasing the CD installation code,
I have no wish to enjoy the anaconda-python adventure
again.

I look at the future in terms of:

* people do a RedHat 7.* install on their own
* and the web-based upgrade procedure takes care of the rest

(The web-based upgrade procedure should be deliverable on CD though)

Why on earth would I ever want to fill my mind with useless
knowledge about the intricacies of the RedHat installation
CD-ROM?  I think, yes, it truly does beat the insanity of
javascript.

Especially, when a great upgrade procedure has more to offer
to offer the future in a number of ways I think...

Regards,
Scott

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998