Subject: RE: [LON-CAPA-dev] 11-15-2005 meeting notes

From: "GARRETT, DONNELL MAZON" <[email-masked]>
Date: Wed, 16 Nov 2005 16:21:58 -0500

I was forwarded this question:

I wonder:  If Lon-CAPA can communicate via COM and XML docs, it might
even be possible to use a tool like Matlab or Mathcad or Maple to let
the students enter math expressions and do any symbolic processing on
them, then let Lon-CAPA evaluate if the correct answer was entered. Then
we get the best of both worlds because we already have licenses for the
various math engines.
-Roger Dougal

I don't know the answer
What should I reply with?

I was under the understanding that the external response would allow for
external solving, however how this is done I don't know yet.  Via COM? I
dunno.. I assume that XML docs can be used (since that's how .problem's
are constructed anyway).  I haven't had time to mess with external
response yet.

Thanks
Donnell

---

From: Guy Albertelli II <[email-masked]>
Date: Wed, 16 Nov 2005 16:34:27 -0500 (EST)

Hi Donnell,

> are constructed anyway).  I haven't had time to mess with external

It is done through HTTP (we submit a http POST request to a specifed
url with 
- any key/value pairs the problem wants to send
- the text of the student's submission
- the problem's answer

We then expect back an xml response that looks like:

<loncapagrade>
  <awarddetail>EXACT_ANS</awarddetail>
  <message>Message to student</message>
</loncapagrade>

Current valid possible awards are: (some of these may not make sense
in this context, and if we need new ones they aren't hard to add)

MISSING_ANSWER
ERROR
NO_RESPONSE
TOO_LONG
UNIT_INVALID_INSTRUCTOR
UNIT_INVALID_STUDENT
UNIT_IRRECONCIBLE
UNIT_FAIL
NO_UNIT
UNIT_NOTNEEDED
WANTED_NUMERIC
BAD_FORMULA
SIG_FAIL
INCORRECT 
MISORDERED_RANK
INVALID_FILETYPE
DRAFT
SUBMITTED
ASSIGNED_SCORE
APPROX_ANS
EXACT_ANS
COMMA_FAIL 

-- 
[email-masked]   0-7-2-0-27,137