Subject: [LON-CAPA-dev] Version 0.5 tagged

From: Guy Albertelli II <[email-masked]>
Date: Thu, 15 Aug 2002 00:02:45 -0400 (EDT)

Hi All,

New tag version_0_5 is now in cvs.

I think it is close to release ( I have installed it on data )

Things that need fixing still:
- statitiscs has a couple of issues, (unable to tie, redownload doesn't
                                      increment couter, . . .)
- Can't make a problem from a template
- search for resource can lose select buttons
- select buttons in search not working on netscape 6 on MacOSX

Things I am currently ignoring:
- build updates over past 2 days (both build directory files,
                                  and loncapafiles.lpml)
- lonsql both explicitly bad version and the newer maybe not bad version
- chat updates

If there is something you 
1) don't like  about the release
2) don't want in the release
3) think needs fixing before release

let me know

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-4-  O-
    Well I best be going . . . crack don't smoke itself you know 
                                           -C.Chambers

---

From: Jeremy Bowers <[email-masked]>
Date: Thu, 15 Aug 2002 02:09:11 -0500

> 3) think needs fixing before release

Scott has educated me on the importence of semicolons in the file glob 
listings and I also had an extraneous .tex file in the file glob. If the 
.tar building is importent to be officially in STABLE, you should apply 
version diff 1.62 -> 1.64 (that's two new versions, 1.63 which added the 
semi-colons and 1.64 which removed a missing file).

---

From: Scott Harrison <[email-masked]>
Date: Thu, 15 Aug 2002 00:33:32 -0400

Guy,

#1)
The new semi-colons and removed extraneous file should be included
in the STABLE-ified loncapafiles.lpml--as Jeremy mentioned.

Files you might want to temporarily remove from loncapafiles.lpml are:
+ perltest.pl (TARGET=/home/httpd/cgi-bin/perltest.pl)
+ cpan_distributions.txt

Then, loncapafiles.lpml should be compatible with what you envision
(ignoring new build stuff for now, etc).

#2)
Also, I have noticed many new modules added to loncapafiles.lpml...
in the last week or two.

Are these really all ready to be STABLE?

#3)
To test your proposed STABLE distribution, you might try typing:

"make build" and then "make tardist".

#4)
(Also, a final reminder to not include tth_func.c in the tarball
 once it really truly is being built for version 0.5.)

Just my two cents.

Regards,
Scott

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev
> ------( NOTE )------------->
> This E-mail was scanned for viruses by Ramcell Online 
> (http://www.ramcell.net/antivirus.asp)
> 

-- 
Scott Harrison, [email-masked]

---

From: Scott Harrison <[email-masked]>
Date: Thu, 15 Aug 2002 00:47:45 -0400

Ih Yug,

> Are these really all ready to be STABLE?

To complete my thought... are you sure that loncapafiles.lpml as
it is two days ago ...

it still has lots of new modules...

and all those new modules are stable?

Sdrager, Ttocs

---

From: Guy Albertelli II <[email-masked]>
Date: Thu, 15 Aug 2002 15:29:15 -0400 (EDT)

Hi Scott,

> in the STABLE-ified loncapafiles.lpml--as Jeremy mentioned.

Thanks I'll make a branch version of this.

> Are these really all ready to be STABLE?

Chat is fairly simple and I don't care if doesn't work, so I am going
to include it.

Gerd assures me that calendar works. Feel free to poke at it to to
make sure it works.

I am going to disable the Course Docs button we have had another
rethink on how it should work to better support some future ideas that
we want so I am going to inhibit it, and there were a couple of
modules associated with it, I will let them install but it will be
effectively dead code for now.

> "make build" and then "make tardist".

Yep I'll be doing that tommorrow ish on s4.

>  once it really truly is being built for version 0.5.)

Thanks!
-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-4-  O-
    Explaining the ineffable can be difficult -E.O. Wilson