Subject: [LON-CAPA-dev] 2.2.2 is around the corner

From: Guy Albertelli II <[email-masked]>
Date: Fri, 6 Oct 2006 15:28:09 -0400 (EDT)

Hi All,

2.2.2 is coming round the mountain.... let me know if my english is
    lacking or wrong.

---------
New Version 2.2.2 Released

This is bugfix release. It's highly suggested that you install this
update.

Changes From 2.2.1:
- Support SLES 10, SuSE 10.1
- two classes of spare hosts possible

Bugfixes from 2.2.1:
- put correct extension on encrypted urls used in tags (like <img>)
- imporvements to how SSO is handled
- correct spelling of lonSSOUserUnknownRedirect (was lonSSOUserUnkownRedirect)
- printing works correctly on https style servers
- correct after end of slot submission notification message
- grading while viewing a student view of a problem was broken
- grading problems with _ in the part id failed to work
- when scantron grading skipped students, the students stay on the
  skipped list until they have actually been graded. (This means a user
  can appear on both the skipped and corrected lists)
- resource's whose titles started with _ caused internal server errors
- updated the Physical Units help to include all supprted units
- directories with ' could cause problems in DOCS when it was the 
  last location visited in RES
- course language now properly overrides user's selected language
- links in blog entries didn't actually get added to the entry
- can edit the export row of the student level spread sheet
- German translation updated
- some speedups to printing/scantron grading
- Detailed problem analysis of radiobutton response graphs no longer
   are blank
- accessing /adm/authenticate no longer causes an ISE

To install this update:

1) You will need to be running Fedora Core 4 or 5, RHEL (AS|ES) 4,
   SUSE 9.3 or 10.1, SLES 9 or 10
     (Fedora Core 3 should continue to work but is deprecated.)

2) If running Fedora, use yum to update your machine and then install the
      LONCAPA-prerequisites (if not already installed).

yum update
yum install LONCAPA-prerequisites

    If running SUSE 9.3 or SLES 9, use you to update your machine.
    If running SUSE 10.1 or SLES 10, use rug to update your machine.
    if running RHEL, use up2date to update your machine.

3) Download the new LON-CAPA tarball from
wget http://install.lon-capa.org/versions/loncapa-2.2.2.tar.gz

and untar it

tar xzvf loncapa-2.2.2.tar.gz

4) stop the Lon-CAPA system services

/etc/rc.d/init.d/loncontrol stop

5) stop the webserver:

Fedora/RHEL:
/etc/rc.d/init.d/httpd stop

SUSE/SLES:
/etc/init.d/apache stop

6) Run the UPDATE script as root
cd loncapa-2.2.2
su
./UPDATE

7) restart the Lon-CAPA system services
/etc/rc.d/init.d/loncontrol start

8) restart the webserver:

Fedora/RHEL:
/etc/rc.d/init.d/httpd start

SUSE/SLES:
/etc/init.d/apache start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org

-- 
[email-masked]   0-7-1-6-27,137

---

From: Ray Batchelor <[email-masked]>
Date: Fri, 6 Oct 2006 14:16:37 -0700

> 2.2.2 is coming round the mountain.... let me know if my english is

This is colloquial.  You need more glottal stops.
e.g.
"Comin' Roun' d' Moun'n".

---

From: Felicia Berryman <[email-masked]>
Date: Sat, 07 Oct 2006 11:38:41 -0400

did you add the bug fix for radio button stat graphs in detailed problem 
analysis?