Subject: [LON-CAPA-dev] Source Line Counting Revisited

From: Guy Albertelli II <[email-masked]>
Date: Mon, 8 Jul 2002 09:56:54 -0400 (EDT)

Hi,

I thought this program was rather cute:
http://www.dwheeler.com/sloccount/

Run on the LON-CAPA checkout, I get:

Totals grouped by language (dominant language first):
perl:         50135 (52.08%)
ansic:        27268 (28.33%)
tcl:          13976 (14.52%)
yacc:          3456 (3.59%)
java:           908 (0.94%)
sh:             380 (0.39%)
python:         142 (0.15%)

Total Physical Source Lines of Code (SLOC)                = 96,265
Development Effort Estimate, Person-Years (Person-Months) = 24.19 (290.30)
 (Basic COCOMO model, Person-Months = 2.4 * (KSLOC**1.05))
Schedule Estimate, Years (Months)                         = 1.80 (21.57)
 (Basic COCOMO model, Months = 2.5 * (person-months**0.38))
Estimated Average Number of Developers (Effort/Schedule)  = 13.46
Total Estimated Cost to Develop                           = $3,268,011
 (average salary = $56,286/year, overhead = 2.40).
SLOCCount is Open Source Software/Free Software, licensed under the FSF GPL.
Please credit this data as "generated using 'SLOCCount' by David A. Wheeler."

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-4-  O-
    I like work; it fascinates me. I can sit and look at it for hours.

---

From: "Matthew Brian Hall" <[email-masked]>
Date: Mon, 8 Jul 2002 10:01:45 -0400 (EDT)

>  (average salary = $56,286/year, overhead = 2.40).

Hmmmmm.

--
------------------------------------------------------------------
Matthew Hall           LON-CAPA developer         [email-masked]
123 North Kedzie Hall                    Michigan State University
------------------------------------------------------------------

---

From: Scott Harrison <[email-masked]>
Date: Mon, 8 Jul 2002 11:38:08 -0400

Dear All:

If of interest, another approach is to use loncom/build/Makefile.cvs.

Current output: http://spock.lite.msu.edu/cvsstats2/

Total lines of "code" is 191116...however this
is including interface files like *.html (I did, however,
filter out *.eps files...I think).

The number of perl module lines of code with this method is
28224 (blank lines were excluded).

LON-CAPA is just one big web-page.  It should only take a single day
to develop. :)

Regards,
Scott

On Mon, Jul 08, 2002 at 09:56:54AM -0400, Guy Albertelli II wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

-- 
Scott Harrison, [email-masked]

---

From: Gerd Kortemeyer <[email-masked]>
Date: Mon, 08 Jul 2002 12:21:05 -0400

> >  (average salary = $56,286/year, overhead = 2.40).

You are not counting the stock options that we give out for
lon-capa.org.

- Gerd.