Subject: [LON-CAPA-dev] Re: Port 8080

From: Gerd Kortemeyer <[email-masked]>
Date: Mon, 24 Feb 2003 09:13:19 -0500

Dear Mirek,

No, you can revert to port 80, but what will happen is that the rather
large Apache children (several tens of megabytes) are busy serving tiny GIF
images. The port 8080 mechanism was used to have a lightweight featureless
webserver provide the tiny images from memory cache.

An alternative route would be to configure lonhttpd
(/home/httpd/perl/lonhttpd) to run from another port, say 88 or 8888, and
then modify the scripts to get the images from that port.

- Gerd.

"Mirek Majewski (from office)" wrote:

> Dear Gerd,
>
> A few days ago we installed LON-CAPA on a computer in the Kuwait
> University. Due to configuration of the network at Zayed University we
> had to go to a computer that is outside, and Kuwait was the best option.
> However, we found another unpleasant thing. In the whole Emirates port
> 8080 is blocked by the local internet provider. This way we were getting
> LON-CAPA pages without pictures (they are loaded through the port 8080).
> Today we changed in all PERL files port 8080 to 80. I wonder if there
> are any unexpected events that may happen due to this change?
>
> Any way, according to my observations in a few countries in this region
> port 8080 is blocked by default. Perhaps it could be worth to be
> prepared that such thing many occur more often.
>
> Best regards
>
> Mirek
> -----------------------------------
> Prof. Miroslaw Majewski, College of Information Systems, ZU
> Editor of mathPAD Online, http://www.mathpad.org/

---

From: Guy Albertelli II <[email-masked]>
Date: Tue, 25 Feb 2003 13:44:22 -0500 (EST)

Hi All,

> then modify the scripts to get the images from that port.

Should now work from a config option in loncapa_apache.conf in the
latest version.

-- 
[email-masked]  LON-CAPA Developer  0-7-7-4-