Subject: [LON-CAPA-dev] lonc?

From: Mark Lucas <[email-masked]>
Date: Mon, 4 Mar 2002 14:48:27 -0500 (EST)

Hi-

	A little earlier I tried downloading the latest and greatest (ie.,
unstable CVS checkout). I installed on CAPA1 (our development machine) and
have not been able to get the system functioning again. I can get the
login screen, but the login is not functioning.

	I'm going to wade through some more to see if I have disfunctional
code changes that are burning us. In the meantime, there was a comment bu
Guy that one should stick to the stable version of lonc. Are there any
other core files that I should stick to stable? (ie, I will literally
check out the stable version of lonc only - does lond also need to be set
to stable?)

						Mark

----------------------------------------------------------------------------
Mark Lucas					email: [email-masked]
252D Clippinger Lab  				phone: (740)597-2984
Department of Physics and Astronomy             fax:   (740)593-0433
Ohio University
Athens, OH 45701

---

From: Scott Harrison <[email-masked]>
Date: Mon, 04 Mar 2002 14:48:34 -0500

Dear Mark:

Some recommendations.

cd loncom
cvs update -r STABLE lonc
cvs update -r STABLE lond

cd loncom/build
make build
make install (as root)

make test (as root)

The "make test" target will test whether or not a login
is supported.

Also, a sanity check is now implemented at the end of "make install"
which should verify whether or not access.conf and hosts.tab
are "good".

Regards,
Scott

Mark Lucas wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: Scott Harrison <[email-masked]>
Date: Mon, 04 Mar 2002 14:50:06 -0500

minor addition...

> cvs update -r STABLE lond

/etc/rc.d/init.d/loncontrol restart
/etc/rc.d/init.d/httpd restart

---

From: Gerd Kortemeyer <[email-masked]>
Date: Tue, 05 Mar 2002 08:34:17 -0500

Hi Mark,

Sorry for that most recent lonc ... we now have an additional developer, Ron Fox,
working on the lonc/lond mechanism. lonc/lond never REALLY worked, we always lost
connection, or connections got "stuck".

Production machines in the cluster should never have anything but the STABLE
releases installed. That's why we have STABLE. Obviously, not all changes are good
...

Connected with the most recent lonc are a few new lines in lonnet.pm - they attempt
to shut down dysfunctional connections by sending a command to lonc. Older lonc's
don't understand that new command, so you might also want to downgrade lonnet.

Again, sorry for the mess and inconvenience.

- Gerd.

---

From: Gerd Kortemeyer <[email-masked]>
Date: Tue, 05 Mar 2002 08:40:21 -0500

Hi Mark (and Scott, see below),

Relevant here: Guy found this on another machine:

> /home/httpd/html/lon-status/londchld/ was owned by root, and was
> unwritable by www
>
If that is the case, lonc and lond will kill all of their children all the
time, since there is no way for them to report status, so they are assumed dead
to begin with.

This would be an installation problem: wrong permissions on londchld.

- Gerd.

---

From: Mark Lucas <[email-masked]>
Date: Tue, 5 Mar 2002 08:51:51 -0500 (EST)

Gerd,

	Thanks for the feedback. It looks like londchld is okay (owned by
www). I pulled across the stable lonc and lond as suggested by Scott, and
things are fine. This is our development library server, capa1 (just in
case you were worried I took out our production cluster).

						Mark

---

From: Scott Harrison <[email-masked]>
Date: Tue, 05 Mar 2002 09:45:24 -0500

Dear Gerd:

According to the loncapafiles.lpml cvs log
and the Makefile.install...

install -o www -g www -m 0755 -d /home/httpd/html/lon-status/londchld

londchld has never been defined as a root owned directory.

This is not an installation problem.
This must be a user error or system administrator error.

Regards,
Scott

---

From: Scott Harrison <[email-masked]>
Date: Tue, 05 Mar 2002 10:17:49 -0500

Dear Gerd:

If people run "make install" more often, this will have the
magical effect of making their machine more up to date,
and will fix errors like londchld permissions that they
somehow created.

We are turning this into a vanilla layer "upgrade me" button
to make it even more simple.

Regards,
Scott

---

From: Guy Albertelli II <[email-masked]>
Date: Tue, 5 Mar 2002 10:20:49 -0500 (EST)

Hi Scott,Gerd,

> londchld has never been defined as a root owned directory.

That was my fault.

> This must be a user error or system administrator error.

Yep, it was this user.

-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-9-8-  O-
    Well I best be going . . . crack don't smoke itself you know 
                                           -C.Chambers