Subject: [LON-CAPA-dev] 4-22-08 meeting notes

From: Felicia Berryman <[email-masked]>
Date: Thu, 24 Apr 2008 14:57:38 -0400

SUMMARY OF MYSTERY BUGS:
Still a mystery:
- Neutrino bug: Still unknown causes
- Error 500: This can be masked and worked around
Maybe not a mystery:
- CAPA response:  Swig error?
No longer mystery:
- Log-in screen in metadata: Caused by logging out while publishing
- Exam grading number shift:  Caused by changing roles while grading. 
  Logging out while grading still needs to be tested.

Felicia
- conference planning with Ray, discussion about conference accounts
- verified that log-in screen in metadata is caused by logging out while
    publishing
- verified that exam number shift is caused by switching roles while grading
- Planned summer meetings: May 13 - August 26, 2:30 - 4:00 PM, 212 N Kedzie.
to-do
- test unit and numerical input some more
- teacher registration form
- clarify bug repots
- check-out answer display printout on data2
- attending MSU IT conference

Gerd
- gathered research about outdated machines
- some install/sys-admin support
- ran LON-CAPA training at Frontiers workshop on Saturday.  Went well.
- worked with student on PDF form printout and upload
- sentmail cache issues
to-do
- work on method to lock publication and grading to prevent two of the
    mystery bugs
- testing the regrade of one student

Stuart
- propath updates: ls3 and statfile in lonnet
- worked on scantron.tab such that users are given scantron formats based
    on which server the course is in, not which server they are logged in on
- more discussion on username changes
- hardware: autoloader fixes and improvments
- more work admin interface for registration
- worked on rtf/html testbank import
to-do
- self-enrollment token issue
- update course catalog such that some courses can be excluded
- create mechanism to display user enrollment history
- improve roles screen display when you don't have any roles
- investigate environment issues (publication and grading mystery bugs)
- campus source updates
- get rid of old MSU versions in scantron.tab
- finish last propath call in filelocation

Ron
- started testing the new entities.pm  1'st step
    ensuring that LaTeX can do an error free processing of the output.
- In the process found/reported/fixed BZ 5961...that the existing
    lonprintout.pm could produce invalid latex for some entities

---

From: Peter Riegler <[email-masked]>
Date: Fri, 25 Apr 2008 15:34:00 +0200

Felicia, Gerd,

> - test unit and numerical input some more

is this something one of my students could do?
I have hired one to assist Stefan with &mt-ing code. Maybe he or someone 
else could do this testing?

Peter

-- 
Peter Riegler
Fachhochschule Braunschweig/Wolfenbüttel
Salzdahlumer Str. 46/48, 38302 Wolfenbüttel
Tel. +49 5331 939 6314, Fax. +49 5331 939 6002
email: [email-masked]
http://public.rz.fh-wolfenbuettel.de/~riegler

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 25 Apr 2008 11:31:35 -0400

Hi,

On Apr 25, 2008, at 9:34 AM, Peter Riegler wrote:

> I have hired one to assist Stefan with &mt-ing code. Maybe he or  
> someone else could do this testing?

Yes, you would need to use a development server. I fixed some of the  
unit evaluation, so it both includes implicit multiplication, and in  
certain situations does not work by accident, but by design. Try  
multidimensional situations, like

3,5.3,1 m/s

Thanks!!!

- Gerd.