Subject: [LON-CAPA-dev] ALERT! perl 5.6.1

From: Scott Harrison <[email-masked]>
Date: Tue, 07 May 2002 21:05:48 -0400

Dear All:

Any great strategies out there?  (I am 99% ready
now to fully adopt Ron's recommendation of using
cfengine because RedHat RPM updates are officially nuts...)

(The only other alternative is to have knowledgeable
system admins who never make human errors.)

--> http://bugs.lon-capa.org/show_bug.cgi?id=414 <--
Maybe we should change systemperl naming scheme to be:
LON-CAPA-systemperl-5.6.1-rh72

Except another caveat...

RedHat did what I knew it would do... it released
perl 5.6.1 as an RPM update without updating all the
other perl packages that are still in the 5.6.0 tree...

These include:
perl-DateManip-5.39-5
perl-HTML-Parser-3.25-2
perl-Parse-Yapp-1.04-3
perl-libwww-perl-5.53-3
perl-libxml-perl-0.07-5
perl-DBI-1.18-1
perl-Digest-MD5-2.13-1
perl-HTML-Tagset-3.03-3
perl-libnet-1.0703-6
perl-NKF-1.71-2
perl-Storable-0.6.11-6
perl-URI-1.12-5
perl-XML-Encoding-1.01-2
perl-XML-Parser-2.30-7
perl-libxml-enno-1.02-5
perl-XML-Twig-2.02-2
perl-CPAN-1.59_54-26.72.3
perl-File-MMagic-1.06-2
perl-MIME-Base64-2.12-6
perl-Text-Kakasi-1.04-4
perl-XML-Grove-0.46alpha-3
perl-XML-Dumper-0.4-5
perl-SGMLSpm-1.03ii-4
perl-DBD-MySQL-1.2216-4

Regards,
Scott

-- 
Scott Harrison -- Graduate Student
Microbiology and Molecular Genetics
Mich. State. Univ., East Lansing, MI
[email-masked], 517-353-0998

---

From: Guy Albertelli II <[email-masked]>
Date: Tue, 7 May 2002 23:17:30 -0400 (EDT)

Hi Scott,

> other perl packages that are still in the 5.6.0 tree...

However they did make sure it had an intelligent include line.

It looks first in the 5.6.1 dirs, and then in the 5.6.0 dirs.

Which mean things will still work fine as they are.
-- 
[email-masked]        BM: n^20 t20 z20 qS 
Guy Albertelli -7-8-7-  O-
    I would love to but . . . I have some real hard words to look
    up in the dictionary.

---

From: Scott Harrison <[email-masked]>
Date: Tue, 07 May 2002 17:20:01 -0400

Cool!  Thanks.

Guy Albertelli II wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev