Subject: [LON-CAPA-dev] Meeting Notes 2-22-2005 (pt. 2)

From: Guy Albertelli II <[email-masked]>
Date: Tue, 22 Feb 2005 16:48:18 -0500 (EST)

Forgot the pdf.

-- 
[email-masked]  LON-CAPA Developer  0-7-3-2-

---

From: "H. K. Ng" <[email-masked]>
Date: Thu, 24 Feb 2005 09:48:46 -0500

I did a cvs update and when I restart httpd it complain that "Can't locate 
AlgParser.pm in @INC ...." So naturally, I tried to find the rpm module but 
could not locate one. Where can I get a copy? Thanks, -hk

---

From: Matthew Hall <[email-masked]>
Date: Thu, 24 Feb 2005 08:23:02 -0700

Hi Hon-Kie,

Use "cvs update -d".  CVS doesn't by default create new directories
and AlgParser.pm is in a new directory,
loncapa/modules/TexConvert/algebra

Matthew

On Thu, 24 Feb 2005 09:48:46 -0500, H. K. Ng <[email-masked]> wrote:
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev
> 

-- 
-------------------------------------
Matthew Hall
[email-masked]    Try not to read it as "hamtheallwet".

---

From: "H. K. Ng" <[email-masked]>
Date: Thu, 24 Feb 2005 10:39:54 -0500

Hi Matthew,

>loncapa/modules/TexConvert/algebra

This is what I got when I ran

[ng@tycho TexConvert]$ pwd
/home/ng/loncapa/modules/TexConvert

[ng@tycho TexConvert]$ cvs update -d
cvs update: Updating .
cvs update: cannot open directory /home/cvs/modules/TexConvert: Permission 
denied
cvs update: skipping directory

It looks like I don't have access to TexConvert subdir. I ran it on 
TeXConvert but that gave a different message.

-hk

---

From: Matthew Hall <[email-masked]>
Date: Thu, 24 Feb 2005 09:27:40 -0700

Hi Hon-Kie,

This should remind me not to reply without testing things.  Guy will
have to deal with this...

Matthew

---

From: Guy Albertelli II <[email-masked]>
Date: Thu, 24 Feb 2005 13:08:28 -0500 (EST)

Hi Hon-Ke,

> cvs update: skipping directory

Give this a try again.

I believe I have the permissions repaired.

---

From: Guy Albertelli II <[email-masked]>
Date: Thu, 24 Feb 2005 13:19:00 -0500 (EST)

Hi Hon-Kie,

> > >loncapa/modules/TexConvert/algebra

Bluh I moved it to

loncapa/loncom/xml/algebra

do a cvs update -d in loncapa

and make build/install should wok again
sorry about this.

---

From: "H. K. Ng" <[email-masked]>
Date: Thu, 24 Feb 2005 13:52:44 -0500

Hi Guy,

>loncapa/loncom/xml/algebra

BTW - what does this module do? Seems like something useful for our 
AlgebraI library.

>and make build/install should wok again

Seems to help somewhat.

make build quit at
make[2]: Leaving directory `/home/ng/loncapa/loncom/homework/caparesponse'
No #! line at capa.pm line 1.
make[1]: *** [../../loncom/homework/caparesponse/capa.so] Error 9
make[1]: Leaving directory `/home/ng/loncapa/loncom/build'
make: *** [build] Error 2

and make install
install: cannot stat `../../loncom/cron/loncapa.built': No such file or 
directory
make[2]: *** [/etc/cron.d/loncapa] Error 1
make[2]: Leaving directory `/home/ng/loncapa/loncom/build'
make[1]: *** [configinstall] Error 2
make[1]: Leaving directory `/home/ng/loncapa/loncom/build'
make: *** [install] Error 2

- loncontrol and httpd seem to start but I don't get the login page - says 
"This LON-CAPA servers is temporarily unavailable ..."

Thanks,
hk

---

From: Guy Albertelli II <[email-masked]>
Date: Thu, 24 Feb 2005 15:15:31 -0500 (EST)

Hi Hon-Kie,

> AlgebraI library

I parses 'algebraic notation' into latex and then passes tth over it.

so 3/4 -> \frac{3}{4} 
   alpha^tau -> \alpha^{\tau}
   etc.

This should look goodish:
<algebra>asin(3/(int(x,4,10)))</algebra>
 
> "This LON-CAPA servers is temporarily unavailable ..."

That is beacuse you are unable to connet to yourself.

Check the lonc.log lond.log for the reason why.
-- 
[email-masked]  LON-CAPA Developer  0-7-3-2-

---

From: "H. K. Ng" <[email-masked]>
Date: Thu, 24 Feb 2005 15:43:25 -0500

Hi Guy,

This is great for the algebraI Lib.

>I parses 'algebraic notation' into latex and then passes tth over it.

What about an expression over another? Not as \frac but say {{ x^2 + x} 
\over {y^2 + 2 y}}

><algebra>asin(3/(int(x,4,10)))</algebra>

Presumably, you have
<algebra eval="on"> to insert variables etc.

Thanks,
-hk

---

From: Guy Albertelli II <[email-masked]>
Date: Thu, 24 Feb 2005 16:25:53 -0500 (EST)

Hi Hon-Kie,

> This is great for the algebraI Lib.

I expect so.

BTW it handles

<algebra>a--b+-c-+d</algebra> converting it to a+b-c-d

> What about an expression over another? Not as \frac but say {{ x^2 + x} 

<algebra>(x^2+x)/(y^2+2y)</algebra> -> \frac{x^{2}+x}{y^{2}+2 y}

the idea behind algebra is to make things easy to input, if you want
complete control over what it looks like, <m> is for that.

> <algebra eval="on"> to insert variables etc.

Nope.

<m> needs it because $ means someting in LaTeX, but $ doesn;t mean
anything in algebra so I can handle

<algebra>x^$pow+$constant</algebra>

just fine.

BTW almost all of the code doing this was grab from Moodle who got it
from WebWork.