Subject: [LON-CAPA-dev] 2.2.1 pre-announce

From: Guy Albertelli II <[email-masked]>
Date: Fri, 8 Sep 2006 16:03:20 -0400 (EDT)

Hi All,

Let me know if I got any English problems.

New Version 2.2.1 Released

This is bugfix release. It's highly suggested that you install this
update.

Bugfixes from 2.2.0:
- Student view of class list works again
- Bulletin boards were throwing errors in some contexts
- problem with titles with [ or ] in them would throw errors
- Course Broadcast messages re-added to 'Student Notes' screen
- SSO style authentication works more quickly and with remote control users
- conditions properly block simple pages
- randomlabel using images with spaces in the filenames can be printed
- can set an end date when creating a CC through CUSR as DC 
- can edit portfolio metadata from an access server
- group portfolio metadata can be edited
- metadata database cleanup script no longer sends spurious emails
- default Spreadsheets weren't loading into new classes
- add ability to reset the spreadsheets back to the system default
- <window> works when viewing a student's submissions
- forcing jsMath mode on in <m> works correctly in CSTR space
- some multicolumn <tables> when printed could cause LaTeX to go into an 
   infinite loop
- jsMath supports eqnarray* environments
- landscape letter mode of printing fits onto the paper better
- German translation updated
- <algebra> was removing some needed parentheses in the denominator of
   some fractions

To install this update:

1) You will need to be running Fedora Core 4 or 5, RHEL (AS|ES) 4,
   SUSE 9.3, SLES 9
     (Fedora Core 3 should continue to work but is deprecated.)

2) If running Fedora, use yum to update your machine and then install the
      LONCAPA-prerequisites (if not already installed).

yum update
yum install LONCAPA-prerequisites

    If running SUSE, use you to update your machine.
    if running RHEL, use up2date to update your machine.

3) Download the new LON-CAPA tarball from
wget http://install.lon-capa.org/versions/loncapa-2.2.1.tar.gz

and untar it

tar xzvf loncapa-2.2.1.tar.gz

4) stop the Lon-CAPA system services

/etc/rc.d/init.d/loncontrol stop

5) stop the webserver:

Fedora/Red Hat Enterprise:
/etc/rc.d/init.d/httpd stop

SUSE:
/etc/init.d/apache stop

6) Run the UPDATE script as root
cd loncapa-2.2.1
su
./UPDATE

7) restart the Lon-CAPA system services
/etc/rc.d/init.d/loncontrol start

8) restart the webserver:

Fedora/Red Hat Enterprise:
/etc/rc.d/init.d/httpd start

SUSE:
/etc/init.d/apache start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org

-- 
[email-masked]   0-7-1-6-27,137

---

From: Felicia Berryman <[email-masked]>
Date: Fri, 08 Sep 2006 17:52:25 -0400

sounds good to me

---

From: "H. K. Ng" <[email-masked]>
Date: Wed, 13 Sep 2006 15:03:33 -0400

Hi,

I like to integrate the fsu loncapa course sign up script into 
loncapa. Currently, when an instructor wants a new course he/she has 
to go to a specific link, sign in using the fsu username/password. 
The script then checks if the user is an instructor. Now that CAS is 
working, I like to integrate this and at some point have it linked from BB.

This what I thought of doing.
1. A user is login to BB.
2. User clicks on link to request for a loncapa course - the link 
points to the a script on the lib server.
3. The user is automatically authenticated by CAS.
4. The script then checks for course(s) assigned to the instructor of record.

The script will only run from the library server for security 
reasons. How do I go about integrating this into loncapa?

Thanks,
-hk