Subject: Re: [LON-CAPA-dev] PDF Forms (was: New libraries, etc - need to install for CVS Head)

From: Stefan Bisitz <[email-masked]>
Date: Fri, 03 Apr 2009 19:39:23 +0000 (GMT)

Hi Mark,

This PDF Forms LON-CAPA Add On allows students to print their problems in a special way. The PDF document is built in such a way that form fields are created where the input fields would be on the screen. Big advantage is that no internet connection, even no LON-CAPA connection, is needed to give answers to the homework problems.

Once this is done, the students send their filled in PDF documents to their instructor (e-mail, etc.). He/She is provided with an interface to upload the PDF documents to LON-CAPA. The answers will be included in the standard LON-CAPA grading process just like they have been answered online.

By the way, I have mentioned the work-in-progress of these PDF forms in my presentation at the last conference in Vancouver.

Stefan Bisitz

On 03.04.09, Mark Lucas  <[email-masked]> wrote:

> Gerd,
> 
> Out of curiosity, what does this buy us pedagogically?
> 
> Does this allow you to create a pdf form that students can fill in
> remotely? Would this be used on tests? Assignments?
> 
> Just curious from an educator point of view.
> 
> Mark
> 
> 
> On Fri, 2009-04-03 at 12:36 -0400, Gerd Kortemeyer wrote:
> > Hi,
> > 
> > This is forwarded on behalf of Thomas Onken:
> > 
> > Enable PDF-Forms in LON-CAPA
> > 
> > First you need to install the AcroTeX-education bundle from ctan.
> > 
> > Get the package and unzip it:
> > 
> >      [root@loncapa ]# wget http://tug.ctan.org/get/macros/latex/contrib/acrotex.zip (http://tug.ctan.org/get/macros/latex/contrib/acrotex.zip)
> >      [root@loncapa ]# unzip acrotex.zip
> > 
> > go into the acrotex-folder and install
> > 
> >      [root@loncapa ]# cd acrotex
> >      [root@loncapa acrotex]# latex acrotex.ins
> > 
> > Now move the folder acrotex file into the latex path. You can easly  
> > find it by searching for "cite.sty" or some other tex-packages.
> > 
> >      [root@loncapa /]# locate cite.sty
> >      /usr/share/texmf/tex/latex/cite/cite.sty
> >      /usr/share/texmf/tex/latex/cite/drftcite.sty
> >      /usr/share/texmf/tex/latex/cite/overcite.sty
> >      On CentOS5 the latex path is: /usr/share/texmf/tex/latex/
> > 
> >      [root@loncapa acrotex]# cd ..
> >      [root@loncapa ]# mv acrotex /usr/share/texmf/tex/latex/
> > 
> > Remove the acrotex.zip
> > 
> >      [root@loncapa]# rm acrotex.zip
> > 
> > After that you must rehash tex:
> > 
> >      [root@loncapa ]# texhash
> > 
> > Now you are able to print PDF with Forms (Radiobutton-, Comboboxes-,  
> > Textfield based problems).
> > 
> > The second thing to do is to enable the Upload-script lonpdfupload.pm.  
> > Before you can use it you have to install CAM::PDF for perl. It is  
> > available on CPAN so you can use the perl –MCPAN -eshell.
> > 
> >      [root@loncapa ~]# perl -MCPAN -eshell
> > 
> >      cpan shell -- CPAN exploration and modules installation (v1.7602)
> >      ReadLine support enabled
> > 
> >      cpan>install CAM::PDF
> >      (…follow installation and also install the dependencies)
> >      cpan>exit
> > 
> > Next you need to copy the upload-script from CVS to the LON-CAPA  
> > Apache folder.
> > 
> >      [root@loncapa ~]# cp [your-cvs-folder]/loncom/interface/ 
> > lonpdfupload.pm /home/httpd/lib/perl/Apache/
> > 
> > Now restart httpd:
> >      [root@loncapa ~]# /etc/init.d/httpd restart
> > _______________________________________________
> > LON-CAPA-dev mailing list
> > [email-masked]
> > http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev (http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev)
> 
> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev (http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev)
> 
>

---

From: Gerd Kortemeyer <[email-masked]>
Date: Fri, 3 Apr 2009 16:12:15 -0400

Hi,

On Apr 3, 2009, at 3:39 PM, Stefan Bisitz wrote:
>
> This PDF Forms LON-CAPA Add On allows students to print their  
> problems in a special way. The PDF document is built in such a way  
> that form fields are created where the input fields would be on the  
> screen. Big advantage is that no internet connection, even no LON- 
> CAPA connection, is needed to give answers to the homework problems.
>
> Once this is done, the students send their filled in PDF documents  
> to their instructor (e-mail, etc.). He/She is provided with an  
> interface to upload the PDF documents to LON-CAPA. The answers will  
> be included in the standard LON-CAPA grading process just like they  
> have been answered online.

Eventually, the students should be able to upload their own sheets,  
but in this first incarnation, due to security concerns, this is not  
yet a possibility.

- Gerd.