Subject: [LON-CAPA-dev] ping processes

From: Martin Siegert <[email-masked]>
Date: Tue, 7 Jan 2003 10:07:56 -0800

Hi,

I noticed a flood of ping processes hanging around on our library
server:

# ps -ef
root      9372   841  0  2002 ?        00:00:00 CROND
www       9382     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww       9383  9382  0  2002 ?        00:00:13 ping -c 1 install.lon-capa.org
root     14696   841  0  2002 ?        00:00:00 CROND
www      14706     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      14707 14706  0  2002 ?        00:00:12 ping -c 1 install.lon-capa.org
root     20636   841  0  2002 ?        00:00:00 CROND
www      20646     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      20647 20646  0  2002 ?        00:00:11 ping -c 1 install.lon-capa.org
root     28036   841  0  2002 ?        00:00:00 CROND
www      28046     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      28047 28046  0  2002 ?        00:00:11 ping -c 1 install.lon-capa.org
root      4365   841  0  2002 ?        00:00:00 CROND
www       4375     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww       4376  4375  0  2002 ?        00:00:10 ping -c 1 install.lon-capa.org
root     19637   841  0  2002 ?        00:00:00 CROND
www      19647     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      19648 19647  0  2002 ?        00:00:10 ping -c 1 install.lon-capa.org
root     25720   841  0  2002 ?        00:00:00 CROND
www      25730     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      25731 25730  0  2002 ?        00:00:09 ping -c 1 install.lon-capa.org
root     30964   841  0  2002 ?        00:00:00 CROND
www      30974     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      30975 30974  0  2002 ?        00:00:08 ping -c 1 install.lon-capa.org
root      2478   841  0  2002 ?        00:00:00 CROND
www       2488     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww       2489  2488  0  2002 ?        00:00:08 ping -c 1 install.lon-capa.org
root     10360   841  0  2002 ?        00:00:00 CROND
www      10370     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      10371 10370  0  2002 ?        00:00:06 ping -c 1 install.lon-capa.org
root     13889   841  0  2002 ?        00:00:00 CROND
www      13899     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      13900 13899  0  2002 ?        00:00:06 ping -c 1 install.lon-capa.org
root     19248   841  0  2002 ?        00:00:00 CROND
www      19258     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      19259 19258  0  2002 ?        00:00:06 ping -c 1 install.lon-capa.org
root       618   841  0  2002 ?        00:00:00 CROND
www        628     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww        629   628  0  2002 ?        00:00:05 ping -c 1 install.lon-capa.org
root      7179   841  0  2002 ?        00:00:00 CROND
www       7189     1  0  2002 ?        00:00:00 sh -c ping -c 1 install.lon-capawww       7190  7189  0  2002 ?        00:00:04 ping -c 1 install.lon-capa.org
root     12165   841  0 Jan01 ?        00:00:00 CROND
www      12175     1  0 Jan01 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      12176 12175  0 Jan01 ?        00:00:03 ping -c 1 install.lon-capa.org
root     16817   841  0 Jan02 ?        00:00:00 CROND
www      16827     1  0 Jan02 ?        00:00:00 sh -c ping -c 1 install.lon-capawww      16828 16827  0 Jan02 ?        00:00:03 ping -c 1 install.lon-capa.org
root     10879   841  0 05:10 ?        00:00:00 CROND
root     10892 10879  0 05:10 ?        00:00:00 /usr/sbin/sendmail -FCronDaemon 

I first thought that this epidemic has to do with the /etc/cron.d/loncapa
cron job. However, /usr/local/loncapa/bin/CHECKRPMS --cronmail 
calls "ping -c1 -w10 ..." which should terminate properly, whereas the
pings above were called without the -w flag and therefore hang.
Does somebody know were those pings are coming from?
(the origin of the hangs comes from the fact that the pings did not go through
the firewall - I changed this for now).

This brings me to something else: I do not want CHECKRPMS to contact
ftp servers, I want it to look in /mnt/redhat as specified in the
check-rpms.conf file. It seems that CHECKRPMS ignores the check-rpms.conf
which I find rather undesirable. Is there a simple way of changing this
(before I dive in and rewrite CHECKRPMS)?

Cheers,
Martin

========================================================================
Martin Siegert
Academic Computing Services                        phone: (604) 291-4691
Simon Fraser University                            fax:   (604) 291-4242
Burnaby, British Columbia                          email: [email-masked]
Canada  V5A 1S6
========================================================================

---

From: Scott Harrison <[email-masked]>
Date: Tue, 7 Jan 2003 13:35:37 -0500

> pings above were called without the -w flag and therefore hang.

Older versions of CHECKRPMS did not use the -w option.

> Does somebody know were those pings are coming from?

Older versions of CHECKRPMS.

> (before I dive in and rewrite CHECKRPMS)?

CHECKRPMS is meant to be a highly global solution for LON-CAPA servers,
not a highly customizable one.  Note that install.lon-capa.org provides
an updates ftp mirror of not just redhat RPMs, but now also of
LON-CAPA-systemperl (and additional LON-CAPA specific RPMs in the
future).

At present, if you do not want to use CHECKRPMS, then please just
comment out the CHECKRPMS line inside /etc/cron.d/loncapa, and use
your own methods.

That said, CHECKRPMS could use some improvement.  For instance,
yes, I do think, in the future, the command-line should allow
some customization of what servers are contacted (and also
whether or not the check-rpms.conf file is used).

Regards,
Scott

> _______________________________________________
> LON-CAPA-dev mailing list
> [email-masked]
> http://mail.lon-capa.org/mailman/listinfo/lon-capa-dev

-- 
Scott Harrison, [email-masked]