Subject: [LON-CAPA-dev] Nearly there

From: Guy Albertelli II <[email-masked]>
Date: Fri, 13 Dec 2002 18:32:35 -0500 (EST)

Hi All,

Looks good here, I plan on sending the email out to lon-capa-announce
tommorrow

Here is the current version of the email (final version of the .tar
file is going up right now. should be there in 6 minutes)

-------------
New Version 0.6 Released

-255 Defects and enhancement requests done
http://bugs.loncapa.org/buglist.cgi?bug_status=RESOLVED&resolution=FIXED&chfield=bug_status&chfieldfrom=Aug.+21&chfieldto=Dec.+12&cmdtype=doit

Notable Changes and Enhacements:
- Spreadsheet twice as fast
- Improved page design
- New version of tth, looks better, supports Mozilla and Netscape 6+
- Printing significantly better
- New 'DOCS' button supports uploading resources without being an
author
  and allows multiple toplevel maps
- System makes generating Syllabus, Bulletin Board, 'About Me'
  and other course pages simple
- New navmpas screen
- 'quickgrade' view makes it easier for student to see how much
  they have completed
- Prettier/more functional problem editor
- Randomlabel better/faster display
- More functions available to problem writers
- Better <optionreponse> control display of dropdown box and order
  randomization
- Excel spreadsheet download of internal spreadsheets, and classlists

To install this update:

1) Redhat 6.2 machines will need to delete these files and diretory if
   they exist
/usr/lib/perl5/5.00503/File/Spec   (directory - needs to go or be
   renamed)
/usr/lib/perl5/5.00503/File/Spec.pm

2) Verify that you have version 3.5 of the LON-CAPA-sytemperl rpm
   installed

$ rpm -q LON-CAPA-systemperl
LON-CAPA-systemperl-3.5-1

If it doesn't say that you will need to install it:

If you are running RedHat 6.2 get
http://install.loncapa.org/3.1/latestRPMS/LON-CAPA-systemperl-3.5-1.i386.rpm

If you are running RedHat 7.[0,1,2,3] get
http://install.loncapa.org/3.1/latestRPMS/LON-CAPA-systemperl-3.5-rh7.i386.rpm

Install it by doing:
rpm -Uvh --force LON-CAPA-systemperl-3.5-1.i386.rpm
or
rpm -Uvh --force LON-CAPA-systemperl-3.5-rh7.i386.rpm

3) You will need to have the Kerberos 5 rpms install

For Redhat 6.2:
Get and install these RPMS:
wget
ftp://ftp.redhat.com/pub/redhat/linux/updates/6.2/en/os/i386/krb5-libs-1.1.1-30.i386.rpm
wget
ftp://ftp.redhat.com/pub/redhat/linux/updates/6.2/en/os/i386/krb5-devel-1.1.1-30.i386.rpm

For Redhat 7.2:
Get and install these RPMS:
wget
ftp://ftp.redhat.com/pub/redhat/linux/updates/7.2/en/os/i386/krb5-libs-1.2.2-15.i386.rpm
wget
ftp://ftp.redhat.com/pub/redhat/linux/updates/7.2/en/os/i386/krb5-devel-1.2.2-15.i386.rpm

For Redhat 7.3:
Get and install these RPMS:
wget
ftp://ftp.redhat.com/pub/redhat/linux/updates/7.3/en/os/i386/krb5-libs-1.2.4-3.i386.rpm
wget
ftp://ftp.redhat.com/pub/redhat/linux/updates/7.3/en/os/i386/krb5-devel-1.2.4-3.i386.rpm

otherwise contact Guy at [email-masked] to get the proper rpms.

4) Download the new LON-CAPA tarball from
wget http://install.lon-capa.org/versions/loncapa-0.6.tar.gz

and untar it

tar xzvf loncapa-0.6.tar.gz

5) Run the UPDATE script as root
cd loncapa-0.6
su
./UPDATE

6) restart the system services
/etc/rc.d/init.d/loncontrol stop
/etc/rc.d/init.d/loncontrol start
/etc/rc.d/init.d/httpd stop
/etc/rc.d/init.d/httpd start

----NOTES
1) Many questions are answered at http://help.lon-capa.org
2) Defects reports, and enhancements requests can be entered at
   http://bugs.lon-capa.org
3) Mailing lists can be joined and left at http://mail.lon-capa.org
4) We will be withdrawing support for RedHat 6.2 in the next release
   please update your systems to RedHat 7.3

-- 
[email-masked]          BM: n^20 t20 z20 qS 
Guy Albertelli -7-7-7-  O-
    Today I will rely on the language of love and understanding. 
    If that doesn't work, I'll go back to intimidation and fear.

---

From: Scott Harrison <[email-masked]>
Date: Sat, 14 Dec 2002 13:27:23 -0500

Hi All:

> 2) Verify that you have version 3.5 of the LON-CAPA-sytemperl rpm

I have placed LON-CAPA-systemperl-*.rpm on the install.lon-capa.org ftpmirror
so that when users receive their CHECKRPMS cronmail, they will see:

THIS SCRIPT IS NOW PROBING SEVERAL FTP SERVERS....
PLEASE BE PATIENT, THIS MAY TAKE A FEW MINUTES.
Trying install.lon-capa.org...
ftpmirror:[email-masked] found...
perl /usr/local/CHECKRPMS/bin/check-rpms  --rpmuser www -ftp ftpmirror:lonnstall.lon-capa.org/pub/redhat/linux/updates/7.3/en/os
**** WARNING **** You need to update at least 1 RPMS shown in
the list below.  THIS IS IMPORTANT FOR SECURITY.

LON-CAPA-systemperl-3.5-rh7.i386.rpm

Please visit ftp://ftpmirror:[email-masked]/pub/redhat/linuxes/7.3/en/os
and download the RPMS you need.
For instructions on working with (and upgrading) RPMS, please
visit http://www.rpm.org/max-rpm/.
To automatically download these RPMs to /tmp/loncapa_rpm_updates/,
run the CHECKRPMS_custom command as "./CHECKRPMS_custom --download"

Regards,
Scott

---

From: Scott Harrison <[email-masked]>
Date: Sat, 14 Dec 2002 13:45:46 -0500

Hi Guy:

Some small suggestions (note that the /home/loninst/public_html/3.1/
directory is almost completely deprecated).
(Also, note that I have updated install.lon-capa.org web-site
to conform with the 3.5 release of systemperl.)

> If it doesn't say that you will need to install it:

**** FIX **** (grammatical)
Perhaps...
"If 'rpm -q LON-CAPA-systemperl' does not show you to have systemperl
 version 3.5-1", then you will need to install it"

**** FIX **** (might point at website)
Then visit instructions at:
http://install.lon-capa.org/docs/downloads/index.html#resources

> http://install.loncapa.org/3.1/latestRPMS/LON-CAPA-systemperl-3.5-1.i386.rpm
**** FIX ****  Should be
http://install.loncapa.org/resources/LON-CAPA-systemperl-3.5-1.i386.rpm

> http://install.loncapa.org/resources/LON-CAPA-systemperl-3.5-rh7.i386.rpm
**** FIX ****  Should be
http://install.loncapa.org/resources/LON-CAPA-systemperl-3.5-rh7.i386.rpm

>    please update your systems to RedHat 7.3
Yes!

Regards,
Scott