[LON-CAPA-admin] problem with dependencies in centos/sl 7

Stuart Raeburn raeburn at msu.edu
Mon Aug 29 18:14:01 EDT 2016

Hi Eduardo,

>  I noted yum stopped updating our loncapa server.

That would have happened when you added epel.repo to the enabled  
repositories on your Scientific Linux 7 server.

The maxima-runtime-sbcl package included in the CentOS/Scientific/RHEL  
repos for LON-CAPA was built against sbcl-1.0.38-3.el6, because the  
EPEL repo for 7Server was not available at that time CentOS 7 was  
originally released (July 2014), at which time LON-CAPA also began  
being supported on that distro.

Anyway, I have updated the maxima-runtime-sbcl package in the LON-CAPA  
Scientific Linux 7 repo at install.loncapa.org with a new rpm built  
against the updated sbcl (sbcl-1.2.8-1.el7) available from the EPEL  
7Server repo for CentOS/Scientific/RHEL 7.

If you do:

yum clean all
yum update

you'll retrieve version 5.30.0-4 of both maxima and the sbcl runtime  
for maxima, as well as version 1.2.8-1 of sbcl.

Restart the LON-CAPA daemons, and the web server after the update:

/etc/init.d/loncontrol restart
/bin/systemctl restart  httpd.service

I would also recommend including the line:


in /etc/yum.repos.d/epel.repo

because although the EPEL 6Server repo includes maxima, that is no  
longer the case for EPEL 7Server, so if the version of sbcl is updated  
in the EPEL 7Server repo in the future you'll encounter the same issue  
with a dependency from the maxima runtime, unless you've added that  
exclude line.

Stuart Raeburn
LON-CAPA Academic Consortium

Quoting Juan Eduardo Ramirez <eduardo at charma.uprm.edu>:

> Hi,
>  I noted yum stopped updating our loncapa server. Checking closer, I
> found that  maxima-runtime-sbcl has the wrong dependence (See below)
> holding other packages updates. The problem is sbcl can not be upgraded
> to epel version 1.2.8-1.el7 because maxima-runtime is asking for a
> given version from previous os (el6).
> Could this be fixed, to let automatic security updates work again?
> Thanks,
> Eduardo
> ##from yum-daily.cron output###
> Failed to check for updates with the following error message:
> Failed to build transaction:
> maxima-runtime-sbcl-5.30.0-3.scientific.lc.x86_64 requires sbcl =
> 1.0.38-3.el6

More information about the LON-CAPA-admin mailing list