[LON-CAPA-admin] Parts/grades not showing up on published problems

Jon Hall jdh65 at bellsouth.net
Tue Aug 7 23:08:00 EDT 2012


After several years away from using LC, I am back to it and have set up a new server at my new school.

I set the server up at home over the weekend and published some problems and all is well with those problems.

In the Course Contents, the multipart problems show up as being multipart problems.  They work properly and grades are viewable.

Since all seemed to be well at home, I brought the machine to school and after some wailing and gnashing of teeth, I managed to get it up and running on our school network.  Or so I thought.

Multipart problems published after the move do not show up as multipart problems.  They appear as only a single part both in the Course Contents listing and from any Parameter settings perspective.  The worst part about it is the grading does not seem to be accessible from any reasonable method.  They do appear to work correctly from a student perspective, however.  I'm pretty sure the submissions are being recorded and graded however, because if I look at a student's activity there is evidence of their work.  E.g. 

119	/adm/flip		Tue Aug 7 02:24:47 pm 2012 (CDT)	VIEW	
120	laws_19_20.problem	Tue Aug 7 02:24:35 pm 2012 (CDT)	CSTORE	
	host	=	jp2l1
	ip	=
	resource.13.14.awarddetail	=	INCORRECT
	resource.13.14.submission	=	foil4=4
	resource.13.award	=	INCORRECT
	resource.13.awarded	=	0
	resource.13.solved	=	incorrect_attempted
	resource.13.tries	=	1
121	laws_19_20.problem	Tue Aug 7 02:24:34 pm 2012 (CDT)	POST	
	HWVAL_12	=	0
	HWVAL_14	=	4
	submit_13	=	Submit Answer
	submitted	=	part_13
	symb	=	uploaded/jp2/6s35441789e1d5035jp2l1/default_1344227740.sequence___11___jp2/jonhall/lawson/laws_19_20.problem
122	laws_19_20.problem	Tue Aug 7 02:24:28 pm 2012 (CDT)	POST	
	HWVAL_12	=	0
	submit_11	=	Submit Answer
	submitted	=	part_11
	symb	=	uploaded/jp2/6s35441789e1d5035jp2l1/default_1344227740.sequence___11___jp2/jonhall/lawson/laws_19_20.problem
123	laws_19_20.problem	Tue Aug 7 02:24:28 pm 2012 (CDT)	CSTORE	
	host	=	jp2l1
	ip	=
	resource.11.12.awarddetail	=	EXACT_ANS
	resource.11.12.submission	=	foil0=0
	resource.11.award	=	EXACT_ANS
	resource.11.awarded	=	1
	resource.11.solved	=	correct_by_student
	resource.11.tries	=	1
124	laws_19_20.png	Tue Aug 7 02:21:27 pm 2012 (CDT)	VIEW	
125	/adm/flip	Tue Aug 7 02:21:26 pm 2012 (CDT)	VIEW	
126	laws_19_20.problem	Tue Aug 7 02:21:26 pm 2012 (CDT)	POST	
	symb	=	uploaded/jp2/6s35441789e1d5035jp2l1/default_1344227740.sequence___11___jp2/jonhall/lawson/laws_19_20.problem

If I look at the Grading Page for the same kid, same problem, this is what I see:

9 (0 parts)	
View of the problem
500 Can't connect to physics.jp2hs.org:80 (Bad hostname 'physics.jp2hs.org')

Correct answer
500 Can't connect to physics.jp2hs.org:80 (Bad hostname 'physics.jp2hs.org')

History			host	ip			Part 11.12 awarddetail 	Part 11.12 submission 	Part 11 award 	Part 11 awarded 	Part 11 solved 		Part 11 tries 	Part 13.14 awarddetail 	Part 13.14 submission 	Part 13 award 	Part 13 awarded 	Part 13 solved 			Part 13 tries 	timestamp
Transaction 1	jp2l1 	EXACT_ANS 				foil0=0 				EXACT_ANS 		1 					correct_by_student 	1 	 	 	 	 	 	 																													Tue Aug 7 02:24:28 pm 2012 (CDT) 
Transaction 2	jp2l1 	 	 	 	 	 	 																									INCORRECT 				foil4=4 				INCORRECT 		0 					incorrect_attempted 	1 				Tue Aug 7 02:24:35 pm 2012 (CDT) 
Current			jp2l1 	EXACT_ANS 				foil0=0 				EXACT_ANS 		1 					correct_by_student 	1 				INCORRECT 				foil4=4 				INCORRECT 		0 					incorrect_attempted 	1 				Tue Aug 7 02:24:35 pm 2012 (CDT) 

Part	Points	 	Assign Grade	Weight	Grade Status

So the data is there, but I can't seem to get at it easily.

The source for the question is:

<part id="11">
<startouttext />
Suppose you are given two clay balls of equal size and shape.  The two clay balls also weigh the same.  One ball is flattened into a pancake-shaped piece.  <i>Which of these statements is correct?</i>
<endouttext />
<radiobuttonresponse direction="vertical" max="10" id="12" randomize="no">
      <foil value="false" name="foil0"><startouttext />The pancake-shaped piece weighs more than the ball<endouttext /></foil>
      <foil value="true" name="foil1"><startouttext />The two pieces still weigh the same<endouttext /></foil>
      <foil value="false" name="foil2"><startouttext />The ball weighs more than the pancake-shaped piece<endouttext /></foil>
<part id="13">
<startouttext /><i>because</i><endouttext />
<radiobuttonresponse direction="vertical" max="10" id="14" randomize="no">
      <foil value="false" name="foil0"><startouttext />the flattened piece covers a larger area.<endouttext /></foil>
      <foil value="false" name="foil1"><startouttext />the ball pushes down more on one spot.<endouttext /></foil>
      <foil value="false" name="foil2"><startouttext />when something is flattened it loses weight.<endouttext /></foil>
      <foil value="true" name="foil3"><startouttext />clay has not been added or taken away.<endouttext /></foil>
      <foil value="false" name="foil4"><startouttext />when something is flattened it gains weight.<endouttext /></foil>

If I go back to the published problem and do a clean-up or try to re-publish, I get 500 Error and 80 Warning.  But no further information about what those might be.

I don't actually think the problem is with the questions, but rather with something about how I set up the network.  It all seems to work fine, but obviously something I configured was not correct.  

If anyone has any ideas, I would be very appreciative.


Best Regards,
Jon Hall

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.lon-capa.org/pipermail/lon-capa-admin/attachments/20120807/8d74159e/attachment.html>

More information about the LON-CAPA-admin mailing list